Web server permission problems

Place to discuss Fedora and/or Red Hat
Post Reply
Buzza24
scripter
scripter
Posts: 59
Joined: Fri Mar 14, 2003 2:01 am
Contact:

Web server permission problems

Post by Buzza24 » Sun Apr 25, 2004 7:11 pm

Hey Peoples,

Well i don't think this is the first or last time I asked for help about my webserver on this forum.
My problem is that there are four users on the server (buzza, tom, killruff, thex) and i am buzza obviously. I seem to be the only one able to be displayed off the server.

Doogee helped me out by having

Code: Select all

 UserDir enable tom buzza 
but then I discovered that this didn't work. it was only me being displayed and everyone else was "forbidden". If it helps i am running Apache 2 on Red hat 9. All users have a directory called "public_html" and in it a HTML file called index.html.

What am I doing wrong?

Any help would be great!

Thanks & God Bless,
Buzza

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Re: Web server permission problems

Post by Void Main » Sun Apr 25, 2004 7:53 pm

Buzza24 wrote:Hey Peoples,

Well i don't think this is the first or last time I asked for help about my webserver on this forum.
My problem is that there are four users on the server (buzza, tom, killruff, thex) and i am buzza obviously. I seem to be the only one able to be displayed off the server.

Doogee helped me out by having

Code: Select all

 UserDir enable tom buzza 
but then I discovered that this didn't work. it was only me being displayed and everyone else was "forbidden". If it helps i am running Apache 2 on Red hat 9. All users have a directory called "public_html" and in it a HTML file called index.html.

What am I doing wrong?

Any help would be great!

Thanks & God Bless,
Buzza
You only show you and tom in your "UserDir" statement above, do you also have the other two users in there in your config? Usually what this means is the permissions on your directories leading up to the index.html are open enough for the apache user to be able to read your index.html files. I would be willing to bet that it is your user home directories themselves that are too closed up. You have a couple of options, you can set the directories with 755 permissions or you can change the group on the directories to "apache" and set the permissions to 750.

# cd /home
# chmod 755 tom killruff thex tom/public_html killruff/public_html thex/public_html

Buzza24
scripter
scripter
Posts: 59
Joined: Fri Mar 14, 2003 2:01 am
Contact:

Post by Buzza24 » Sun Apr 25, 2004 8:40 pm

That worked! You won your bet.
My directories were too closed up. I entered the command you gave me and now it works. Just quickly, would there be any "side effects" such as surcuity issues now that I have changed those permission?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Apr 25, 2004 8:45 pm

Any user on your system can read the contents of the directories you changed permissios on the way it is. They can't write, just read. You could have just turned the execute bit on for world which also would have been enough and then they other users would have been able to change directory into the other user's directories but would not be able to do an "ls" or any other read type of command. That would have been:

$ cd /home
$ chmod 751 user1 user2 user3

Of course if you don't want any other user in those directories then you could have used groups and group permissions (and make sure either "apache" is the group, or the "apache" user is in the group that you use).

Post Reply