fam rears it's ugly head again!!!!

Place to discuss Fedora and/or Red Hat
Post Reply
Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

fam rears it's ugly head again!!!!

Post by Ice9 » Sun Feb 20, 2005 4:58 pm

A couple of days ago I installed FC3 on my wife's pc, I wanted to tinker a little more with it but I didn't want to replace Debian on my box or even dual-boot so I put it on her pc :D
Everything went very smoothly, the usual customisation chores but she was running in no time.

Now before I move any further I have to clarify something.
My wife is VERY critical about linux, she loved the "user friendlyness" of Windows and she doesn't like the fact that there are some things she has to do differently.
So when she tried to unmount her external USB drive and got the "device is busy" error she complained quite heavily!
A little digging gave me

Code: Select all

[root@localhost media]# fuser /media/MEDIADRIVE
/media/MEDIADRIVE:    5248
[root@localhost media]# ps 5248
  PID TTY      STAT   TIME COMMAND
 5248 ?        S      0:00 /usr/libexec/gam_server
A little more digging told me that gam_server replaced the infamous sgi_fam, so I started to look for a service calle gam_server, or gamin or anything that looked remotely like that with chkconfig --list and couldn't find anything.

Could it be that this new flavor of a file alteration monitor cannot be disabled?
I tried to apt)get remove gamin gamin-devel but apt wants to remove like half of the system ...

Any ideas?
I'll keep looking in the meantime and keep you updated if I find anything interesting.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Feb 20, 2005 6:42 pm

The problem looks very similar to problems in previous versions:
https://bugzilla.redhat.com/bugzilla/sh ... ?id=128905

Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

Post by Ice9 » Mon Feb 21, 2005 4:38 am

Yes it definitely does.
And I still haven't found a way to disable the darn thing.

What's more, yesterday I couldn't kill the PID either.
Every time I killed the process blocking my mount point another process was spawned.

This bug has been present since RH8 (and possibly even before), one would think that such an annoying "feature" would have been fixed by now!!!!!!!!!!

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Mon Feb 21, 2005 8:07 am

Funnily enough I had this problem yesterday with my iRiver iHP140 and was thinking of asking about it.
I just did a kill -3 on the process, but thats me all over.
Tell me if you find a more elegant fix :)

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Thu Apr 14, 2005 3:53 pm

two problems on my FC3 install -

1)
since installing 2.6.11-1.14 the gam_server usage on my machine made it
nearly unworkable.... the mouse pointer was jerky.... everything was slow
and the gam_server was eating up the cpu..

Currently on gamin 0.0.25-1
After counteless searches on what to do, how to switch it off etc..
I went ahead and renamed usr/libexec/gam_server so that nothing can
find it.
So far I've had no problems except for warnings about not being able to
find gam_server - my cpu is idle, I can work, and until I hit a real
brickwall or an upgrade that works, I'll leave it as is.

2)
While trying to solve the above - i did a "grep -irl gam_server *"
in the /etc directory - when boom :shock: - my machine froze,
no messages, no logs, nothing??
rebooted - did the same from the command line and :x it happened
again and again while trying to figure out what cooks.
Using knoppix I renamed my /etc directory, created a new one and
copied everything back (thinking there is a bad patch on the disk)
This time doing the grep, at least I got a message...
nvidia: module licence "NVIDIA" tainted kernel.
Kernel panic - not synciing: arch/i386/kernel/semaphore:64: spin_is_locked on uninitialized spinlock e141f130. (Tainted: P )

Now what in the blazes is this all about?
Current the nvidia 7167 drivers installed!

Cannot find anything with google - and those that look promising
are in languages I cannot read - never mind understand..

Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

Post by Ice9 » Fri Apr 15, 2005 3:29 pm

This is not reallly useful to you but I've given up on trying to disable gam_server.
I've read a fair share about it and I think I remember reading stuff about automatic respawning of the process and things like that.
Anyway you can't switch it off just like sgi_fam and when you kill it another process spawns, it looked so hopeless that I learned my wife to live with it and I arranged for her to never have to manually mount/unmount drives.

No real solution I know but it's the best I could come up with :?

Membrax
scripter
scripter
Posts: 99
Joined: Tue Oct 21, 2003 2:04 pm
Location: 50'48''N - 4'21''E
Contact:

Post by Membrax » Mon May 09, 2005 9:12 am

Well, Ice9, as long as you don't know by heart where the spawn points are you'll still be beaten by PID.

Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

Post by Ice9 » Mon May 09, 2005 1:43 pm

If I remember correctly you ate a lot more rockets on spawn point than I did :P

Post Reply