apt not cooperating

Place to discuss Fedora and/or Red Hat
worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

apt not cooperating

Post by worker201 » Tue Jun 28, 2005 12:39 pm

I'm having some troubles with apt. It doesn't seem to want to work. Synaptic works, kinda - all it will do is give you a list of the packages installed. I think my sources are messed up or something. Anyway, I ran "apt-get install mjpegtools", and it couldn't find it. Then I tried "apt-get install libquicktime", and it couldn't find that either. Fortunately, I have figured out how to go to Freshrpms and find all the rpms I could ever want.

So what's the deal? How do I get this thing to work?

I mean, I like synaptic - it was very handy. I don't need an rpm finder/manager, because I can do it myself. In fact, I can build anything from source, I don't even need rpms. But they're convenient. So I would like to get this working.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 28, 2005 2:16 pm

Can you post the output of the following commands?

# rpm -q apt
# apt-get update
# apt-get dist-upgrade

Also, you might want to look over my apt/synaptic tip (even though it's not up to date) just so you can get an idea of how things work:

http://voidmain.is-a-geek.net/redhat/fe ... _have.html

The main differences is that instead of using apt from FreshRPMS, use the one from Dag's site, and instead of editing /etc/apt/sources.list for your repositories it would be these files: /etc/apt/sources.list.d/*.list

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Jun 28, 2005 3:33 pm

Turns out my sources files were fouled up. Since I was going to be copying and pasting, I used "gedit dag.list" from the command line. For some reason, this removed dag.list and created dag.list.rpmnew and dag.list.rpmsave. The result was that Dag's repo could not be found. I only used gedit to save some time and effort. Once I got this sorted out, I used vi instead, like I usually do.

So, now apt and synaptic work okay. Kinda strange, though, that some of the package upgrades now have unresolvable dependencies. Like gaim and Abiword, 2 of my favorites. Hopefully that will get sorted out soon.

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Jun 28, 2005 3:42 pm

Shoot, I spoke too soon. Seems to be a GPG signature problem. Is there a way to override this? The files are downloaded, but apt won't install them.

Code: Select all

[root@holcombe2 sources.list.d]# rpm -q apt
apt-0.5.15cnc7-6.fc4

[root@holcombe2 sources.list.d]# apt-get update
Get:1 http://newrpms.sunsite.dk redhat/en/i386/fc3 release [496B]
Get:2 http://ayo.freshrpms.net fedora/linux/4/i386 release [1836B]
Get:3 http://apt.sw.be fedora/4/en/i386 release [474B]
Get:4 http://ayo.freshrpms.net fedora/linux/3/i386 release [2133B]
Get:5 http://apt.sw.be dries/fedora/fc3/i386 release [485B]
Err http://ayo.freshrpms.net fedora/linux/4/i386 release
  no signatures in file /var/state/apt/lists/partial/ayo.freshrpms.net_fedora_linux_4_i386_base_release
Fetched 5424B in 0s (6617B/s)
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/core release
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates pkglist
Hit http://ayo.freshrpms.net fedora/linux/3/i386/updates release
Hit http://apt.sw.be fedora/4/en/i386/dag pkglist
Hit http://apt.sw.be fedora/4/en/i386/dag release
Hit http://apt.sw.be dries/fedora/fc3/i386/dries pkglist
Hit http://apt.sw.be dries/fedora/fc3/i386/dries release
Hit http://newrpms.sunsite.dk redhat/en/i386/fc3/newrpms pkglist
Hit http://newrpms.sunsite.dk redhat/en/i386/fc3/newrpms release
Failed to fetch http://ayo.freshrpms.net/fedora/linux/4/i386/base/release  no signatures in file /var/state/apt/lists/partial/ayo.freshrpms.net_fedora_linux_4_i386_base_release
Reading Package Lists... Done
Building Dependency Tree... Done
W: Release files for some repositories could not be retrieved or authenticated. Such repositories are being ignored.
W: You may want to run apt-get update to correct these problems
E: Some index files failed to download, they have been ignored, or old ones used instead.

[root@holcombe2 sources.list.d]# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded
   ImageMagick (6.2.2.0-2 => 6.2.2.0-2.fc3)
   ImageMagick-devel (6.2.2.0-2 => 6.2.2.0-2.fc3)
   a52dec (0.7.4-7.1.fc3.rf => 0.7.4-7.2.fc4.rf)
   a52dec-devel (0.7.4-7.1.fc3.rf => 0.7.4-7.2.fc4.rf)
   caca-utils (0.9-4.1.fc3.rf => 0.9-4.2.fc4.rf)
   faac (1.24-1.1.fc3.rf => 1.24-1.2.fc4.rf)
   faac-devel (1.24-1.1.fc3.rf => 1.24-1.2.fc4.rf)
   fftw (2.1.5-4.1.fc3.rf => 2.1.5-4.2.fc4.rf)
   fftw-devel (2.1.5-4.1.fc3.rf => 2.1.5-4.2.fc4.rf)
   gamin (0.1.0-1.1 => 0.1.1-1.FC3)
   id3lib (3.8.3-7.1.fc3.rf => 3.8.3-7.2.fc4.rf)
   imlib2 (1.2.0-1.1.fc3.rf => 1.2.0-1.2.fc4.rf)
   imlib2-devel (1.2.0-1.1.fc3.rf => 1.2.0-1.2.fc4.rf)
   lame (3.96.1-2.1.fc3.rf => 3.96.1-2.2.fc4.rf)
   lame-devel (3.96.1-2.1.fc3.rf => 3.96.1-2.2.fc4.rf)
   libXvMCW (0.9.3-1.1.fc3.rf => 0.9.3-1.2.fc4.rf)
   libdv099 (0.99-1.1.fc3.rf => 0.99-1.2.fc4.rf)
   libdvbpsi (0.1.4-1.1.fc3.rf => 0.1.4-1.2.fc4.rf)
   libdvdcss (1.2.8-4.1.fc3.rf => 1.2.8-4.2.fc4.rf)
   libdvdcss-devel (1.2.8-4.1.fc3.rf => 1.2.8-4.2.fc4.rf)
   libdvdnav (0.1.10-2.1.fc3.rf => 0.1.10-2.2.fc4.rf)
   libdvdnav-devel (0.1.10-2.1.fc3.rf => 0.1.10-2.2.fc4.rf)
   libdvdplay (1.0.1-4.1.fc3.rf => 1.0.1-4.2.fc4.rf)
   libdvdplay-devel (1.0.1-4.1.fc3.rf => 1.0.1-4.2.fc4.rf)
   libdvdread (0.9.4-7.1.fc3 => 0.9.4-7.2.fc4.rf)
   libdvdread-devel (0.9.4-7.1.fc3 => 0.9.4-7.2.fc4.rf)
   libfame (0.9.1-7.1.fc3.rf => 0.9.1-7.2.fc4.rf)
   libfame-devel (0.9.1-7.1.fc3.rf => 0.9.1-7.2.fc4.rf)
   libgc (6.2-0.1.fc3.rf => 6.2-0.2.fc4.rf)
   libid3tag (0.15.1b-3.1.fc3.rf => 0.15.1b-3.2.fc4.rf)
   libmad (0.15.1b-3.1.fc3.rf => 0.15.1b-3.2.fc4.rf)
   libmad-devel (0.15.1b-3.1.fc3.rf => 0.15.1b-3.2.fc4.rf)
   libmodplug (0.7-1.1.fc3.rf => 0.7-1.2.fc4.rf)
   libmpeg3 (1.5.4-3.1.fc3.rf => 1.5.4-4.2.fc4.rf)
   libmusepack (1.1.1-1.1.fc3 => 1.1.1-1.2.fc4.rf)
   libmusepack-devel (1.1.1-1.1.fc3 => 1.1.1-1.2.fc4.rf)
   libpixman (0.1.2-1.1.fc3.rf => 0.1.2-1.2.fc4.rf)
   libsamplerate (0.1.2-1.1.fc3.rf => 0.1.2-1.2.fc4.rf)
   libsndfile (1.0.11-1.1.fc3.rf => 1.0.11-1.2.fc4.rf)
   libuninameslist (0.20030713-0.1.fc3.rf => 0.20030713-0.2.fc4.rf)
   netpbm (10.27-3 => 10.27-4.FC3)
   netpbm-progs (10.27-3 => 10.27-4.FC3)
   perl-GD (2.16-1.1.fc3.rf => 2.16-1.2.fc4.rf)
   perl-SVG (2.28-1.1.fc3.rf => 2.28-1.2.fc4.rf)
   perl-SVG-GD (0.07-1.1.fc3.rf => 0.07-1.2.fc4.rf)
   perl-libintl (1.11-2.1.fc3.rf => 1.11-2.2.fc4.rf)
   xvidcore (1.0.3-1.1.fc3.rf => 1.0.3-1.2.fc4.rf)
   xvidcore-devel (1.0.3-1.1.fc3.rf => 1.0.3-1.2.fc4.rf)
The following NEW packages will be installed:
   kbd (1.12-2)
   setserial (2.17-17)
The following packages have been kept back
   gaim (1.3.0-1.fc4 => 1.3.1-0.fc3)
48 upgraded, 2 newly installed, 0 removed and 1 not upgraded.
Need to get 0B/17.6MB of archives.
After unpacking 5286kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Checking GPG signatures...  ########################################### [100%]
E: Unknown signature /var/cache/apt/archives/a52dec_0.7.4-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/faac_1.24-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/fftw_2.1.5-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/id3lib_3.8.3-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/imlib2_1.2.0-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/lame_3.96.1-2.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdv099_0.99-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvbpsi_0.1.4-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdcss_1.2.8-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdnav_0.1.10-2.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdread_0.9.4-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdplay_1.0.1-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libfame_0.9.1-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libgc_1%3a6.2-0.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libid3tag_0.15.1b-3.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmad_0.15.1b-3.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmodplug_0.7-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmpeg3_1.5.4-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmusepack_1.1.1-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libpixman_0.1.2-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libsndfile_1.0.11-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libsamplerate_0.1.2-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libuninameslist_0.20030713-0.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/xvidcore_1.0.3-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/a52dec-devel_0.7.4-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/caca-utils_0.9-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/faac-devel_1.24-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/fftw-devel_2.1.5-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/imlib2-devel_1.2.0-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/lame-devel_3.96.1-2.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libXvMCW_0.9.3-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdcss-devel_1.2.8-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdread-devel_0.9.4-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdnav-devel_0.1.10-2.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libdvdplay-devel_1.0.1-4.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libfame-devel_0.9.1-7.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmad-devel_0.15.1b-3.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/libmusepack-devel_1.1.1-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/perl-GD_2.16-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/perl-SVG-GD_0.07-1.2.fc4.rf_noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/perl-SVG_2.28-1.2.fc4.rf_noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/perl-libintl_1.11-2.2.fc4.rf_noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Unknown signature /var/cache/apt/archives/xvidcore-devel_1.0.3-1.2.fc4.rf_i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#6b8d79e6)
E: Error(s) while checking package signatures:
0 unsigned package(s)
43 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
E: Handler silently failed

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Tue Jun 28, 2005 6:14 pm


User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 28, 2005 6:38 pm

You are not running Dag's apt like I suggested. Do this:

Code: Select all

# rpm -e synaptic apt
# mv /etc/apt /etc/apt.old
# rpm -Uvh http://dag.wieers.com/packages/apt/apt-devel-0.5.15cnc6-4.2.fc4.rf.i386.rpm
# apt-get update
# apt-get dist-upgrade
# apt-get install synaptic
For the record, I run Dag's apt on around 20 desktops and servers running FC3 and FC4 (about half/half) with absolutely no problems. Come to think of it I also run it on some FC1, ES3, AS3 and AS4 servers with no problems. I would also suggest you browse over Dag's Installation/FAQ documentation:
http://dag.wieers.com/home-made/apt/

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Jun 28, 2005 7:02 pm

Okay, there was an unknown error in the rpm via http command, but I managed to download and install apt and apt-devel manually. The dist-upgrade is running now.

So, I've got dag rolling. But why dag? What's wrong with freshrpms?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 28, 2005 7:09 pm

Nothing wrong with FreshRPMS, in fact it's included with Dag's apt. Dag, FreshRPMS, PlanetCCRMA, and Dries are all in it together in something called RPMForge. It's all on that page I linked to:

http://dag.wieers.com/home-made/apt/

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Jun 28, 2005 7:24 pm

After installing 152 packages, the dist-upgrade is complete. But now comes the sadness.
[root@holcombe2 sources.list.d]# apt-get install synaptic
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
synaptic: Depends: libapt-pkg-libc6.3-6.so.2 but it is not installable
E: Broken packages
Does this mean that I have an error? Or does it mean that I have to wait a while for synaptic to be updated?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 28, 2005 7:30 pm

Did you remove synaptic like I suggested in the previous note? Which version do you have installed?

# rpm -q synaptic

If it's not "synaptic-0.55.3-1.rf" do this:

# rpm -e synaptic
# apt-get install synaptic

EDIT: I'm an idiot. I forgot that Synaptic hasn't been built for FC4 yet. I built my own from the SRPM. You can do the same or you can add my repository to your sources.list.d directory and then install synaptic with apt.

Add this file to your /etc/apt/sources.list.d directory:
http://voidmain.is-a-geek.net/files/RPMS/void.list

Then:
# apt-get update
# apt-get install synaptic

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Jun 28, 2005 8:14 pm

It doesn't seem to like that. I added your list, and did the update, verifying that Void's repo was added. But I still get the same error message. Probably some kind of conflict between your package and the incompatible package.

Oh, and no version of synaptic is currently installed.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 28, 2005 8:23 pm

I just installed synaptic from my repository. I don't have that version of libapt installed and don't get that message. It acts like you still have the wrong apt package installed. Do you have "apt-0.5.15cnc6-4.2.fc4.rf" installed?

Can I see the full output again of this:

# rpm -q apt
# rpm -V apt
# apt-get update
# apt-get install synaptic

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Wed Jun 29, 2005 1:27 pm

[lholcombe@holcombe2 ~]$ rpm -q apt
apt-0.5.15cnc6-4.2.fc4.rf
[lholcombe@holcombe2 ~]$ rpm -V apt
..?..... c /etc/apt/preferences
missing c /etc/apt/sources.list.d/newrpms.list
..?..... c /etc/apt/vendors.list
[lholcombe@holcombe2 ~]$ su
Password:
[root@holcombe2 lholcombe]# apt-get update
Get:1 http://voidmain.is-a-geek.net apt/fedora/4/en/i386 release [503B]
Get:2 http://ayo.freshrpms.net fedora/linux/4/i386 release [1836B]
Get:3 http://apt.sw.be fedora/4/en/i386 release [474B]
Get:4 http://apt.sw.be dries/fedora/fc4/i386 release [486B]
Fetched 3299B in 0s (4354B/s)
Hit http://ayo.freshrpms.net fedora/linux/4/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net fedora/linux/4/i386/freshrpms release
Hit http://ayo.freshrpms.net fedora/linux/4/i386/core pkglist
Hit http://ayo.freshrpms.net fedora/linux/4/i386/core release
Get:1 http://ayo.freshrpms.net fedora/linux/4/i386/updates pkglist [406kB]
Hit http://apt.sw.be fedora/4/en/i386/dag pkglist
Hit http://apt.sw.be fedora/4/en/i386/dag release
Get:2 http://apt.sw.be dries/fedora/fc4/i386/dries pkglist [481kB]
Hit http://voidmain.is-a-geek.net apt/fedora/4/en/i386/voidmain pkglist
Hit http://voidmain.is-a-geek.net apt/fedora/4/en/i386/voidmain release
Hit http://voidmain.is-a-geek.net apt/fedora/4/en/i386/voidmain srclist
Hit http://ayo.freshrpms.net fedora/linux/4/i386/updates release
Hit http://apt.sw.be dries/fedora/fc4/i386/dries release
Fetched 887kB in 4s (187kB/s)
Reading Package Lists... Done
Building Dependency Tree... Done
[root@holcombe2 lholcombe]# apt-get install synaptic
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
synaptic: Depends: libapt-pkg-libc6.3-6.so.2 but it is not installable
E: Broken packages
The output from "rpm -V apt" looks very suspicious...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Jun 29, 2005 2:16 pm

Dang, I can't see where it tried to grab synaptic from, must be in cache. Can you do this:

# apt-get clean
# apt-get install synaptic

And take note of where it's trying to grab synaptic from? It acts like it's getting another version from somewhere.

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Wed Jun 29, 2005 2:28 pm

[lholcombe@holcombe2 ~]$ su
Password:
[root@holcombe2 lholcombe]# apt-get clean
[root@holcombe2 lholcombe]# apt-get install synaptic
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
synaptic: Depends: libapt-pkg-libc6.3-6.so.2 but it is not installable
E: Broken packages
That's all there is. No info on where it comes from.

Post Reply