PAM Madness

Place to discuss Fedora and/or Red Hat
Post Reply
Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

PAM Madness

Post by Tux » Mon Jul 18, 2005 6:18 pm

I get all this, logging into te first virtual teminal.
Odd.

audit(1121731997.385:0): user pid=2730 uid=0 length=100 msg='PAM authentication: user=tux exe=/bin/login (hostname=?, addr=?, terminal=tty1 result=Success)'
audit(1121731997.386:0): user pid=2730 uid=0 length=96 msg='PAM accounting: user=tux exe=/bin/login (hostname=?, addr=?, terminal=tty1 result=Success)'
audit(1121731997.435:0): user pid=2730 uid=0 length=96 msg='PAM session open: user=tux exe=/bin/login (hostname=?, addr=?, terminal=tty1 result=Success)'
audit(1121731997.443:0): user pid=2730 uid=0 length=92 msg='PAM setcred: user=tux exe=/bin/login (hostname=?, addr=?, terminal=tty1 result=Success)'

Got a clue?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Jul 18, 2005 9:20 pm

I just noticed this for the first time after upgrading my old laptop to FC4 and updating it. I think it started when I disabled the audit daemon. I haven't verified it but did you turn off auditd?

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Tue Jul 19, 2005 5:30 am

[root@mithrandir ~]# service audit status
audit: unrecognized service
[root@mithrandir ~]# service auditd status
auditd: unrecognized service


and the version is audit-libs-0.9.15-1.FC4

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jul 19, 2005 8:35 am


User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Jul 20, 2005 8:51 am

Did you happen to upgrade your kernel lately? On the old laptop that I got those messages on I installed the latest kernel (2.6.12-1.1398_FC4) and I don't have that one on any other machine yet. It was the first time I had saw messages like that.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Wed Jul 20, 2005 4:50 pm

Using 2.6.11.6, so fairly new in the grand scheme of things. Dunno what the current Fedora kernel is supposed to be; i'm in the habit of rolling my own when nessesary.

Anyhow, audit seems to have solved it. Or at least hidden it like Ibuprofen.
Thanks for the help.

Post Reply