audacity install via apt

Place to discuss Fedora and/or Red Hat
Post Reply
User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

audacity install via apt

Post by Calum » Fri Aug 05, 2005 12:37 pm

help:
[root@harvey ~]# apt-get install audacity
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against

that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
audacity: Depends: libwx_gtk-2.4.so.0
Depends: libwx_gtk-2.4.so.0(WXGTK_2.4)
Depends: wxGTK (>= 2.4.0) but it is not going to be installed
E: Broken packages
[root@harvey ~]# cat /etc/apt/sources.list*
# Add any local / 3rd party repositories here..
cat: /etc/apt/sources.list.d: Is a directory
[root@harvey ~]# cat /etc/apt/sources.list.d/*
# Name: Dag RPM Repository
# URL: http://dag.wieers.com/apt/

### Dag RPM Repository for Fedora Core
rpm http://apt.sw.be fedora/4/en/i386 dag

# Name: Dries RPM Repository
# URL: http://dries.studentenweb.org/apt/

### Fedora Core
rpm http://apt.sw.be dries/fedora/fc4/i386 dries

# Name: FreshRPMS
# URL: http://ayo.freshrpms.net/

### Fedora Core
rpm http://ayo.freshrpms.net fedora/linux/4/i386 freshrpms

# Package repository URLs
#
# Planet CCRMA for Fedora Core 2

# Main site, CCRMA, California, USA

rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 core updates
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetcore

rpm-src http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma

# Mirrors: IRCAM, Paris, France
#
# rpm http://mirrors.ircam.fr/pub/planetccrma/apt fedora/2/i386 core updates
# rpm http://mirrors.ircam.fr/pub/planetccrma/apt fedora/2/i386 planetccrma
# rpm http://mirrors.ircam.fr/pub/planetccrma/apt fedora/2/i386 planetcore
#
# rpm-src http://mirrors.ircam.fr/pub/planetccrma/apt fedora/2/i386 planetccrma
i am using fedora 4, note that fedora 2 is the most recent CCRMA repository available, and that i can't upgrade grip either from that repository.

i also got the same errors before i added the CCRMA repository today. any ideas? i am hoping not to have to install it from source code...

thanks in advance of course.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Aug 05, 2005 12:47 pm

You might want to take a peek at this thread:

http://voidmain.is-a-geek.net/forums/vi ... php?t=1543

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Fri Aug 05, 2005 2:28 pm

excellent!

sorry i started a new thread then - i should have seen that.

it worked flawlessly, i will have to add those fedora extras to my sources.list if such a thing is possible. unless there is some reason why i should not do this?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Aug 05, 2005 2:37 pm

I'm not sure if there is an apt repo for them. I think there is a yum repo but I think yum is yuk.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Sat Aug 06, 2005 3:20 pm

that's a very apt thing to say.

and i am so sad that i didn't actually mean that as a pun!

Post Reply