wireless troubleshooting

Place to discuss Fedora and/or Red Hat
Post Reply
Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

wireless troubleshooting

Post by Master of Reality » Sat Jul 01, 2006 9:50 am

Ive got a D-Link wireless router here with a 64bit HEX WEP key set, which i know.
The wireless is set as Open system and it is enabled on the router. I can see the network when i do "iwlist wlan0 scan" it comes up with the essid "Luke".

But when i try to connect with:
# iwconfig wlan0 essid Luke key xxxxxxxxxx
# dhclient wlan0
I never get a response from dhcpd on the router. I also tried a static IP (the router help page said i should be able to connect with it) and it didnt work.

So i took off encryption entirlely and tried to connect the same way and dhclient still didnt get a response.

Is there any more troubleshooting that i can do?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Jul 01, 2006 10:22 am

Are you actually getting associated with the AP? After doing the associate what does "iwconfig wlan0" output? Does it show that it's associated and does it show that it's using the proper SSID and encryption key? Also, "iwlist wlan0 key" will show your keys.

You should also be able to use "ifup" and "ifdown" to control your interface if you have your /etc/sysconfig/network-scripts/ifcfg-wlan0 and /etc/sysconfig/network-scripts/keys-wlan0 configured properly.

ifcfg-wlan0:

Code: Select all

DEVICE=wlan0
IPV6INIT=no
TYPE=Wireless
ONBOOT=yes
DHCP_HOSTNAME=yourmachinename
BOOTPROTO=dhcp
IWPRIV="mode 0"
ESSID=Luke
USERCTL=yes
PEERDNS=yes
IPADDR=
DOMAIN=
NETMASK=
HWADDR=
GATEWAY=
CHANNEL=7
MODE=Managed
RATE=Auto
keys-wlan0:

Code: Select all

KEY=FFEEDDCCAA9988776655443322
Of course you would set the hostname, channel and key to whatever yours are. Then "ifup wlan0" or "ifdown wlan0". Of course these can be configured graphically with system-config-network.

Personally, I use WPA encrpytion but this is a little harder to set up because you have to build/install wpa_supplicant and configure it. I also added a call to it in the /etc/sysconfig/network-scripts/ifup-wireless. I also run the OpenWrt Linux distro on my access point. It might actually run on yours too depending on what model you have:

http://www.openwrt.org/

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Sat Jul 01, 2006 10:44 am

the key is shown in the [1] slot, but after i do the # iwconfig wlan0 essid Luke key xxxxxxxxx
iwconfig still shows the access point being non-associated. Whats this mean?

Its not actually my router or network (im at a friends place or a few days), so im trying not to change many of their settings if possible.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Jul 01, 2006 11:24 am

You have to be associated with the AP before anything else can happen. Something at the 802.11 level is wrong (SSID, channel, key, etc). Does "iwlist wlan0 ap" show the access point you want to connect to? How about "iwlist wlan0 scan"?

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Sat Jul 01, 2006 11:51 am

So this is exactly what im doing. I get the key from the routers config page (its all numbers, but is still set as hex).

Really i have no idea what else i can try, it was working fine yesterday at cafes when i was connecting to random open networks.

Code: Select all

[root@ace ~]# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:13:46:47:31:70
                    ESSID:"Luke"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.412 GHz (Channel 1)
                    Quality:0/100  Signal level:-35 dBm  Noise level:-256 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0

[root@ace ~]# iwconfig wlan0 essid Luke channel 1 key xxxxxxxxxx ap 00:13:46:47:31:70

[root@ace ~]# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Bit Rate:54 Mb/s   Tx-Power:25 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:5192-7311-29   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@ace ~]#  

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Jul 01, 2006 1:04 pm

I don't see anything that you are doing wrong but it certainly is not associating with the access point. Is there any MAC restrictions set on the access point? Are there any logs that you can look at on the access point?

Post Reply