MPlayer subtitle size

Place to discuss Fedora and/or Red Hat
Post Reply
insomnia
programmer
programmer
Posts: 123
Joined: Thu Feb 05, 2004 6:58 pm
Location: Belgium, Antwerp

MPlayer subtitle size

Post by insomnia » Thu Aug 03, 2006 3:14 pm

How do you change the default subtile size in MPlayer (srt)?
I only found how to change them from the CLI (but not permanent). Is their any way to set new defaults?

Thanks.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Aug 03, 2006 11:13 pm

What parameters are you using on the command line to get what you want? Can't you put those options in your ~/.mplayer/config? For example, if you used the "-dumpsrtsub" on the command line you could put it in your ~/.mplayer/config as:

Code: Select all

dumpsrtsub='yes'

insomnia
programmer
programmer
Posts: 123
Joined: Thu Feb 05, 2004 6:58 pm
Location: Belgium, Antwerp

Post by insomnia » Fri Aug 04, 2006 9:40 am

Well, it seems I was wrong from the beginning. It doesn't change anything from the cl either . I overlooked this since it did play (but without scaling the subtitles).
Void Main wrote:What parameters are you using on the command line to get what you want?
−subfont-text-scale=7 (This used to work in the past. I never tried it with Fedora though.)

Since scaling(−subfont-text-scale) only seems to be possible with FreeType fonts (according to the MPlayer manual) I looked for its config file (~/.mplayer/subfont.ttf) and it doesn't seem to exist (I did have it with older versions) :s

So... could this be my problem?
And if so, should I simply create this file manually (and can I just copy some .ttf fonts in here)?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Aug 04, 2006 3:08 pm

I would think you would just put this in your ~/.mplayer/config
subfont-text-scale=7
and of course your MPlayer would have to be compiled with freetype support. Where did you get your copy of MPlayer? What's the full RPM name?

insomnia
programmer
programmer
Posts: 123
Joined: Thu Feb 05, 2004 6:58 pm
Location: Belgium, Antwerp

Post by insomnia » Fri Aug 04, 2006 5:48 pm

Void Main wrote:I would think you would just put this in your ~/.mplayer/config
subfont-text-scale=7
and of course your MPlayer would have to be compiled with freetype support. Where did you get your copy of MPlayer? What's the full RPM name?
Didn't work.
I use the Dries and Freshrpms repos (and take some packages from the extra repo to resolve dependencies). MPlayer came from the Freshhrpms or Dries repo though, I don't have extra and Livna in my sources list.
I googled some more on this and only found the same results. It seems you do need "~/.mplayer/subfont.ttf" (I just don't really know how it should be like).

Would installing MPlayer from source solve that(and how can I add the freetype support)?
I don't really like the idea of doing source installations on an RPM distro (I probably could install it in a different directory and use both tho. I do need the rpm package for easy dependencies and updating).

EDIT; After reading my logs it seems I once did a yum update(I normally only use apt) with the extra repo enabled. My current MPlayer package is 1.0-0.28.pre8.fc5.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Aug 04, 2006 6:42 pm

Ahh, subfont.ttf is just a truetype font file. You can copy any *.ttf file to that name in your ~/.mplayer directory and it should work. I would suggest symbolic linking that name to whatever font you want to use. I think that parameter in your config file will work once you have a font file installed.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Aug 04, 2006 8:31 pm

Ok, I figured it out (now that I am home and have a DVD to test with). Here's what I put in my ~/.mplayer/config:

Code: Select all

font=/usr/X11R6/lib/X11/fonts/TTF/comic.ttf
subfont-text-scale=7
You may not have any truetype fonts installed where I installed mine but just put the font= line to point to a ttf font file whereever it exists. You can also put your other options in the config. It was all in the man page actually.

EDIT: This does not work with the GUI (gmplayer) and only seems to work with mplayer on the command line. Haven't figured out why but I do see other people complain about it. I'm going out on a limb and will say the version we have installed is broken.

insomnia
programmer
programmer
Posts: 123
Joined: Thu Feb 05, 2004 6:58 pm
Location: Belgium, Antwerp

Post by insomnia » Sat Aug 05, 2006 6:50 pm

Thanks!!! :D
I already figured out how to use the "font=" option, but didn't know about that gmplayer problem(displays everything at minimal size).
Instead of just trying it from the command line, I sadly just spent about 4 hours trying(and combining) about all subtitle(and font) related options from the MPlayers docs (I kept starting all movies in GNOME) :?
It works indeed perfect from the command line.
"subfont-text-scale=7" was actually way to big for my TV, so I'm using "subfont-text-scale=3.5":
font=/usr/share/fonts/bitstream-vera/Vera.ttf
subfont-text-scale=3.5
I'm trying out some very nice other options as well.

Geusts with less good eyes can finally enjoy my movies as well :)
Thanks again,
Jens.

Post Reply