mp3 and movies

Place to discuss Fedora and/or Red Hat
Post Reply
kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

mp3 and movies

Post by kovax » Tue Jan 02, 2007 7:51 am

What is a suitalble player that can be used on Red Hat enterprise? I would like to be able to play mp3's and movies.

I have tried to install MPlayer but I get some issues and was wonderig if there was a better player out there.

Thanks

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jan 02, 2007 9:39 am

xmms for mp3s (with xmms-mp3) and mplayer (with codecs) or vlc for video. Dag has the xmms and mplayer RPMs for RHEL:

http://dag.wieers.com/packages/xmms/
http://dag.wieers.com/packages/mplayer/

ATrpms might have more updated versions:
http://atrpms.net/

kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

almost there

Post by kovax » Mon Jan 08, 2007 2:41 pm

Thanks for the help!!!!

I got XMMS working but mplayer is beating me up. I get the following now:
# rpm -ivh mplayer-1.0-0.20.pre7.1.el3.rf.i386.rpm
warning: mplayer-1.0-0.20.pre7.1.el3.rf.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
libdvdread.so.3 is needed by mplayer-1.0-0.20.pre7.1.el3.rf.i386

I got a bunch of other prerequisites that i was able to install with no problem. THis is my last one. Any additional help is appreciated.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Jan 08, 2007 2:47 pm

Are you saying this one doesn't work?
http://dag.wieers.com/packages/libdvdre ... f.i386.rpm

kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

Post by kovax » Mon Jan 08, 2007 2:56 pm

When i tried that one I get this:

# rpm -ivh libdvdread-1.9.7-1.el3.rf.i386.rpm
warning: libdvdread-1.9.7-1.el3.rf.i386.rpm: V3 DSA signature: NOKEY, key ID 6b8d79e6
error: Failed dependencies:
libdvdcss >= 1.2.5 is needed by libdvdread-0.9.7-1.el3.rf.i386

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Jan 08, 2007 3:10 pm

Yes, that means you also need the libdvdcss package. You know the easiest thing to do is to install apt and then just "apt-get install mplayer" and it will download and install the required dependencies at the same time. It's either that or go through them one at a time like you are doing.

kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

closer

Post by kovax » Mon Jan 08, 2007 3:11 pm

I am now getting this:

# mplayer
mplayer: error while loading shared libraries: liblirc_client.so.0: cannot open shared object file: No such file or directory


I was able to get the other lib installed.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Jan 08, 2007 3:33 pm


kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

Post by kovax » Tue Jan 09, 2007 7:50 am

that worked GREAT. I am now watching movies......

You are the best.
I will have to look for some post on apt-get to see how it works.

Thanks again

Post Reply