power saver hang

Place to discuss Fedora and/or Red Hat
Post Reply
caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

power saver hang

Post by caveman » Sun Feb 04, 2007 6:45 am

Hi.

Been having this problem now for about 2 months - not had time to investigate....
I know its little to go on, but....

Running FC5 on an AMD 1600+ cpu and an ASUS mobo with 2GB memory.
All was fine until the last sets of upgrade (Nov '06 I think) was done,
ever since - whenever the harware powersavers kick-in the system hangs -
no logs or anything to indicate the reason - freezes solid.
Took a while to figure out when it actually happens.
I have switched off all screen savers, power savers in the OS and where ever I could find in
the hardware. But it still start within about 15 minutes - then the system hangs completely!
Have to press the reset button!
As long as the machine is busy - it can actually run for days on end. This is done by
connecting my security cameras to it and running tvtime. Everytime the screen savers
try to activate - I touch the mouse - and after a while no power savers will start,
then the machine just cariess on-and-on.

The machine have been running all from RH8 thru FC4 without any problems.
The FC5 was a vanilla install - except for the data partitions. I am now at a total loss
I'll try and supply any info needed - just not now sure what can or may help.

Am a bit busy with some Oracle 10 stuff on it - and as soon as this is done
I am planning to boot the machine from one of the latest Knoppix on cd.
Let this run for a while and see if the problem persist - shall keep you posted.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Feb 04, 2007 10:27 am

That's strange, I see where people were having the screensaver do this but if you have them disabled then that shouldn't cause it. You also have all the hardware based power savers turned off, does that include hard drive shutdown and the like? I believe the interface between the OS and the hardware power saving is ACPI (or APM). Have you tried disabling those services and kernel functions as well? There is an ACPI service that you could try disabling and turn off ACPI in the kernel by adding "acpi=off" to the kernel boot line in /etc/grub.conf to see if that has any effect.

Post Reply