php4 to php5 update

Place to discuss Fedora and/or Red Hat
Post Reply
User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

php4 to php5 update

Post by cdhgold » Tue Jul 31, 2007 12:54 pm

i have RHEL 4 box running php 4 and want to update to php5 i have all the php5 rpms in one directory but when i try to execute

Code: Select all

rpm -Uvh *.rpmrpm -Uvh *.rpm
in the directory where the rpms are i get

Code: Select all

[root@101009-phoenix php5]# rpm -Uvh *.rpm
error: Failed dependencies:
        libmcrypt is needed by php-mcrypt-5.2.3-1.rs.rhel4.i386
        libmcrypt.so.4 is needed by php-mcrypt-5.2.3-1.rs.rhel4.i386
        libmhash is needed by php-mhash-5.2.3-1.rs.rhel4.i386
        libmhash.so.2 is needed by php-mhash-5.2.3-1.rs.rhel4.i386
        freetds >= 0.64 is needed by php-mssql-5.2.3-1.rs.rhel4.i386
        libsybdb.so.5 is needed by php-mssql-5.2.3-1.rs.rhel4.i386
        libsqlite3.so.0 is needed by php-pdo-5.2.3-1.rs.rhel4.i386
the default load from my host did not include yum or apt .. i found articles on how to use yum and apt(which i know already) looking for best place to get rpm for yum or apt to help with the php update or any suggestions on doing the udpate

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Tue Jul 31, 2007 2:51 pm

never mind issue resolved now at php5

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jul 31, 2007 3:03 pm

First of all, do you actually need all of the RPMS you are trying to install? Are you really going to use Microsoft SQL server as a backend database to your PHP scripts? Be sure you actually need all of the RPMS you are trying to install. You may not have to install any dependencies if you don't need any of the ones that failed.

Having said that, you will need to get and install all the RPMS for your OS that the RPMS you are trying to install depend on.

For instance, the first one "php-mcrypt-5.2.3-1.rs.rhel4.i386" needs libmcrypt you'll need to find and install the RHEL4 version of mcrypt. If you are hooked up to Red Hat Network it should be as simple as "up2date libmcrypt". Same thing for the rest of them.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jul 31, 2007 3:03 pm

Dang, too late. :)

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Tue Jul 31, 2007 4:02 pm

my fix was to add the channel from my host that contained the php5 updates ..once that was done a quick up2date and problem solved

Post Reply