apt -get Synaptic for rh9

Place to discuss Fedora and/or Red Hat
Post Reply
siplus
user
user
Posts: 48
Joined: Sun Jan 12, 2003 1:29 pm
Location: Pa, USA
Contact:

apt -get Synaptic for rh9

Post by siplus »

http://voidmain.kicks-ass.net/redhat/re ... _have.html

i was trying to install apt-get and snynaptic for redhat9, so after i downloaded http://ftp.freshrpms.net/pub/freshrpms/ ... 4.i386.rpm
and tried to install it, it said i had Failed dependencies

Code: Select all

[root@siplus downloads]# ls
apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4.i386.rpm
[root@siplus downloads]# rpm -Uvh apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4.i386.rpm
warning: apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
        libelf.so.0 is needed by apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4
        librpm-4.1.so is needed by apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4
        librpmdb-4.1.so is needed by apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4
        librpmio-4.1.so is needed by apt-0.5.5cnc4.1-fr1.20030325a.0.rh80.4
[root@siplus downloads]#
where are those files that i need? or was this apt-get thing only for rh8?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

As titled, those instructions are for Red Hat 8.0, not 9. You need to use the version of apt for Red Hat 9:

http://apt.freshrpms.net/

I suppose I should update the instructions to be for RH8.0 and RH9 but as of this time they are RH8.0 specific For the most part you want to ignore that entire tip for RH9.

siplus
user
user
Posts: 48
Joined: Sun Jan 12, 2003 1:29 pm
Location: Pa, USA
Contact:

Post by siplus »

ok, thanks!

Post Reply