Change default browser in Evolution

Place to discuss Fedora and/or Red Hat
Post Reply
lovswr
scripter
scripter
Posts: 59
Joined: Tue Apr 08, 2003 2:06 pm
Location: [H]otlanta
Contact:

Change default browser in Evolution

Post by lovswr » Fri Oct 03, 2003 7:39 pm

Hello. Total nube here. How do I change the default browser in Evolution from Mozilla to Konqueror? Konqueror is my default system browser for KDE, but when I click a link inside of a mail message in Evolution it always pulls up Mozzila (which does not work as it keeps asking for some typr of security certificate). TIA :)



p.s One more thing. How do I archive mail from Evolution. As far as I can tell, it does not have a built in archive tool.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Oct 03, 2003 8:41 pm

Not sure what your issue is with Mozilla (Mozilla is my current favorite) but to change your default browser in Red Hat you click you "Red Hat menu", then "Preferences", then "Prefered Applications" and change the 'mozilla "%s"' to 'konqueror "%s"' or select konqueror in the pull down.

As far as the archive function question. If you mean an archive function that would be similar to MS Outlook I don't believe Evolution has such a function. Fortunately Evolution, unlike Outlook, stores messages in the standard mbox format. This makes it easy to copy/backup your message folder files (there would be one for each folder including your INBOX). I periodically save off my INBOX file to another name and then start a new one. I usually name the file "archive-yyyymmdd" and it shows up as another folder so I can always go back and look at messages in it.

I actually use IMAP on my server so my INBOX resides on my server and that is where I do the copying. If you use POP you would do it on your local PC under your ~/evolution directory, or right within Evolution by creating a new folder and moving all of your messages out of your INBOX into it. Evolution also has powerful filter and virtual folder options where you could get creative and keep you INBOX cleaned out and sorted into proper folders. I might also suggest dropping by Ximian's web site and click on the support button and browsing through the knowlegebase and the FAQ. It doesn't take long and you'll probably pick up some very useful tips.

lovswr
scripter
scripter
Posts: 59
Joined: Tue Apr 08, 2003 2:06 pm
Location: [H]otlanta
Contact:

Post by lovswr » Fri Oct 03, 2003 8:51 pm

Thank you for your prompt reply. Unfortunately I do not have a "Preferred Applications" udner Preferences. I have the following:



About Myself
Configure Panel
Desktop Settings Wizzard
Handheld PDA
Login Photo
Password
Printing Manager


As to Mozzila. I just prefer Konq.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Oct 03, 2003 9:01 pm

Hmmm, I guess you are using KDE rather than Gnome. That's the way you do it in Gnome. Evolution is a Gnome app so you have to change it the Gnome way. If you press "ALT+F2" and try and run the "gnome-default-applications-properties" command does it bring up the preffered app program? I'll log in to KDE and see if I can do it. Also if you are using IMAP in Evolution you can just right click on your INBOX and do a "Copy Folder" to a new location and then clean it out if you want a point and clicky way to do it. Be back in a minute...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Oct 03, 2003 9:56 pm

I guess I had never tried this under RH9 and I haven't been able to quickly find a way to change it. In older versions of Red Hat I had done that with no problem but the procedures were different then. I have found a couple of instructions on Google but I couldn't get them to work. Unfortunately I don't have much time to investigate any further so hopefully someone else here has the answer. I switched to Gnome/Bluecurve/Mozilla about a month after RH8 came out. I used KDE for several years prior to that.

lovswr
scripter
scripter
Posts: 59
Joined: Tue Apr 08, 2003 2:06 pm
Location: [H]otlanta
Contact:

Post by lovswr » Sun Oct 05, 2003 11:29 am

Hey Void. I found the following [url=http://www.linuxquestions.org/questions ... 06/4/67366
yeOss]here.[/url] I already had Konqueror at the top. I guess this just does not work in Evolution because it is a Gnome app like you said. Maybe I'll just upgrade to the lateset version of stable Mozilla instead.

Hi,

Thanks for that. How would I go about doing this? Also, when I try to open up Firebird it tells me, "The program Mozilla Firebird could not be found". How do I fix this?

Thanks,
ByeOss


SenorPedo
To change your MIME settings go to your control center (in the red hat menu again, or also in the start here icon on the desktop) and go to File Associations. This may be listed under something like KDE components. If you can't find it, just search in the control center for MIME types. Now open up the Text sub-menu and find HTML. Under Application Preference Order, click on Firebird and then Move Up to put it at the top of the list. If it's not listed, add it by selecting Add and type in the executable name.

SuSELinux
user
user
Posts: 37
Joined: Mon Jul 14, 2003 2:08 am
Location: Vancouver, Canada
Contact:

Post by SuSELinux » Mon Oct 06, 2003 12:41 am

in KDE press Alt-F2, or right click on the desktop and choose run command

type in --------------- gnome-default-applications-properties

this should give you a little box called "preffered applications"

under the "web browser" tab choose the button "Select a web browser"

and in the scroll down beside that button choose Konqueror

if you do not see Konq. the choose the button below called "custom web browser"

in the feild beside that button type -------------- konqueror %s

I had to do the same thing in Suse because Evolution would open Galeon instead of Mozilla.

hope this works for you.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Oct 06, 2003 8:13 am

I had suggested that and although the command exists and works in Gnome on Red Hat 9 it doesn't seem to effect the KDE side. Although I don't remember if I logged off and back on or not which may need to be done.

agent007
administrator
administrator
Posts: 254
Joined: Wed Feb 12, 2003 11:26 pm

Post by agent007 » Wed Oct 08, 2003 12:00 pm

I too am not a fan of Mozilla....Am using Galeon instead. So, to avoid all this hassel, I just renamed the mozilla executable to something else and created a new simlink with the name mozilla which in turn points to the real galeon!

cool huh? :P

007
Last edited by agent007 on Thu Oct 09, 2003 1:26 pm, edited 1 time in total.

SuSELinux
user
user
Posts: 37
Joined: Mon Jul 14, 2003 2:08 am
Location: Vancouver, Canada
Contact:

Post by SuSELinux » Thu Oct 09, 2003 12:58 am

See, this is the cool thing about Linux, there is like five hundered ways to get the job done.


very impressive problem solving Mr.Bond. Very impessive indeed.

agent007
administrator
administrator
Posts: 254
Joined: Wed Feb 12, 2003 11:26 pm

Post by agent007 » Thu Oct 09, 2003 1:27 pm

hehe....Thanks dude!

lovswr
scripter
scripter
Posts: 59
Joined: Tue Apr 08, 2003 2:06 pm
Location: [H]otlanta
Contact:

Post by lovswr » Sat Oct 11, 2003 12:56 pm

Ok, I did the thing that Void first suggested. Konq was already th edefault browser (it was above Mozilla), but I selected it & hit apply anyway. Well what can I say, but it worked. I get Konq when I click on links inside Evolution now. Thanks for all the replies! :)

Post Reply