libvorbis installation problem

Place to discuss Fedora and/or Red Hat
Post Reply
sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

libvorbis installation problem

Post by sh00der » Sat Nov 01, 2003 12:35 pm

Now then guys, my limited knowledge has gotten me into a fix again. I installed Audacity and found that I needed to upgrade libogg-1.0-1 and libvorbis-1.0-1 to libogg-1.0rc3-1 and libvorbis-1.0rc3-1 to get it running. I downloaded and installed the rc rpms and installed them using

rpm -i lib(package name).rpm

thinking it would upgrade the existing packages, sadly not. I uninstalled libogg ok using rpm -e but when I try

rpm -e libvorbis-1.0-1

I get ...

error: Failed dependencies:
libvorbisenc.so.2 is needed by (installed) sox-12.17.3-7
libvorbisenc.so.2 is needed by (installed) vorbis-tools-1.0-1
libvorbisenc.so.2 is needed by (installed) kdebase-3.0.3-13
libvorbisenc.so.2 is needed by (installed) timidity++-2.11.3-4
libvorbisfile.so.3 is needed by (installed) sox-12.17.3-7
libvorbisfile.so.3 is needed by (installed) vorbis-tools-1.0-1
libvorbisfile.so.3 is needed by (installed) xmms-1.2.7-13.p
libvorbisfile.so.3 is needed by (installed) SDL_mixer-1.2.4-5
libvorbisfile.so.3 is needed by (installed) kdemultimedia-arts-3.0.3-4
libvorbisfile.so.3 is needed by (installed) kdemultimedia-kfile-3.0.3-4
libvorbisfile.so.3 is needed by (installed) kdemultimedia-libs-3.0.3-4

Now my ogg player in xmms doesn't work, can you help me sort it out please. Thanks

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Nov 01, 2003 12:44 pm

Add these to your /etc/apt/sources.list:

Code: Select all

rpm http://www-ccrma.stanford.edu/planetccrma/apt redhat/9/en/i386 planetcore
rpm http://www-ccrma.stanford.edu/planetccrma/apt redhat/9/en/i386 planetccrma
then:

# apt-get update
# apt-get install audacity

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Sat Nov 01, 2003 1:23 pm

Void, thanks for the fast response, this is what I get when trying

apt-get update

after Hit ftp and Hit http a few times it gets stuck on

warning: cannot get exclusive lock on /var/lib/rpm/Packages
Reading Package Lists... 0%

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Nov 01, 2003 1:32 pm

sh00der wrote:Void, thanks for the fast response, this is what I get when trying

apt-get update

after Hit ftp and Hit http a few times it gets stuck on

warning: cannot get exclusive lock on /var/lib/rpm/Packages
Reading Package Lists... 0%
That usually means another copy of the "rpm" command is running and has a lock on the RPM database. Make sure you are root "su" and make sure there is no other copy of rpm or Synaptic running "ps auxw | grep rpm". If there is kill it. If you still get the message you may have a stale lock file. You can remove the 3 lock files by:

# rm /var/lib/rpm/__*

Now, after installing I seem to have a little problem keeping the app running. It seems if I play a wav file it will play it but crash at the end. Must be a feature. Maybe I should download the newer source and make my own RPM and put up in my repo. Let me know once you get it installed if you have the same problem.

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Sat Nov 01, 2003 1:43 pm

Void, thanks for that. Following your advice, I got apt-get update working and got this warning for each libogg and libvorgis

W: There are multiple versions of "libogg" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^libogg$"; };

To disable these warnings completely set:

RPM::Allow-Duplicated-Warning "false";

BTW I forgot to mention that I am on RH 8.0

Should I uninstall anything before going for the

apt-get install audacity

??

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Nov 01, 2003 1:53 pm

Oh, I incorrectly assumed you were on Red Hat 9. You need to change the "9" in the URL you added to your sources.list to "8.0" and then do another "apt-get update". Now, how did you get more than one version of libogg installed on your system? You should probably get rid of one. Doing an "apt-get -f" might fix the problem. Or you might want to force remove both libogg RPMS using the "rpm -e --nodeps libogg-xxx" command, followed by an "apt-get -f" which should download/install the proper libogg RPM needed by your installed apps.

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Sat Nov 01, 2003 2:12 pm

Void, I forced the installation of the second libogg :oops: when trying to get audacity to work. I did manage to realise that I needed to swap the 9 for 8.0 in sources.list.
I've removed the libogg and libvorbis I installed and now apt is installing audacity for me (56k connection :( ).

Thanks for your excellent help, and prompt service. It is great to have somewhere to come with these problems, thanks again.

PS I hope it installs and runs ok hehe

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Nov 01, 2003 3:41 pm

If you have problems with that one like I did (and even if you don't) you can replace it with the newer RPM I just built of the latest version (1.2.0-pre2). In order to do this you would:

# apt-get remove audacity

Replace the two ccrma lines you added earlier to your /etc/apt/souces.list with:

Code: Select all

rpm http://voidmain.is-a-geek.net apt/redhat/8.0/en/i386 voidmain
rpm-src http://voidmain.is-a-geek.net apt/redhat/8.0/en/i386 voidmain 
for Red Hat 8.0 or:

Code: Select all

rpm http://voidmain.is-a-geek.net apt/redhat/9/en/i386 voidmain
rpm-src http://voidmain.is-a-geek.net apt/redhat/9/en/i386 voidmain
for Red Hat 9. Then:

# apt-get update
# apt-get install audacity

I would be interested to see if my RPM works well in Red Hat 8.0 (I can't actually test it as I no longer have any RH8 machines).

Of course you can also get to the RPMS directly here:

http://voidmain.is-a-geek.net/files/RPMS/

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Mon Nov 03, 2003 6:04 am

Void, I will gladly give those rpms a try on my RH8.0 machine and I'll let you know how I get on. I'll try it tonight.
I haven't really had much chance to play with the version of audacity I have just installed but I did have problems when trying to record one track while playing another. It seemed as though the sample rate on the recording track dropped. I was wondering whether I might need to upgrade my Duron 1200 processor. Maybe this new version will be better?

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Mon Nov 03, 2003 1:19 pm

Void, no problems with the audacity rpm on RH8.0.
I am struggling to get timidity set up as my midi device for alsa though.

Thanks again

sh00der
scripter
scripter
Posts: 50
Joined: Fri Apr 18, 2003 3:00 pm
Contact:

Post by sh00der » Thu Nov 06, 2003 3:20 pm

I'm not sure if this is related but I am having some more trouble with apt or synaptic actually. I tried installing fluidsynth from the ccrma stanford repositories but it didn't work. Checking the dependancies tab showed libfluidsynth in red and libMidiShare.so was also red and reported 'package is not installable' at the bottom.
Also when I update the list I get an error message saying that some of the index files did not load properly and were either ignored or old ones used. Please help, again.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Nov 06, 2003 4:22 pm

I don't know if I can help you much with CCRMA. I don't use it because I had big trouble with it in the past.

Post Reply