OpenGL not running - 3D not working

Place to discuss Debian Linux and Debian based distributions
Post Reply
Membrax
scripter
scripter
Posts: 99
Joined: Tue Oct 21, 2003 2:04 pm
Location: 50'48''N - 4'21''E
Contact:

OpenGL not running - 3D not working

Post by Membrax » Wed Sep 06, 2006 5:30 am

Hi Folks !

This mai sound like an endless story but the point is that the situation hasn't changed since my last post ... a while ago.

- My graphic card is a Nvidia 6600GT
- The latest drivers are installed and compiled without a glitch
- Using kernel 2.6.16-2
- The following packages are part of my system :
* xlibmesa-dri
* xlibmesa-gl
* xlibmesa-glu
* mesa-utils
* libgl1-mesa-dri
* libgl1-mesa-glx
- Everything seems fine ... BUT :

* glxinfo gives the following :

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None


Nothing that requires 3D works on my system.

Any tip/idea/suggestion ... very welcome !!!

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Sep 06, 2006 8:46 am

What does your XF86Config/xorg.conf look like? Do you have "Load glx" in the proper section? Are you sure your X server is using that config? Have you verified in your X server log which config file and which driver is being loaded? You might want to browse this thread to spark some ideas on where to look:

http://www.nvnews.net/vbulletin/showthread.php?t=75525

Membrax
scripter
scripter
Posts: 99
Joined: Tue Oct 21, 2003 2:04 pm
Location: 50'48''N - 4'21''E
Contact:

Post by Membrax » Tue Sep 12, 2006 4:07 pm

After months of patience and many -I should write zillions- attempts, ... believe it or not but now it just WORKS FINE !!!

The thing I've identified thanks to this page :
http://download.nvidia.com/XFree86/Linu ... dix-c.html

I've been scoping this page one word at a time and after each of them I checked my system. All of a sudden I discovered that nvidia_drv.o and nvidia_drv.so where present on my system, but in this directory /usr/xorg/lib/modules/drivers/ ... instead of there /usr/X11R6/lib/modules/drivers/

Did a copy-paste operation and that was it !

Now I can throw in the bin the exorcist's phone number I've been using for almost 2 years.

I sincerely hope that this post will meet some others' needs and hence provide some help further.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Sep 12, 2006 4:18 pm

Ahhh, so you are still using XFree86 and not Xorg?

Membrax
scripter
scripter
Posts: 99
Joined: Tue Oct 21, 2003 2:04 pm
Location: 50'48''N - 4'21''E
Contact:

Post by Membrax » Tue Sep 12, 2006 4:30 pm

That is exactly where my mind blows up :
Yes I use xorg and made the move thanks to a huge Synaptics apt-get package nuclear operation.

So I assume that xorg is being used by my system.

Is there any way to check whether it is XFree86 or Xorg that is active ?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Sep 12, 2006 5:30 pm

Well, if you are running Xorg you should see the Xorg process running:

Code: Select all

$ pgrep -lf Xorg
It will also create a log file by the name of /var/log/Xorg.0.log. The module path could be defined in your configuration file by a line like this in your /etc/X11/xorg.conf:

Code: Select all

    ModulePath   "/usr/X11R6/lib/modules"
Otherwise the default compiled in module path would be used and it should show up in the /var/log/Xorg.0.log in a line like this:

Code: Select all

(==) ModulePath set to "/usr/lib/xorg/modules"
(==) = default settings.

Of course this assumes you are using Xorg and not XFree86 (Xorg is just a fork of XFree86).

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Tue Sep 12, 2006 11:52 pm

You probably are using Xorg. Based on what little I've understood, it looks like you have a backwards compatibility issue. Like one of your packages, perhaps the nvidia driver package, put the library files in the wrong folder. In theory, you could change the references to the correct path, or you could put the files into the expected path. Actually, that's what I would do - leave both files in both directories. That way, a process that needs them can look in either path, without you having to specify which one.

Post Reply