Pixmap in GRUB Menu ?????

Place to discuss Slackware
Post Reply
User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Pixmap in GRUB Menu ?????

Post by Calum » Mon Apr 21, 2003 9:12 am

has anybody ever succeeded in getting the grub menu to display a pixmap under slackware?

in red hat i had a few pixmaps i could use as the grub menu background, now i am running grub from slackware i find i need to apply a patch to get it to do this. i found an LFS hint on how to do it, but the patch they suggest is for grub 0.91 and the GNU site only provides grub 0.92 and 0.93 for download. i also tried using the redhat 8 version of grub (0.92) (using rpm2tgz to create a slackpackage of it) since i know it has this capability, but it appears not to work. i installed it, ran grub-install /dev/hda and i still get the boring black and white menu when i boot up.

does anybody know how this can be done?
thanks...

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Apr 21, 2003 9:53 am

wouldnt know, ive only got lilo (thats what it installed for me)

i rather grub though, tutorials???

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Apr 21, 2003 10:00 am

I don't understand the problem. Don't you have Red Hat as one of your boot options on your GRUB menu? If you do why not just use Red Hat's GRUB from that install rather than Slack's?

And if you want something even cooler you should get the SuSE version of LILO. You can have animated boot graphics, really cool looking (although I no longer user it and am using Red Hat's GRUB at the moment).

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Apr 21, 2003 10:30 am

nope ive only got slacks...


Where can i get SuSE's lilo, sounds like it kicks a rather large amount of ass.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Apr 21, 2003 11:33 am

Actually I was referring to Calum when I mentioned using Red Hat's GRUB from his Red Hat installation. As far as where to get SuSE's LILO, when I used it I got it straight from their FTP site in their distro install files. There was a HOWTO somewhere out on the net with some animated graphics to use with it. I had linked to it at "the other forum". I'm sure a little Googling will find it.

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Apr 21, 2003 9:33 pm

oooh, ok sorry.

I'll still look around though.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Apr 21, 2003 9:53 pm

A google search produced this:

http://www.gamers.org/~quinet/lilo/help.html

I believe that's the place I used for instructions on setting up the animated boot menus. I remember the pink web pages. :)

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Tue Apr 22, 2003 6:51 am

Void Main wrote:I don't understand the problem. Don't you have Red Hat as one of your boot options on your GRUB menu? If you do why not just use Red Hat's GRUB from that install rather than Slack's?

And if you want something even cooler you should get the SuSE version of LILO. You can have animated boot graphics, really cool looking (although I no longer user it and am using Red Hat's GRUB at the moment).
hello, yes up till this weekend i also had red hat and was using red hat's grub to create my boot menu, but now i have removed red hat (it was complaining about being in a 2Gig partition) and replaced it with peanut linux (which takes up 500MB and is more of a challenge to force into cooperation) so now, i have no red hat and must use grub from slackware (or peanut, but the same problems apply there) and i miss my pixmap!

as for lilo, i just don't like it as much. i do remember your mentioning it before, but never got it to work (i was mucho newbie at the time!) perhaps i should look into it, but it would mean admitting defeat regarding grub.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Apr 22, 2003 8:24 am

As far as boot looks, that LILO with the animated graphics kicks GRUB's butt all over the place. I am sure you would be pleased if looks is what you are interested in. As far as which one is better I am comfortable with either and don't really favor one over the other. Since GRUB is now the default in RH that's what I use.

Post Reply