Bell

Discuss Applications
Post Reply
Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Bell

Post by Tux »

How can I ring the system bell from a terminal?
I feel so dumb :roll:
Please and Thankyou.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Do you mean like 'tput bel' or 'printf "\a"'?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

NOTE: In FC3 if you do not have the "pcspkr" kernel module loaded you will not actually hear the bell and of course you can adjust the volume and pitch with the "xset" command. Is this the bell you are referring to?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

There is also a command called "xkbbell" that will send a beep. If you are doing it from a gnome-terminal, make sure you have the bell enabled (there is a checkbox for it in the gnome-terminal settings menu).

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

Thanks void, I loaded the module but unfortunately it shill doesn't make a sound. What sort of values does xset take for volume?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

xset b 100 250 125

The above would set the volume to 100% and frequency to 250 and duration to 125 miliseconds. Is the bell box checked in your terminal settings?

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

Still no joy. I'm sure it's connected though, it works durign POST.
I guess this means it is time to sleep :)

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

It seems to work from a virtual terminal, but not from any X application. I'm not at all sure why :S

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

You do have the box checked in your gnome-terminal settings to allow the bell right? Just right-click on any Gnome terminal and look at your settings.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

Yup, I tried in Konsole and xterm also to triple check the issue :)

Post Reply