yum update gone bad

Discuss Applications
Post Reply
User avatar
Basher52
guru
guru
Posts: 916
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

yum update gone bad

Post by Basher52 » Fri Apr 23, 2010 7:12 pm

... probably due to bad disks and... forth...

Code: Select all

soprano-2.4.1-3.fc12.i686 from updates has depsolving problems
  --> Missing Dependency: libiodbc.so.2 is needed by package soprano-2.4.1-3.fc12.i686 (updates)
PolicyKit-kde-4.3.5-2.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libpolkit-qt-gui.so.0 is needed by package PolicyKit-kde-4.3.5-2.fc11.i586 (installed)
virtuoso-opensource-6.1.0-2.fc12.i686 from updates has depsolving problems
  --> Missing Dependency: libiodbc.so.2 is needed by package virtuoso-opensource-6.1.0-2.fc12.i686 (updates)
DeviceKit-disks-004-3.fc11.i586 from fedora has depsolving problems
  --> Missing Dependency: libatasmart.so.0 is needed by package DeviceKit-disks-004-3.fc11.i586 (fedora)
Error: Missing Dependency: libcln.so.6 is needed by package kdeplasma-addons-4.4.2-1.fc12.i686 (updates)
Error: Missing Dependency: setools-libs = 3.3.5-8.fc11 is needed by package setools-libs-python-3.3.5-8.fc11.i586 (fedora)
Error: Missing Dependency: libparted-1.8.so.8 is needed by package DeviceKit-disks-004-3.fc11.i586 (fedora)
Error: Missing Dependency: libpolkit-qt-gui.so.0 is needed by package PolicyKit-kde-4.3.5-2.fc11.i586 (installed)
Error: Missing Dependency: libiodbc.so.2 is needed by package soprano-2.4.1-3.fc12.i686 (updates)
Error: Missing Dependency: libreadline.so.5 is needed by package gnugo-3.8-1.fc11.i586 (fedora)
Error: Missing Dependency: libiodbcinst.so.2 is needed by package virtuoso-opensource-6.1.0-2.fc12.i686 (updates)
Error: Missing Dependency: libatasmart.so.0 is needed by package DeviceKit-disks-004-3.fc11.i586 (fedora)
Error: Missing Dependency: libiodbc.so.2 is needed by package virtuoso-opensource-6.1.0-2.fc12.i686 (updates)
Error: Missing Dependency: libreadline.so.5 is needed by package ruby-libs-1.8.6.383-6.fc12.i686 (updates)
Error: Missing Dependency: libpolkit-qt-core.so.0 is needed by package PolicyKit-kde-4.3.5-2.fc11.i586 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@kgdubben lib]# 
First I tried: package-cleanup --problems then later: rpm -Va --nofiles --nodigest, but still the same problem.
If this was me lonely I would reinstall it all but I need to figure out how to repair a system in production as this machine will be :P

User avatar
Basher52
guru
guru
Posts: 916
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Sat Apr 24, 2010 1:54 pm

fix it :) and when I saw the commands I remembered that VoidMain have given me that before too lol

Code: Select all

yum clean dbcache
yum clean metadata

yum -y update yum

yum update

User avatar
Void Main
Site Admin
Site Admin
Posts: 5715
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Apr 24, 2010 3:50 pm

Cool. I didn't say anything because you said "you" needed to figure it out. :)

User avatar
Basher52
guru
guru
Posts: 916
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Sat Apr 24, 2010 4:32 pm

oh, hehe. That was just my way not to make you mad since I'm kinda slow :(
I even think that's why I'm losing my job after next week.

I even thought you was away for the weekend and I needed to get this fixed so I had to google trough... I think 50 or 60 pages before I found this, but I did :)

Post Reply