k3b setup - mkisofs question

Discuss Applications
Post Reply
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium

k3b setup - mkisofs question

Post by Ice9 »

When I run the k3b setup it lists everything ok, both my Lite On DVD and Plextor Writer are recognized, no problem with mkisofs, cdrecord or cdrdao.
I click finish and k3b tells me that it saves the config and is ready for use now.
I start and when I go into configuration I see "Reader" and "Writer" nut no devices are associated with them, also mkisofs, cdrecord and cdrdao aren't found.
I hit "search" and it comes up with nothing, instead 1 time out of 3 it crashes KDE!!!

I installed the RH8 rpm's so I assume there is no problem with it being installed in the wrong directory, I'm pretty clueless, anybody got an idea?

Edit :
Ok, I fixed it (part of it), however I'm not sure I did the right thing!
First I went in /usr.share/apps/k3b
I noticed that k3bsetup was rw for root only
I did chmod 644 k3bsetup and suddenly my devices were detected in user mode too, so were cdrdao and cdrecord.

Now the problem that remains is mkisofs, it's in the xcdewrite group, I added my user to that group, still not found.
When I chmod 711 mkisofs it works, so the user needs to be able to execute it and being member of the xcdwrite group doesn't do the trick.
Is it safe to chmod mkisofs of shouldn't I do it?
I also noticed that the permissions for cdrecord and cdrdao were slightly different :
cdrecord & cdrdao rws--x---
mkisofs rwx--x---

so rwx=7 but what do I chmod to for rws?????

2nd edit :
Ok, I found that too, but that's not the solution, mkisofs still doesn't show up.
For it to be found by k3b I have to chmod 711 mkisofs, so I did that but I'm still not sure that this is safe, why is it owned and readable only by root by default?

Posts: 99
Joined: Tue Oct 21, 2003 2:04 pm
Location: 50'48''N - 4'21''E

Post by Membrax »

Dear Ice9,

first of all, may I suggest you to upgrade your version to the latest one (0.10.3) http://k3b.sourceforge.net/cgi-bin/index.pl/download
After that, you'll run the k3b setup and give the permissions to the users to mkisofs, cdrecord and cdrdao.

This should solve your issue.

Cheers !

Post Reply