Linksys WRT54G DOWN

Discuss Networking
Post Reply
Posts: 1
Joined: Mon Oct 18, 2004 5:15 am

Linksys WRT54G DOWN

Post by feel »

I've upgrade the firmware to openwrt, then change a line in the boot script ...

the router wil not restart, he crash ! (power led flashing)
the boot wait is turned ON,

i have try to upload the linksys default firmware with tftp at boot time but, the router give no ack ... tftp -> timeout !

anybody have an idea ?

this is the version 2

boot sequence led :

starting :

powerled directly flashing, other led (1234+internet) on about 1 second
then (1234+internet) down and powerled flashing ...

when i ping the router (always under linux) the '1' led flash but the router give no response :
~$ ping
PING ( 56 data bytes
--- ping statistics ---
12 packets transmitted, 0 packets received, 100% packet loss

anybody have an idea ? i have try to shorcut pin 15 16 of the flash chip (intel C3 320) while turning the power on , but it have no effect !! help :(

ps : sory, english is not my mother talk :)

Posts: 1
Joined: Wed Dec 22, 2004 4:08 am

Post by delveneto »

I have this exactly same problem with my recently bought WRT54G.
It has made it a useless piece of equipment.
Did you find any solution to the problem?

Posts: 1
Joined: Thu Feb 10, 2005 8:35 pm

Post by Nightwolf »

Yea same problem here too ;\

Tried flashing from a Sveasoft firmware back to official, and it died. Tried using the reset button in a manner of ways, shorted pints 15-16 while power-on. Setting the mac (arp -s $MAC) didn't help, the router doesn't respond at all. Sucks.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA

Post by Void Main »

SVEASOFT huh? I would go ask them for help or at least get your money back from them for destroying your router.

Posts: 1
Joined: Sat Feb 19, 2005 10:55 am
Location: oHIo

Post by jjbrad »

hi all....don't give up yet, there is another method to recover your bricked wrt54gs.
i have not been in your situation yet, but i found a thread on the site about using the jtag interface to recover the router when the other methods fail.
check out: ... ydairymaid

Post Reply