k3b, sudo and root access questions

Place to discuss Debian Linux and Debian based distributions
Post Reply
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium

k3b, sudo and root access questions

Post by Ice9 » Wed Sep 28, 2005 1:56 pm

I screwed up my whole system lately by playing with cfdisk and qtparted lately so I had to reinstall everything.
Since I was very happy with Debian unstable I installed that again, a bit f testing and everything runs great again, except for k3b.
I have been using k3b without problems since my early RH8 days now so I was really bummed.

What bummed me even more is that I have been unable to get it to run for 3 days now, no matter what version of cdrecord and/or library I throw at it ...
Now I read some stuff about the setuid bit for cdrecord not being needed anymore and I started thinking.
I added myself to the sudoers list and started k3b as root ... and it worked :?:
So I looked again at my debugging output file from k3b but I couldn't find anything in it that gives me a clue about what to do to be able to burn cd's without root access!

Here's the debugging output, could someone give me a clue please?
I'd love to be able to decipher this kind of things but for the moment it's just chinese to me!

Code: Select all

K3b Version: 0.12

KDE Version: 3.4.2
QT Version:  3.3.5
Kernel:      2.6.12-1-686
PLEXTOR CD-R   PX-W4012A 1.01 (/dev/hdd, ) at /media/cdrom1 [CD-R; CD-RW; CD-ROM] [CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R]

LITEON DVD-ROM LTD163 GDHA (/dev/hdc, ) at /media/cdrom0 [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [None]
Used versions
cdrecord: 2.1.1a03

/usr/bin/cdrecord: Warning: Running on Linux-2.6.12-1-686
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdd'
devname: '/dev/hdd'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
Error: Cannot gain SYS_RAWIO capability.Is cdrecord installed SUID root?
: Operation not permitted
/usr/bin/cdrecord: Warning: using inofficial version of libscg (ubuntu-0.8ubuntu1 '@(#)scsitransp.c 1.91 04/06/17 Copyright 1988,1995,2000-2004 J. Schilling').
SCSI buffer size: 64512
/usr/bin/cdrecord: Operation not permitted. Cannot send SCSI cmd via ioctl
Cdrecord-Clone 2.01.01a03 (i686-pc-linux-gnu) Copyright (C) 1995-2005 Joerg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.
TOC Type: 0 = CD-DA
Using libscg version 'ubuntu-0.8ubuntu1'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PX-W4012A'
Revision       : '1.01'
Device seems to be: Generic mmc CD-RW.
Current: 0x0009
Profile: 0x0008 
Profile: 0x0009 (current)
Profile: 0x000A 

cdrecord command:
/usr/bin/cdrecord.mmap -v gracetime=2 dev=/dev/hdd speed=16 -dao driveropts=burnfree -eject -overburn -useinfo -audio -shorttrack /tmp/kde-yc/k3b_audio_0_01.inf /tmp/kde-yc/k3b_audio_0_02.inf /tmp/kde-yc/k3b_audio_0_03.inf /tmp/kde-yc/k3b_audio_0_04.inf /tmp/kde-yc/k3b_audio_0_05.inf /tmp/kde-yc/k3b_audio_0_06.inf /tmp/kde-yc/k3b_audio_0_07.inf /tmp/kde-yc/k3b_audio_0_08.inf /tmp/kde-yc/k3b_audio_0_09.inf /tmp/kde-yc/k3b_audio_0_10.inf /tmp/kde-yc/k3b_audio_0_11.inf /tmp/kde-yc/k3b_audio_0_12.inf 
The only thing that is different from my earlier setup (where it worked without a hitch) is that I used kernel 2.6.11 then and now I'm using 2.6.12.
Tried to install 2.6.11 but it's nowhere to be found ... so I'm stuck with either 2.6.12 or 2.6.8 which caused known problems with k3b.
Last edited by Ice9 on Thu Sep 29, 2005 3:07 am, edited 1 time in total.

Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Wed Sep 28, 2005 3:20 pm

heh heh.

a bit of track - but have you thought of using it?
I have been suing k3b without problems since my early RH8 days now so I was really bummed.
and stop suing it? how much you paying the attorneys?

:D :D

Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium

Post by Ice9 » Wed Sep 28, 2005 3:32 pm


User avatar
Posts: 927
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Thu Sep 29, 2005 1:55 am

sorry, but i n00b question :(
what's k3b? and what does it do?

Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium

Post by Ice9 » Thu Sep 29, 2005 3:05 am

In my book k3b is the best cd/dvd burning program ever!
In the windoze world, the reference program is Nero, I consider k3b to be superior to Nero and on top of that it looks incredibly sexy :wink:
Check the k3b website for more info.

Post Reply