Error in YUM or?

Place to discuss Fedora and/or Red Hat
Post Reply
User avatar
Basher52
guru
guru
Posts: 912
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Error in YUM or?

Post by Basher52 » Sat Aug 01, 2009 2:24 pm

I get this on both servers:
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
---> Package wsdl4j.i386 0:1.5.2-5.4.fc10 set to be updated
--> Finished Dependency Resolution
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
--> Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
--> Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
--> Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
so what do I do with this?
I can't find no 'package-cleanup' thing so I might miss if that is some package I need to install

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Aug 02, 2009 5:07 pm

What were you trying to do?

User avatar
Basher52
guru
guru
Posts: 912
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Tue Aug 04, 2009 3:13 am

Just a 'yum update'
I tried the 'package-cleanup --problems' and 'package-cleanup --dupes' but those didn't help.
Have not tried the '--skip-broken' or 'rpm -Va --nofiles --nodigest yet'

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Aug 04, 2009 6:04 am

The problem is the package called "swig". Do you need that package? What happens when you try to remove it (rpm -e swig)? If nothing depends on it and you can remove it your problem should be solved.

User avatar
Basher52
guru
guru
Posts: 912
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Tue Aug 04, 2009 6:12 am

yep that worked, damn you're good :D

thx again

User avatar
Basher52
guru
guru
Posts: 912
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 » Fri Aug 21, 2009 1:49 pm

I just had this again and this time a module called: ktorrent was having dependency problems, so I removed it and the update worked.

Too bad though that I had to check this post to be able to remember it.
Hopefully I can remember it next time :)
(if that is within like 6 months or I'll forget it again :P)

Copperhead
scripter
scripter
Posts: 83
Joined: Wed May 14, 2003 1:12 am
Location: Los Angeles, CA, USA

Post by Copperhead » Fri Sep 04, 2009 9:51 am

You can always use the exclude flag with yum as well:

$ yum -x <package_name> update/upgrade

I ran into a similar problem with conflicts between lua and mod_security.

Post Reply