New Fedora Core install

Place to discuss Fedora and/or Red Hat
chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:
New Fedora Core install

Post by chartoo » Fri Mar 26, 2004 2:05 pm

This is my first venture into the world of Linux. Well, that's not entirely true I 've used Knoppix and couple of times but I've never had a working installation of Linux on any of my PCs before.

Last night I installed Fedora Core 1 on my secondary hard drive in a 29 Gig partition. Except for the partitioning process, took me awhile to understand how to use Disk Druid, the installation was flawless.
Fedora found all my devices, ATI 9600 video card, my Gigagit lan on the motherboard , Realtek motherboard based sound card and cofigured my internet connection without any assistance on my part.

The problem, when I got to the end of the installation I selected no when prompted to create a boot disk at the end of the installation process..
Afterwards I realized I had made a mistake. When I rebooted the system I found myself back in Windoze on my primary hard drive, Fedora didn't boot.
Fortunately, the bios on my computer let's you change the boot order of the hard drives on the system, so I entered bios and selected the secondary drive as the primary boot drive and booted sucessfully into Fedora and finished the installation process.

I installed Grub at the beginning of the Linux partition during installation not in the MBR, so when I reboot bios doesn't see Fedora. I was extremely nervous about overwritting the MBR on my primary drive and I wasn't entirely sure that when I was prompted by Grub to install in the MBR that it would install it on the MBR of my secondary drive.

One of my concerns is my girlfriend uses this PC too and I'm not sure what she would do when presented with the Grub boot screen if she has to reboot the computer if I'm not home.

I could leave my PC set to boot from the secondary drive to access my Fedora install and change the bios settings when I need to use Windoze. Or does it make more sense to re-install Grub so I can dual boot or just switch the bios settings as needed?


Does this make any sense?

Fedora is great, I'm planning on adding the Planet CCRMA upgrades so I'll have a Linux audio/video workstation.

:-)

Linux Frank
administrator
administrator
Posts:239
Joined:Fri Jan 10, 2003 2:06 pm

Post by Linux Frank » Fri Mar 26, 2004 3:19 pm

I think install Grub, set the default to that other OS, and tell your girlfriend that when that screen is visible leave it alone and Windows will come up. I'd give you more specifics on doing this, but I don't have Fedora, and have not dual booted with M$ware in years, and use Lilo. However google will give you more info that you could possibly need for this.

Got to go, weekend break coming up and got to transfer a friend to their Mac (another M$ system bites the dust, he he he he).



http://www.overclockersclub.com/guides/ ... ora_xp.php

Hope this helps some.

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Fri Mar 26, 2004 10:36 pm

Thanks
Google will give you more info that you could possibly need for this.
That's for sure, I hate leaving home without it.

Image ;-)

ZiaTioN
administrator
administrator
Posts:460
Joined:Tue Apr 08, 2003 3:28 pm
Contact:

Post by ZiaTioN » Mon Mar 29, 2004 4:25 pm

Yeah you should have installed grub on your mbr of your primary drive. This will not tamper with your Windows install. Only Windows is greedy enough and crappy enough to damage data and overwrite while writing to the mbr. That is why it is imperative to install Windows FIRST when dual booting and then install Linux second.

The Linux install will recognize there is already a boot record in that disk sector and go elsewhere. Also like was already stated you can set a defualt OS in your /etc/grub.conf file so your system will boot to this OS (if the cursor or selector is not touched) after a set number of seconds (which is also configurable by the user through the config file). This should allow your girlfriend to successfully polute her brain further with a Microsoft product without any issues. :)

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Mon Mar 29, 2004 6:07 pm

your girlfriend to successfully polute her brain further with a Micro$oft product
I can talk to her about Linux until I'm blue in the face to no avail, she's not interested in learning anything new, especially if she doesn't have to, duh.

The only thing bothers me about Fedora is that I can't see or access my Windoze files(NTFS). I was surprised, 'cause before Installing Fedora I tried out the Knoppix Live CD and I was able to access all my files.
I'd like to be able to play my MP3s without having to copy them over to Fedora.
Also it seems that I can't play my video files with Kaboodle, I'm still trying to figure that one out, though I'm happy to have found Grub.conf. file.

Since Fedora is already installed, what do I have to do to get Grub to run again and install itself in my primary drive's MBR?

;-)

User avatar
Void Main
Site Admin
Site Admin
Posts:5716
Joined:Wed Jan 08, 2003 5:24 am
Location:Tuxville, USA
Contact:

Post by Void Main » Mon Mar 29, 2004 6:57 pm

chartoo wrote:The only thing bothers me about Fedora is that I can't see or access my Windoze files(NTFS).
http://linux-ntfs.sourceforge.net/rpm/fedora1.html

Just install the appropriate NTFS RPM from the above link and that problem will be solved.

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Mon Mar 29, 2004 8:18 pm

above link and that problem will be solved.
Awesome Void , you just made my day.

Thanks!

User avatar
Void Main
Site Admin
Site Admin
Posts:5716
Joined:Wed Jan 08, 2003 5:24 am
Location:Tuxville, USA
Contact:

Post by Void Main » Tue Mar 30, 2004 7:24 pm

Another way to intstall the NTFS support is with apt if you have the dag repositories in your sources.list.d:

Code: Select all

# apt-get install kernel-module-ntfs
# apt-get install kernel-module-ntfs#2.4.22-1_2.4.22_1.2174.nptl.rhfc1.dag

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Tue Mar 30, 2004 8:51 pm

Another way to intstall the NTFS support is with apt if you have the dag repositories in your sources.list.d:

Code:

# apt-get install kernel-module-ntfs
# apt-get install kernel-module-ntfs#2.4.22-1_2.4.22_1.2174.nptl.rhfc1.dag
Thanks again.

I dowloaded the NTFS rpm " http://linux-ntfs.sourceforge.net/rpm/fedora1.html " and installed it.

The ntfs module didn't seem to be working after I installed it so I rebooted to see if that would help but, and that's a big butt, before rebooting I found the panel that let me change my video card driver. I saw that the ATI 9600 Pro was listed so I selected the ATI driver and then rebooted.....
You guessed it, Fedora freezes when Gnome starts to load, so I haven't had a chance to work with my new NTFS file access just yet.

I'm at work now, so later this evening I plan to use the Linux rescue function on the Fedora Core 1 installation CD and hopefully fix the video card settings so I can boot to Fedora.

So now my (new) latest project will be to figure out how to get Fedora up and running again. Considering my minimal command line experience I have my hands full and it make take me awhile but I'll get there, eventually.

Fortunately I don't have any created any important files yet so if I have to I can re-install Fedora.

;-)

User avatar
Void Main
Site Admin
Site Admin
Posts:5716
Joined:Wed Jan 08, 2003 5:24 am
Location:Tuxville, USA
Contact:

Post by Void Main » Tue Mar 30, 2004 9:03 pm

Well, I guess you have to live and learn. :) Were you having problems with your video prior to changing it? Usually you don't just want to go in and change the video driver unless you know exactly what you are doing. If X can't start when you boot it should detect this and ask you if you want to temporarily disable the graphical login. Does it do this? If so, log in as root and restore the backup copy of your X configuration file. The configuration tool saves a copy when you change it. Here would be the procedure:

# cd /etc/X11
# cp XF86Config.backup XF86Config

The above is case sensitive. If you only ran the setup once then the above should get you back to working order and you can start X again by typing:

# init 5

If you don't have an XF86Config.backup or you ran the configuration tool more than once (overwriting your backup) then run this:

# redhat-config-xfree86 --reconfig

Usually once you get a good working video setup you want to make a bakup copy of your X configuration file for little events like this.

Now, if you do not get the option to disable X after it tries to start, but instead just hangs on a black or unusable screen then just boot into runlevel 3 at the GRUB menu. You can do this by arrowing to the kernel you want to boot and then press the "a" key. At the end of the kernel line add a space and a the number "3" and press ENTER. The line would look something like this:

Code: Select all

kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ 3
Or take a look here for more info: http://www.redhat.com/docs/manuals/linu ... evels.html

Booting into runlevel 3 will start everything normally except Xwindows. It will allow you to log in as root (or a normal user) at a virtual terminal and do whatever needs to be done (restore your backup X config or run redhat-config-xfree86 in your case).

Regarding your NTFS modules, you wouldn't have had to reboot to use them. What you would have to do is add an entry for your NTFS partition in your /etc/fstab file and then mount it.

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Tue Mar 30, 2004 9:38 pm

Well, I guess you have to live and learn. :)
Yup, that's why I love this stuff, computers, OSs and all.
Frustrating sometimes but hey, what would life be if you didn't have some interesting challenges.
Actually I'm learning more than if Fedora worked right out of the box with no glitches.
If X can't start when you boot it should detect this and ask you if you want to temporarily disable the graphical login. Does it do this?
Nope, Fedora looked like it had almost finished loading the desktop configuration, you know just before the little icon show prior to booting the desktop, and just freezes.

I just printed out your last response so I'll have it with me when I get home.

If your instructions get me out of this mess I'll owe you a Foster's or two.

Thanks ;-)

User avatar
Void Main
Site Admin
Site Admin
Posts:5716
Joined:Wed Jan 08, 2003 5:24 am
Location:Tuxville, USA
Contact:

Post by Void Main » Tue Mar 30, 2004 9:52 pm

chartoo wrote:If your instructions get me out of this mess I'll owe you a Foster's or two.
Now I am a beer (bier) connoisseur but that just ain't right. :)

chartoo
user
user
Posts:32
Joined:Mon Mar 22, 2004 5:43 pm
Location:cerebral cortex
Contact:

Post by chartoo » Wed Mar 31, 2004 12:28 am

You da Man!

Used Fedora Core 1 installation CD1 ran linux rescue,
mounted the sysimage:
chroot /mnt/sysimage
then typed in
# cd /etc/X11
# cp XF86Config.backup XF86Config
as you suggested, rebooted and now I'm loged in, yeah.
I was lucky that the XF86Config.backup was good. :D

Name your posion, mate. ;-)

Kaelan
user
user
Posts:14
Joined:Sat Feb 28, 2004 10:52 am

Post by Kaelan » Thu Apr 01, 2004 12:53 pm

Void Main wrote:Now I am a beer (bier) connoisseur but that just ain't right. :)

LOL... I prefer the term beer snob..

I brew what I drink and drink what I brew..

User avatar
cdhgold
administrator
administrator
Posts:382
Joined:Tue Mar 18, 2003 6:11 pm
Location:Texas

Post by cdhgold » Thu Apr 01, 2004 3:47 pm

[quote=I brew what I drink and drink what I brew..[/quote]

would enjoy sampling your selections

Chris

Post Reply