Just 'tried' to swap my ADSL modem - FAILED :(

Place to discuss anything, almost. No politics, religion, Microsoft, or anything else that I (the nazi censor) deem inappropriate.
Post Reply
Posts: 84
Joined: Sun Jan 30, 2005 2:29 pm
Location: Bristol, UK

Just 'tried' to swap my ADSL modem - FAILED :(

Post by dickinsd »

Ok the title does not really represent the 'story'

I don't want to start from the beginning as that'll take to long. I will just cover a few points that led me to where I am now.

A few years back I finally got my hands on a nice Broadband connection from my local Cable Co. I already had an established home network that had grown over time, but was basically for sharing printers and playing games (games mainly)

Once I had a decent internet connection I shared this connection using 2 NIC's in one PC connected to a hub that connected to everything else in the house, all was well, but I had some little problems with playing online games and streaming media when I was at any other PC than the one that was actually sharing the connection. (I think this was more down to crappy internet connection sharing software and dodgy proxy software)

I decided it was time to introduce a router to my home network.

This router has been excellent, it only has 4 ports, but enough for me, excuding the odd time when I need to un hook one machine so that a friend could connect or something...

Then a year or so later I bought my first Wireless Access Point and PCMCIA card (which I still have/use today) I hooked it up to one of the ports on the router and all was well.

Then just under 2 years ago I moved to a brand new house, and I felt it was not fair to mangle up this nice new house with cables everywhere and holes all over the place (yes my first attempts at home networking were not pretty)
My solution was to ditch the machines I wasn't using anymore, only use cables for the machine in the same room as connection and get wireless for anything else.

As it turned out I only needed to connect one machine via wireless, the other via a cable to my router, my laptop was already wireless AND my 4th PC was no longer needed so I regretfully gave it away...

I have also recently built another computer from older bits and this connects to my router via cable also.

One more Point when I moved into my home the cable co would not install cable, much to my disapoinment so I also needed an ADSL modem for my new ADSL line.

Back towards the point of the post...

My setup (current)

ADSL modem->Router->Wireless Access Point

-1. Wireless Access Point
-2. PC 1
-3. PC 3

Wireless Access Point:
-1. PC 2
-2. Laptop(mine)
-3. Other laptop(friends/family)

The wires behind my desk are a nighmare!

I am now planning to host a simple web page from PC 3, so I want to move this computer to another location as the noise of the fans would do my head in when I am trying to sleep (light sleeper/loud fans - you decide)

Nearly at the point...

A friend offered me a device that could do the work of the ADSL modem AND the Wireless Access Point.

Which brings me to my point.

I have just spent perhaps an hour or more trying to get this thing to work properly.

Don't get me wrong for a simple install, it worked straight away, I hooked it up entered username and password and it was done.

BUT, it uses address's I do not want to use (for my own reasons), it is very insecure in that you have no way to close HTTP & Telnet ports (for remote connections to ADSL modem) and a quick port scan at grc.com showed all of the other ports to be closed instead of stealthed.

Then there was the internal setup. This was pretty damned fidly, granted I did not have a manual, perhaps I made some mistakes that did not need to be made, but I certainly made a couple of mistakes which locked me out of the modem requiring the old "Pen in a hole" resolution, such a reset required me to go through everything from scratch - great.

But the 2 biggest issues I had with the device where
1: its lack of MAC access list
2: How unbelievably slow it was at assigning IP address's.

In my area I have at least one neighbour that has a wireless setup as I accidentally found it at one point, at this point I suddenly realised that I might be paying for other people to use my internet connection, but I did not want to use the WEP keys to lock out unwanted guests as I would have to give the key to anyone I wanted to access my network, I knew I would forget the key or loose the paper so could not be bothered with that, so I went for the higher risk, but effective enough method of just restricting access by MAC, this works well.

The speed of the IP assignment may not bother people on the whole, but I find with Fedora it just sits there till it gets an IP address, I guess there is a counter that I could modify as it does eventually skip this step if my Access Point has been powered down.
The new access Point seemed to cause both machines to sit there for about 60-90 seconds JUST waiting for an IP address, my existing Access Point assigns an IP address within 30 seconds.

Yeah maybe an extra 60 seconds is not a long time, but add this to the effort involved in getting this far, AND the lack of MAC list, I have unplugged the offending device and returned to my old/ugly/WORKING setup.

And the Device is:

Epic Router AWR-8210

Stay away people!


User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA

Post by Void Main »

30 seconds would even be too long if you ask me. It should only take a couple of seconds to pull a DHCP assigned address. Regarding the security of the device (or lack thereof) and the DHCP issues I would probably suggest using somethign like the WRT54G (or WRT54GS even better) Linksys unit behind your cable modem. Use the wireless functionality of the LinkSys and turn it off on the cable modem. The only device that would talk directly to the cable modem and beyond would be the LinkSys device. There are several devices out there like the WRT54G but as you can see I am a fan of that particular model:


Post Reply