Got a New HP laptop from Wal-Mart ($378)

Place to discuss anything, almost. No politics, religion, Microsoft, or anything else that I (the nazi censor) deem inappropriate.
Post Reply
User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Got a New HP laptop from Wal-Mart ($378)

Post by Void Main » Sat Nov 26, 2005 6:15 pm

I went to Wal-Mart at 5:00am for the day after Thanksgiving sale to get that $378 laptop. My daughter will be heading off to college soon so I figured that would make a nice laptop for her. It's an HP Pavilion ze2000 with a 1.6Ghz AMD, 256MB RAM, 40GB drive, 15" LCD, DVD reader/CD burner, 2 USB ports, built-in modem, Ethernet and 54g wireless, S-Video and external monitor ports, mic and headphone ports. It came with XP home, Works, etc so of course the first thing I did was slap Fedora Core 4 on this baby. Everything seems to work just great and it looks like I shouldn't even have any trouble with the built-in wireless using ndiswrapper which I am about to configure as soon as I get done typing this. My dad also picked one up and I told him if he didn't want it I would buy it from him for my son. I am extremely pleased with it so far.

Jenda
programmer
programmer
Posts: 156
Joined: Mon May 23, 2005 9:46 am
Location: Prague, Czech Republic
Contact:

Post by Jenda » Sun Nov 27, 2005 6:37 am

It seems to me that you payed an extra $100 for having to reinstall the OS...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Nov 27, 2005 7:20 am

Yeah, I should try and get my refund. On another note, I haven't been so lucky in getting a wireless connection. I can get the driver loaded with ndiswrapper and the interface appears to be working but using the same wpa_supplicant configuration I am using on my other laptop I can't get a WPA connection. Seems to be failing authentication. My other laptop usese madwifi drivers where this one needs to use ndiswrapper because it has a Broadcom BCM4318 (pciid: 14e4:4318). I haven't tried no encryption or WEP yet but it can see the access point so I think I should be able to get it working.

ZiaTioN
administrator
administrator
Posts: 460
Joined: Tue Apr 08, 2003 3:28 pm
Contact:

Post by ZiaTioN » Sun Nov 27, 2005 10:42 am

Have you tried DriverLoader?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Nov 27, 2005 7:52 pm

Well no I hadn't tried it but now I have. I still couldn't get WPA working just yet. I think ndiswrapper (and DriverLoader) are loading the driver just fine. There is just something not working with wpa_supplicant (I believe anyway). I have a couple of extra WPA55AG Linksys cards lying here so I just stuck one of them in there and install madwifi for now which brought WPA right up without a problem. I'll mess with it some more later as I am pretty sure I should be able to make it work.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Dec 02, 2005 8:40 pm

I finally pried the new laptop from my kids and got the built-in WIFI working. I also installed the proprietary ATI drivers so I have accelerated video and my Goggles DVD player actually goes full screen now. So basically everything works great on this thing. What a great way to spend 300 bucks.

I booted up the KNOPPIX DVD and loaded ndiswrapper and installed the bcmwl5a.inf from the driver directory that came on the laptop. I brought up the interface and fired up wpa_supplicant with my working wpa_supplicant.conf and bingo it worked. So I checked the versions of ndiswrapper and wpa_supplicant on the KNOPPIX DVD and realized the wpa_supplicant on the DVD was newer than what I was running in FC4. I downloaded the new wpa_supplicant and that got things working in FC4. I'm running ndiswrapper v1.5 and wpa_supplicant v0.4.6 (even though I see there is a v0.4.7 out that will probably work too).

Regarding the ATI drivers I was reasonably impressed with the ATI installer:

Image

So, there are only two things I haven't tested on the laptop and that is the built-in modem and the S-Video port but I have no need for them at the moment.

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 » Mon Dec 05, 2005 2:04 pm

That's pretty sweet that your kids dig Linux. It's probably easier on the youngsters (probably my age!) than it is on the older folks to switch. Grab em while they're young, and get them hooked. Too many people fuddle away with Windows because it is the only thing they know, and can't be bothered to learn something new, even when doing so would be exponentially beneficial to them.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Dec 05, 2005 8:29 pm

My kids grew up with Linux. They actually have rarely touched Windows. There was a few times many years ago here at home and I'm sure they get a dose at school periodically. Other than that if they want to use a computer they use Linux. My daughter is in 12th grade and just got her first college acceptance letter today and my son is in 10th grade. Not once have I ever had to rebuild a computer or fix something they've screwed up. However, they *are* just users and don't really have any in depth interest in computers (programming etc). I am actually a little happy about that. I have a dream of some day moving into a cabin in the hills far away from any computers or internet or cable TV with the 150 channels full of nothing but commercials. You might think of me as a Ted Kaczynski but without the bombs. :)

Jenda
programmer
programmer
Posts: 156
Joined: Mon May 23, 2005 9:46 am
Location: Prague, Czech Republic
Contact:

Post by Jenda » Mon Dec 12, 2005 9:32 am

Good luck with that. I recommend a lot of books and a musical instrument of choice - piano is good :).

Post Reply