gtk-gnutella - no hosts/nodes except pseudo UDP node.

Discuss Applications
Post Reply
User avatar
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland

gtk-gnutella - no hosts/nodes except pseudo UDP node.

Post by Calum »

hi there,

i am using mandriva 2008 (which i changed from Fedora for several reasons) and have just installed gtk-gnutella via urpmi. my current version is gtk-gnutella/0.96.3-12293 (2006-11-09; GTK2; Linux i686) though i have tried several older versions all with the same problem, and each time i deleted ~/.gtk-gnutella in case the problem was config based.

i have opened a port in the firewall GUI that mandrake has, and set the same port for gtk-gnutella to use:

Code: Select all

[calum@harvey ~]$ grep listen_port ~/.gtk-gnutella/config_gnet
listen_port = 29024
i have found, after much searching, several lists of active gwebcache nodes which i have tried to add one by one in the GnutellaNet view, but the only node showing, regardless of what i do is the first line, saying "Pseudo UDP Node (IPv4)" and of course i can't search for anything. The Hostcache view shows zeroes the whole way down. Waiting for an interminable amount of time doesn't help. It's set to connect to 3 ultrapeers, and to try to keep between 32 and 40 connections up. It is set to use up to 10 connections to try to connect more quickly.

bittorrent is installed and working on this system.

I have tried to find the answer to this but have not been able. I have found many comments about how if a person is having problems with gtk-gnutella they should try xyz, amule or whatever your favourite one is. I'm not interested. gtk-gnutella has no reason why it shouldn't work. It worked under Fedora, so it should work now.

Any ideas for how to configure this so it will work please?
Thanks in advance.

Post Reply