'save settings on exit'

Place to discuss Fedora and/or Red Hat
Post Reply
worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

'save settings on exit'

Post by worker201 »

I didn't have this logout box checked, and I found I was losing some things that I shouldn't be losing. For example, I added a new folder to my /mnt directory, and a line in fstab to define it (a vfat partition for Win and Linux to share). The fstab line worked, and I could mount the drive, but anytime I logged off, it would disappear.

I didn't think this is what was meant by 'save settings on exit' - what gives?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

The "save settings on exit" have nothing to do with mounts. It has to do with saving your session (when you log back on it should open the apps you had open when you logged off). What it sounds like you are doing is creating some directories under /mnt and then mounting something on /mnt (which would hid any directoried you actually created under /mnt before mounting the file system. It is possible that this could be happening? Could you paste in a copy of your fstab?

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 »

fstab wrote:LABEL=/1 / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/sda4 /mnt/zip auto user,noauto,owner,kudzu 0 0
/dev/fd0 /mnt/floppy auto user,noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
To get the drive to mount, I add this line to fstab:

Code: Select all

/dev/hda5   /mnt/windows   vfat   user,noauto,owner,kudzu 0 0
and create this directory:

Code: Select all

mkdir /mnt/windows
And it all disappears whenever I restart the computer. Unhappy :( :(

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

What happens when you remove the "kudzu" option and why the "noauto" option? If it were mine the line would look more like this:

Code: Select all

/dev/hda5     /mnt/windows      vfat    umask=0222   0 0
It looks like you copied one of the fstab entries for one of your "removable" devices which is not really what you want here.

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 »

Void Main wrote:What happens when you remove the "kudzu" option and why the "noauto" option? If it were mine the line would look more like this:

Code: Select all

/dev/hda5     /mnt/windows      vfat    umask=0222   0 0
It looks like you copied one of the fstab entries for one of your "removable" devices which is not really what you want here.
Well, to be perfectly honest, I have no idea what 'kudzu' and 'noauto' mean. :wink: If you could explain that 'umask', that would be swell too.

The thing that irks me is that this same code worked really well before. For reasons beyond my ken, I decided to completely reinstall FC1 over the weekend, and things that were great before are not so great anymore. This is an exact copy of my fstab from the previous installation, and I don't see why it won't work.

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 »

I found a neat site that gave me some interesting info about how to mount vfat drives:

http://www.userlocal.com/tips/fatmounting.php

I followed his instructions, and the only thing I have to add is that 'groupad' is located in /usr/sbin on FC1, which might not be in your path.

Hope this helps some people out there.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I don't see how it could have worked like you had it. Are you saying the line I gave you didn't work? All the options are in the man page:

$ man fstab
$ man mount

Most of the options are explained in the "mount" man page. The "kudzu" option is not one of the ones mentioned in the mount man page but that one is the one causing the entry to be deleted when you reboot. More on that later. The "umask=0222" is actually probably not what you want but I used it as a safe example. Since FAT/FAT32 file systems don't know anything about ownership or permissions you have to tell it at mount time what sort of access you want on the entire file system. umask=0222 would result in all files being set to r-xr-xr-x and owned by "root", that is everyone can read everything but nobody can delete or change anything. If you want full access for everyone use "umask=0000". You can also set the owner and group if you want so in combination with a umask statement you could restrict access based on users/groups. "noauto" means not to automatically mount the partition at boot time. "owner" means only the user that owns the device file (/dev/hda5 in your case) can mount the file system. "user" means any user can mount the file system. Like I said, all of these options are usually used for removable file systems (CD, floppy, zip disk, etc) and wouldn't usually be used on normal hard disk partitions.

Now on to the kudzu option. Kudzu is a hardware detection utility that runs on bootup in Red Hat. If it finds a new device like a CD-ROM drive that you installed it will add an entry automatically for that in your /etc/fstab and put "kudzu" in the options, letting kudzu know that it is allowed to manipulate that line if it needs to (including deleting it). Since you put the "kudzu" option in the fstab and kudzu doesn't know anything about any device associated with it (it didn't put it there) so it deletes the line. More on this here:

$ man updfstab

Oh, and I think if you search these forums you might find that this question has been answered a few times. Here's one example where I gave an example very much like the site you refer to came up with:

http://voidmain.is-a-geek.net/forums/vi ... .php?t=620

worker201
guru
guru
Posts: 668
Joined: Sun Jun 13, 2004 6:38 pm
Location: Hawaii

Post by worker201 »

Gotcha. I agree, it may have been the kudzu, now that I know what that does.

After following the instructions from that other site I mentioned, the guid is now set, and I added myself to the group.

In short, everything works ok now. Thanks.

Post Reply