Turn off idle Harddrive FC3

Place to discuss Fedora and/or Red Hat
Post Reply
Maniaman
scripter
scripter
Posts: 94
Joined: Tue Mar 11, 2003 5:10 pm

Turn off idle Harddrive FC3

Post by Maniaman » Sat Jan 15, 2005 4:46 pm

Is there any way to turn off a harddrive after something like 30 minutes of idle time in FC3?

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Sun Jan 16, 2005 7:01 pm

On all my machines I set it in the BIOS - and that seems to work.
Might not be available on very old versions.

Not yet been able to figure out how to stop the fan running all the time
on my laptop with FC3. It is only supposed to start running when the machine
gets hot.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Jan 16, 2005 7:46 pm

What kind of laptop do you have? My Compaq fan works properly. That's a function of ACPI right? I do have an HP 1U server that sounds like an airplane about to take off because the fans are always hi gear. They are also supposed to throttle. I guess I should actually search to see if there is a solution.

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Tue Jan 18, 2005 6:18 pm

It is a local machine by Mustek South Africa and was
an insurance replacement for my previous one fried by lightning.
Came pre-installed with m$ 2k - on that the fan worked the way I
expected. Was removed fairly fast and replaced in turn with RH7.2,
7.3, 8, 9, FC1 and now FC3.

As I never needed to open the box all the way except to replace the
disc drive, I have no idea who made the motherboard - allthough on
the bottom it says made in Taiwan - FCC ID EUN2000.

Thus all I have is what came on the disc with the machine.
-------------------------------------------------------------------
CPU - Socket 7 CPU
- AMD K6-2P 450MHz
- (Thermal Design is up to 22 watts, above
which Clock Throttling kicks in)
Memory - One 144pin SO-DIMM Slots for Factory/Dealer
- Base Memory of 16/32/64/128 MB SDRAM(3.3V)
- PC-100 SDRAM Specification
User Installable Memory
- One 144pin (64-bit) DIMM Slot
BIOS - 512KB Flash Phoenix BIOS
HDD - Dealer configurable 2.5" Format(12.7 or
9.5mm High)HDD Module;
- Bus Mastering, Ultra DMA 33, Support for
LBA Scheme
Video - Trident Blade 3D/AGP Graphic Engine
I/O Ports - One DB 15-Pin (3-row) VGA Port
- One DB 25-pin Printer Port
- One DB 9-pin Serial Port
- One Mini Din 6-pin PS/2 Port
- One S-video Out Port
- Two USB Ports
- One IR Port (SIR/FIR)
- One DC-in Jack
- One 80-pin Docking Port for Port
Replicator
Audio Ports - One Stereo Line In Jack
- One Headphone/ Line Out Jack
- One Microphone Jack
- Sound Volume Controlled Thumb Wheel
Adjustment
Power Management - SMM Fully Supported

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jan 18, 2005 6:37 pm

Hmmm, it must not support ACPI. I can tell what the temperature of my laptop by:

Code: Select all

$ cat /proc/acpi/thermal_zone/C15E/temperature
temperature:             43 C
Do you have anything under /proc/acpi? There are several other goodies under that directory on mine. On a side note I found out that the fans on the HP server I was referring to were running wide open because it doesn't support ACPI. HP does have a linux health driver/service to install for monitoring and taking action on the various hardware. After installing this the fans throttled back and no longer sounded like an airplane taking off.

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Wed Jan 19, 2005 3:36 pm

yep - no /proc/acpi directory
seems I'll have to open the box to get something of the mobo
and check the manufacturing sites.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Jan 23, 2005 11:24 am

Hey, I think you can use the "hdparm" command to set this for each hard drive. If it works you can add the appropriate options to your /etc/sysconfig/harddisks file. See the man page for hdparm for more info.

kovax
scripter
scripter
Posts: 85
Joined: Mon Jan 24, 2005 9:47 am
Location: Jacksonville, USA
Contact:

Server Fans

Post by kovax » Wed Jan 26, 2005 10:49 am

If you are running a HP server you will need to install their server management software. I had the same problem with a Compaq. I loaded the SIM Sofware and the server is quiet now.

Good Luck

Post Reply