atrpms repository broke apt-get

Place to discuss Fedora and/or Red Hat
Post Reply
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium

atrpms repository broke apt-get

Post by Ice9 »

I spent the whole evening yesterday trying to fix my wife's box.
When doing an apt-get dist-upgrade a LOT of packages were scheduled for upgrade.
I went through with it and was planning to fix some issues she was having with the flash plugin and with xmms after that.

Upgrade done, I tried to fire up synaptic.
I wouldn't start so I looked for installed flash packages with apt-cache search and saw 2 different plugins installed for mozilla.
I uninstalled them both and wanted to just reinstall one of them, and that's when the problems really started.
When I tried to install whatever package, I got:
file from package xxx conflicts with file from atrpms-package-config
Read about some conflicts with atrpms on the red hat mailing lists so I removed the entries from sources.list and removed the offending atrpms-package-config.
Boy was I wrong!
Now apt-get doesn't work at all anymore, I would have to run apt-get -f install and it wants to uninstall more than half of the system.
I can still use rpm to install software and everything seems to work ok so far but apt-get refuses service.

I'll try some other stuff tonight like adding the atrpms and the kde-redhat repos again or remove even more of the conflicting packages I think I don't need but I've nearly had it with Fedora, far too many little bugs and inconsistencies as far as I'm concerned.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA

Post by Void Main »

Hmmm, I don't personally use atrpms because I think I ran into a very similar problem. I was able to remove the offending packages or replace them with the non-atrpm packages but I think I did it manually using RPM. This was quite a while ago and I haven't used atrpms since and haven't had a problem since. Not sure what to suggest though but I think if I had my hands on the system I could probably resolve it fairly quickly. You just have to figure out what is installed from atrpms and figure out what should be installed instead of it and use "rpm" to replace these packages. You may have to use "--nodeps" and possibly "--force" a few times until you get everything switched out.

Post Reply