apt-get... "E: Dynamic MMap ran out of room"

Place to discuss Fedora and/or Red Hat
Post Reply
User avatar
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland

apt-get... "E: Dynamic MMap ran out of room"

Post by Calum »

Code: Select all

[root@harvey ~]# apt-get update ; cat /etc/apt/apt.conf
Get:1 http://ayo.freshrpms.net fedora/linux/4/i386 release [1835B]
Get:2 http://apt.sw.be fedora/4/en/i386 release [472B]                         
Get:3 http://apt.sw.be fedora/3/en/i386 release [505B]                         
Get:4 http://apt.sw.be fedora/2/en/i386 release [507B]                         
Get:5 http://apt.sw.be fedora/1/en/i386 release [498B]                         
Get:6 http://apt.sw.be dries/fedora/fc4/i386 release [486B]                    
Get:7 http://apt.bioxray.dk fedora/fc4/i386 release [1071B]                    
Get:8 http://ccrma.stanford.edu fedora/4/i386 release [1619B]                 
Fetched 6993B in 0s (14.3kB/s)                         
Hit http://ayo.freshrpms.net fedora/linux/4/i386/freshrpms pkglist
Hit http://ayo.freshrpms.net fedora/linux/4/i386/freshrpms release
Hit http://apt.sw.be fedora/4/en/i386/dag pkglist                              
Hit http://apt.sw.be fedora/4/en/i386/dag release                              
Hit http://apt.sw.be fedora/3/en/i386/dag pkglist                            
Hit http://apt.sw.be fedora/3/en/i386/dag release                            
Hit http://apt.sw.be fedora/2/en/i386/dag pkglist                            
Hit http://apt.sw.be fedora/2/en/i386/dag release                            
Hit http://apt.sw.be fedora/1/en/i386/dag pkglist                            
Hit http://apt.sw.be fedora/1/en/i386/dag release                            
Hit http://apt.sw.be dries/fedora/fc4/i386/dries pkglist                     
Hit http://apt.sw.be dries/fedora/fc4/i386/dries release                     
Hit http://apt.bioxray.dk fedora/fc4/i386/os pkglist                         
Hit http://ccrma.stanford.edu fedora/4/i386/core pkglist                     
Hit http://apt.bioxray.dk fedora/fc4/i386/os release                         
Hit http://apt.bioxray.dk fedora/fc4/i386/xray pkglist                         
Hit http://ccrma.stanford.edu fedora/4/i386/core release                       
Hit http://apt.bioxray.dk fedora/fc4/i386/xray release                       
Hit http://apt.bioxray.dk fedora/fc4/i386/local pkglist                        
Hit http://ccrma.stanford.edu fedora/4/i386/updates pkglist                    
Hit http://apt.bioxray.dk fedora/fc4/i386/local release                      
Hit http://apt.bioxray.dk fedora/fc4/i386/xray srclist                       
Hit http://apt.bioxray.dk fedora/fc4/i386/local srclist                        
Hit http://ccrma.stanford.edu fedora/4/i386/updates release                    
Hit http://ccrma.stanford.edu fedora/4/i386/extras pkglist
Hit http://ccrma.stanford.edu fedora/4/i386/extras release
Hit http://ccrma.stanford.edu fedora/4/i386/planetccrma pkglist
Hit http://ccrma.stanford.edu fedora/4/i386/planetccrma release
Hit http://ccrma.stanford.edu fedora/4/i386/planetcore pkglist
Hit http://ccrma.stanford.edu fedora/4/i386/planetcore release
Reading Package Lists... Error!                        
E: Dynamic MMap ran out of room
E: Error occured while processing perl-XML-DOM (NewVersion1)
E: Problem with MergeList /var/state/apt/lists/apt.sw.be_fedora_2_en_i386_base_p                                                               kglist.dag
E: The package lists or status file could not be parsed or opened.
// User customizable configuration

  // Uncomment to disable GPG-signature checking for packages
  // GPG-Check "false";
  // Uncomment to prevent kernel being handled along with (dist-)upgrade
  // Upgrade-Virtual "false";
  // Uncomment to hold packages with modified config files in (dist-)upgrade
  // Preserve-Config "true";

// Options for the downloading routines
  // Retries "1";
  // http::Proxy "http://user:password@proxy-server.domain.tld:port/";
  // http::Proxy "http://proxy-server.domain.tld:port/";
Allow-Duplicated { 

Install-Options { "--oldpackage" };

APT::Cache-Limit "8388608";

all of a sudden apt won't work! i tried adding that APT:Cache-Limit bit in apt.conf but it hasn't changed a thing.


User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA

Post by Void Main »

Have you tried increasing that number to like 25000000 or 50000000? On second look, why do you have repositories for all those different versions of FC? You don't really want to mix versions like that. I think if you trim that down to just your version you won't get that error message.

User avatar
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland

Post by Calum »

looks like that's sorted it right enough. i have no idea how that happened, i don't usually do that sort of thing.

thanks though!

Post Reply