2.4.32-gentoo kernel sources; init problems(Sun Blade 100)

Place to discuss Gentoo
Post Reply
X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

2.4.32-gentoo kernel sources; init problems(Sun Blade 100)

Post by X11 » Fri Dec 30, 2005 7:45 am

I have built the 2.4.32 kernel and it refuses to execute init however it mounts the root filesystem fine. However I have also built the normal 2.4.32 sources (not the -gentoo branch) and it works fine.

I want to use the -gentoo sources because they have the grsecurity options and PaX and all that leet shizzle.

Boot output is below...

Code: Select all

Sun Blade 100 (UltraSPARC-IIe), No Keyboard
OpenBoot 4.0, 512 MB memory installed, Serial #51268593.
Ethernet address 0:3:ba:e:4b:f1, Host ID: 830e4bf1.



Boot device: disk  File and args:
SILO Version 1.4.9
\
boot: gentoo-secure
Allocated 8 Megs of memory at 0x40000000 for kernel
Loaded kernel version 2.4.32

Remapping the kernel... done.
Booting Linux...
PROMLIB: Sun IEEE Boot Prom 4.0.45 2001/02/08 14:33
Linux version 2.4.32-sparc (root@sarah) (gcc version 3.3.5 (Gentoo Linux 3.3.5))
 #6 Fri Dec 30 15:18:55 EST 2005
ARCH: SUN4U
Ethernet address: 00:03:ba:0e:4b:f1
On node 0 totalpages: 64941
zone(0): 98177 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Found CPU 0 (node=f006dbd4,mid=0)
Found 1 CPU prom device tree node(s).
Kernel command line: root=/dev/hda1
Calibrating delay loop... 1002.70 BogoMIPS
Memory: 510264k available (2200k kernel code, 352k data, 120k init) [fffff800000
00000,000000002ff02000]
Dentry cache hash table entries: 65536 (order: 7, 1048576 bytes)
Inode cache hash table entries: 32768 (order: 6, 524288 bytes)
Mount cache hash table entries: 512 (order: 0, 8192 bytes)
Buffer cache hash table entries: 32768 (order: 5, 262144 bytes)
Page-cache hash table entries: 65536 (order: 6, 524288 bytes)
POSIX conformance testing by UNIFIX
PCI: Probing for controllers.
PCI: Found SABRE, main regs at 000001fe00000000, wsync at 000001fe00001c20
SABRE: Shared PCI config space at 000001fe01000000
SABRE: DVMA at c0000000 [20000000]
PCI-IRQ: Routing bus[ 0] slot[ 8] map[0] to INO[23]
PCI-IRQ: Routing bus[ 0] slot[ c] map[0] to INO[06]
PCI-IRQ: Routing bus[ 0] slot[ c] map[0] to INO[1c]
PCI-IRQ: Routing bus[ 0] slot[ c] map[0] to INO[24]
PCI-IRQ: Routing bus[ 0] slot[ d] map[0] to INO[0c]
PCI-IRQ: Routing bus[ 0] slot[13] map[0] to INO[0f]
PCI-IRQ: Routing bus[ 1] slot[ 0] map[0] to INO[19]
PCI-IRQ: Routing bus[ 1] slot[ 2] map[0] to INO[15]
PCI0(PBMA): Bus running at 33MHz
isa0: [dma -> (floppy) (parallel)] [power] [serial] [serial]
ebus0: [flashprom] [eeprom] [idprom]
PCIO serial driver version 1.54
su(serial) at 0x1fe020003f8 (tty 0 irq 12,7eb) is a 16550A
su(serial) at 0x1fe020002e8 (tty 1 irq 12,7eb) is a 16550A
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
i2c-core.o: i2c core module version 2.6.1 (20010830)
i2c-dev.o: i2c /dev entries driver module version 2.6.1 (20010830)
i2c-algo-bit.o: i2c bit algorithm module
i2c-proc.o version 2.6.1 (20010830)
pty: 256 Unix98 ptys configured
rtc_init: no PC rtc found
sungem.c:v0.97 3/20/02 David S. Miller (davem@redhat.com)
eth%d: MII PHY ID: 437420 Enable Semiconductor
eth0: Sun GEM (PCI) 10/100/1000BaseT Ethernet 00:03:ba:0e:4b:f1
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ALI15X3: IDE controller at PCI slot 00:0d.0
ALI15X3: chipset revision 195
ALI15X3: 100% native mode on irq 4,7cc
    ide0: BM-DMA at 0x1fe02000a20-0x1fe02000a27, BIOS settings: hda:pio, hdb:pio

    ide1: BM-DMA at 0x1fe02000a28-0x1fe02000a2f, BIOS settings: hdc:pio, hdd:pio

hda: ST315310A, ATA DISK drive
hdb: PIONEER 12X DVD-ROM 1.16, ATAPI CD/DVD-ROM drive
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide0 at 0x1fe02000a00-0x1fe02000a07,0x1fe02000a1a on irq 4,7cc
hda: attached ide-disk driver.
hda: 29888820 sectors (15303 MB) w/2048KiB Cache, CHS=29651/16/63
hdb: attached ide-cdrom driver.
hdb: ATAPI 40X DVD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.12
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4 p5 p6
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
host/usb-uhci.c: $Revision: 1.275 $ time 15:24:00 Dec 30 2005
host/usb-uhci.c: High bandwidth mode enabled
host/usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
host/usb-ohci.c: USB OHCI at membase 0x1ff02000000, IRQ 9,7e4
host/usb-ohci.c: usb-00:0c.3, PCI device 108e:1103
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 4 ports detected
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
Linux video capture interface: v1.00
mice: PS/2 mouse device common for all mice
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 65536 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Mounted devfs on /dev
grsec: exec of /sbin/init (/sbin/init ) by /[swapper:1] uid/euid:0/0 gid/egid:0/
0, parent /[swapper:0] uid/euid:0/0 gid/egid:0/0
Kernel panic: No init found.  Try passing init= option to kernel.
 Press L1-A to return to the boot prom
Anyone know what the problem could be?

X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

Post by X11 » Sun Jan 01, 2006 6:04 am

Nevermind I got the 2.6.14.3 kernel working.

Post Reply