Page 1 of 2

Gentoo for the first time EVER!

Posted: Fri Nov 23, 2007 1:01 pm
by JoeDude
I'm going to try it on one of my boxes...Any suggestions before I start (It is a machine which I will not need for a few days)

Posted: Sat Nov 24, 2007 4:43 pm
by Void Main
I built a Gentoo machine "once". It was a lot more time to install as I am sure you are aware. When I got finished I had a Linux machine not much different than any other Linux machine. No opinion one way or the other. You shouldn't have any trouble though. One thing Gentoo is good at is documentation.

Posted: Sat Nov 24, 2007 4:54 pm
by JoeDude
I started an hour ago, I am sitting here looking at:

Code: Select all

*Finalizing udev configuration ...
which has been up there for 45 minutes...I don't see my hard drive grinding away or my DVD-ROM spinning...I wonder if it's actually doing anything...the _ is just sitting there blinking at me...

I'm using the Gentoo handbook, but so far, the installation has only matched one part of it...

I'll come back and check it tomorrow.

Posted: Sat Nov 24, 2007 5:34 pm
by Void Main
I would say something must be broken. Any messages on any of the other virtual terminals to indicate a problem? (ALT+F1 through ALT+F8)

Posted: Sat Nov 24, 2007 5:45 pm
by JoeDude
It won't even switch to the other terminals...hmmm, maybe a reboot is in order....

Posted: Sat Nov 24, 2007 5:54 pm
by JoeDude
rebooted, I selected the gentoo default kernel and US keymap, now I am waiting as it tries to boot...last time I allowed it to do that automagically, let's see if this works, if not, I may have to move from the Gentoo 2007 full (live) DVD to the alternate install.

I am doing this on an old box...(Intel Celeron 466Mhz, 256Mb RAM, 40 Gb Hd). According to thier web page, it meets min specs...hmm

Oh, its back to finalizing udev...and everything has stopped again...

Aha! Not for the live CD, I have to use the minimal install for this machine! BRB


Hey! Look at that, it worked! I'm on the splash screen now...time to read more directions and prepare!

Posted: Sun Nov 25, 2007 5:53 am
by JoeDude
OK, I stopped last night b'cause I was tired.

Resumed this morning.

Set up network - check - less than 1 minute
set up user accounts - check - less than 1 minute
set up partitions - check - about 5 minutes
assign filesystems - check - about 5 more minutes
download stage3 - check - about 15 minutes
tar stage 3 - check - about 10 minutes
download portage image - check - about 20 minutes
tar portage image - check - about 35 minutes
configuring compile options - check - 5 minutes
installing base system - working - problem: is not recognizing bash commands...that's what I get for actually reading the directions! after chrooting to /mnt/gentoo, I find that env-update isn't working nor is emerge --sync...So now I'm stuck right smack in the middle of it! Research time.

...And I haven't even gotten to the long parts yet...

Posted: Sun Nov 25, 2007 12:25 pm
by JoeDude
got it sorted, I had to do my make.conf based on a model someone in the gentoo forums posted for me. I'm syn'ing now. I'll let you know how far I get this time!

I will admit one thing, besides being annoying, it does make you feel pretty powerful to type a few lines of commands and then have an hours worth of info scrolling across the screen. OK, maybe more annoying than cool, but it's something anyway.

The experiment is to see if it makes this old clunker any noticeably faster. I don't expect it will, but it's an adventure into something new if nothing else.

Posted: Mon Nov 26, 2007 5:58 am
by JoeDude
OK, made it all the way through, got the system installed, put in grub, made a grub.cong, removed the disc, rebooted...

YEAH there's the grub with the Gentoo splash! I did it...

Select Gentoo Linux 2.6.22-r9...

File not found

ARRRGGGGGGGGGGHHHHHHHHHHHHHHHHHHh

Posted: Tue Nov 27, 2007 8:21 pm
by insomnia
Seems you don't have that image in your /boot map.

see: http://www.gentoo.org/doc/en/grub-error-guide.xml
(Code Listing 4.2: Grub Output - Booting an Entry)

Posted: Wed Nov 28, 2007 6:44 am
by JoeDude
kewl, thanx

Posted: Thu Nov 29, 2007 11:02 am
by Calum
so....
gentoo is just a distro of linux for installing then? not for using?

i think i'll stick with fedora and the like for now.

Posted: Fri Nov 30, 2007 2:40 am
by JoeDude
My idea was see if it offerred any advantage being installed on an older system. But, as I don't have the time to dedicate to the install, it's drug out for a while now. As I said before, fortunately, it's not a computer I have to have running.

Posted: Wed Dec 05, 2007 8:48 am
by Calum
that's the first time i have ever seen "drug" as the past participle of "drag" well done! i like it.

Posted: Wed Dec 05, 2007 8:56 am
by Void Main
We don't like to follow the rules here. I've heard that all my life and have probably used it many times myself (used in the past tense of "drag" that is).