Page 1 of 1

"Error" when rooting Samsung Galaxy S

Posted: Wed Dec 08, 2010 12:47 pm
by Basher52
Yesterday I upgraded to A 2.2 and it all worked perfect. Was browsing around in the phone and some some neat changes :) Later I thought that I "had to" root it so I went to a Swedish Android site( and did what they said I should do.
No one seems to have any errors with that rooting so I figured its safe.
But not for me it seems. Now it's either so extremely slow that I haven't got the energy to wait and see if the really starts up at all and gets in to the "Home" (waited like 30 minutes) or something isn't as it should be :P
Redid this twice but same "error" all the times.

I can get into both Recovery and also Download mode.
The program "KEIS" that Samsung uses as its program(and usb drivers) for the phone don't seem to recognize the phone as a Samsung Galaxy S but a (think it was) "7 CDC" what ever that is, so I can't get it to download the A 2.2 again.
I DO get "Odin 1.3" to connect to it but I don't know if it "knows" its model. (Odin 1.3 was used in the rooting "action" as I described above).

I'm still browsing around on the Swedish Android forum( and also waiting for my question about this rooting, and google but nothing has made me found anything yet.

As of now it's seems like it's a bricked phone :(

I'll be back later with more info about how it's all going......

Posted: Wed Dec 08, 2010 5:48 pm
by Basher52
Fixed it :)
Found an old version that I could get in with Odin thus getting me back to A2.1(of some kind), but at least it worked :)

Code: Select all

Then since that worked I used Odin again to up it to a A2.2

Code: Select all

and after that rooted it

Code: Select all

and that worked now too :)
Maybe I rooted to a too new version of A2.2 that the root package wasn't made for.

Still haven't learned the firmware names and the first time I saw the name of a firmware with JP in the name made me think that it was for Japan :P

Now that I know how to fix this if it happens again then I'm gonna start play around with it more and hopefully find an app that so I can backup all my added apps so I don't have to DL them again and some other stuff.

Also tried to add back my Contacts but that didn't work trough "KIES" so I think Samsung has remade the file format as the firmware I got now is a bit older then the publicly released.