Xen

Place to discuss Debian Linux and Debian based distributions
Post Reply
User avatar
Void Main
Site Admin
Site Admin
Posts: 5715
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Xen

Post by Void Main » Thu May 10, 2007 8:43 pm

I have Xen up and running on FC6 and successfully installed an FC6 Xen guest. Now I would like to install a Debian Etch Xen guest. I have the basic disk image created but I can't get it to boot with any kernel. Anyone done this? Here are some instructions on how to set up the disk image (down the page a ways):

http://cosi.clarkson.edu/docs/installin ... an%20Linux

insomnia
programmer
programmer
Posts: 123
Joined: Thu Feb 05, 2004 6:58 pm
Location: Belgium, Antwerp

Post by insomnia » Fri May 11, 2007 12:28 pm

Only with Debian in Debian (not really useful).
I originally used this howto:
http://www.howtoforge.com/debian_etch_x ... repository
(but some others as well).

I did manage to use Xen in FC6 as well (seems to work slightly different), but only with an already installed system. It did multi boot, but I never managed to get the guest system fully working (no networking, no sound, ...).

User avatar
Void Main
Site Admin
Site Admin
Posts: 5715
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri May 11, 2007 1:28 pm

Yeah I saw that document also but like you said, it is for Deb under Deb. Maybe I'll install a Dom0 Deb under VMware and then install a DomU Deb under that Dom0 Deb. :) I didn't have any problems with Networking on the FC6 Xen guest. I just used the xenguest-install script and everything worked. Never tried sound though (installed it on a server remotely).

Post Reply