strange behaviour at boot

Place to discuss Debian Linux and Debian based distributions
Post Reply
Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

strange behaviour at boot

Post by Ice9 » Sat Feb 02, 2008 6:20 pm

A couple of days ago my system started to boot really slowly.
Actually the boot sequence seems normal except for the part where it sits at

Code: Select all

Waiting for /dev to be fully populated
for about 20 seconds and then it spits out

Code: Select all

Setting parameters of disc: (none)
after which it only takes 10 seconds for the boot to complete.

Before this started my system booted in like 15 seconds!!
Any ideas what could cause this?
googled around and found mentions about upgrading initrd (which I did), dist-upgraded my whole system a couple of times, even upgraded the kernel (which I normally don't do very often), nothing helped ...

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Tue Feb 05, 2008 5:49 pm

looks like an issue with udev?
did this start happening after upgrading one day?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Feb 05, 2008 6:00 pm

I usually put some debug echo statements in the startup scripts to pin down exactly where the problem is. Many times I have found module loads to hang and cause these kind of problems (firewire modules in particular).

Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

Post by Ice9 » Wed Feb 06, 2008 3:18 am

udev is definitely a possibility, even though there have been known problems with initrd causing this kind of behaviour. Upgrading initrd didn't fix anything in my case.

On top of all that I started to get kinit messages with very long udev refs.
The pc hangs even longer now, as far as I can tell from various readings the kinit messages are related to the kernel checking for a resume image before booting normally. I still haven't found how I can disable that "feature" other than putting noresume in the grub arguments - which doesn't display the kinit message anymore but judging from the wait time the kernel still checks for a resume image.

Would it be safe to remove udev and put the "testing" version on my "unstable" system?

Ice9
guru
guru
Posts: 577
Joined: Thu Jan 09, 2003 12:40 am
Location: Belgium
Contact:

Post by Ice9 » Sun Feb 10, 2008 4:44 pm

Just installed the latest available kernel in the unstable repos (2.6.23.15-slh-smp-1) and the hang time has vanished, /dev populates in 2 seconds like it used to, now I just have to figure out how to tell the kernel to not look for a resume image ...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5712
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Feb 11, 2008 7:13 am

Don't forget to check it for the local root exploit:

http://it.slashdot.org/it/08/02/10/2011257.shtml

Post Reply