Weird USB IDE controller issues...

Place to discuss Debian Linux and Debian based distributions
Post Reply
User avatar
Duo Maxwell
user
user
Posts: 8
Joined: Fri Jul 22, 2005 6:50 pm
Location: not there, there!
Contact:

Weird USB IDE controller issues...

Post by Duo Maxwell » Sat Jan 29, 2011 2:51 am

What up all? Been a long time, got a problem maybe you can decipher:

USB DVD drive, refused to do anything but see the drive till I added /dev/sr0 to /etc/fstab now though I still can't get the DVD to show up in Nautilus anywhere, but I can play it by opening /dev/sr0 in VLC, would like to not have to mount every disc manually. Yes, I'm still a n00b at this after 5 years now.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Re: Weird USB IDE controller issues...

Post by Void Main » Sat Jan 29, 2011 5:59 am

Is this Ubuntu? Are you running Gnome? If so and If you are logged in to the system and if there is a mountable file system on the disk when you insert it it should get mounted automatically under "/media/volumelabel". Do you have gnome-volume-manager installed and set to start automatically? A couple of threads that might help:

http://www.linuxforums.org/forum/debian ... media.html
http://www.linuxforums.org/forum/red-ha ... -disk.html

User avatar
Duo Maxwell
user
user
Posts: 8
Joined: Fri Jul 22, 2005 6:50 pm
Location: not there, there!
Contact:

Re: Weird USB IDE controller issues...

Post by Duo Maxwell » Sat Jan 29, 2011 12:13 pm

Ubuntu 10.10 with the backports and proposed repos, checked for gnome-volume-manager but all that came up in synaptic where halevt and awn-applets-python-core. If I create a folder in /media called cdrom I can see the disc in /media and on the desktop and side bar, but no app will direct to it to play it back without going to the aforementioned /dev/sr0.

I asked on Ubuntu's IRC and it seems I'm not the only one having this issue though, gotta figure out what broke... This only seems to be happening with USB optical drives, USB sticks and HDDs all work properly. Same enclosure with an IDE HDD in it mounts normally using EXT2, HFS+ and NTFS filesystems.

User avatar
Duo Maxwell
user
user
Posts: 8
Joined: Fri Jul 22, 2005 6:50 pm
Location: not there, there!
Contact:

Re: Weird USB IDE controller issues...

Post by Duo Maxwell » Sun Jan 30, 2011 5:52 pm


Post Reply