fglrx problems

Place to discuss Debian Linux and Debian based distributions
Post Reply
X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

fglrx problems

Post by X11 » Mon Feb 13, 2012 2:24 am

I am using debian squeeze, and I tried installing the fglrx drivers from the AMD website. My xorg would not start and gdm would hang (10 years ago gdm quit trying after a few times, what happened?) - so I installed the fglrx drivers from apt and removed ATIs drivers. I am getting segfaults now from anything gl related. Here is me attempting some minecraft...

Code: Select all

john@hayek:~/mcserver$ minecrap
27 achievements
174 recipes
Setting user: KintaroBC, -609661734205374970
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x2ca3b29c, pid=6342, tid=763337584
#
# JRE version: 6.0_26-b03
# Java VM: Java HotSpot(TM) Server VM (20.1-b02 mixed mode linux-x86 )
# Problematic frame:
# C  [libGL.so.1+0x6d29c]  XF86DRIQueryExtension+0x8e
#
# An error report file with more information is saved as:
# /home/john/mcserver/hs_err_pid6342.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted
john@hayek:~/mcserver$ glxgears 
Segmentation fault
john@hayek:~/mcserver$ glxinfo
name of display: :0.0
Segmentation fault
I've probably wrecked the install using the drivers from the AMD website. Does anyone have any ideas on fixing this? I would just reinstall but this is some kind of library mishap and is really interesting. It would be nice to know what happened. I did use the drivers uninstall before installing fglrx from apt.

Post Reply