routine apt-get question

Place to discuss Debian Linux and Debian based distributions
Post Reply
User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

routine apt-get question

Post by Calum »

Code: Select all

claudia:~# apt-get update && apt-get dist-upgrade
Hit http://xnv2.xandros.com xandros2.0-xn/main Packages
Hit http://www.planet-moll.de sarge/main Packages
Hit http://www.planet-moll.de sarge/main Release
Hit http://xnv2.xandros.com xandros2.0-xn/main Release
Hit ftp://ftp.de.debian.org sarge/non-US/main Packages
Hit ftp://ftp.de.debian.org sarge/non-US/main Release
Hit http://xnv2.xandros.com xandros2.0-xn/contrib Packages
Hit ftp://ftp.de.debian.org sarge/main Packages
Hit http://xnv2.xandros.com xandros2.0-xn/contrib Release
Hit ftp://ftp.de.debian.org sarge/main Release
Hit http://xnv2.xandros.com xandros2.0-xn/non-free Packages
Hit http://xnv2.xandros.com xandros2.0-xn/non-free Release
Hit http://xnv2.xandros.com unsupported2.0-xn/main Packages
Hit http://xnv2.xandros.com unsupported2.0-xn/main Release
Hit http://xnv2.xandros.com unsupported2.0-xn/contrib Packages
Hit http://xnv2.xandros.com unsupported2.0-xn/contrib Release
Hit http://xnv2.xandros.com unsupported2.0-xn/non-free Packages
Hit http://xnv2.xandros.com unsupported2.0-xn/non-free Release
Reading Package Lists... Done
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
claudia:~# apt-get install synaptic
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  synaptic: Depends: libc6 (>= 2.3.2.ds1-4) but 2.3.2-7 is to be installed
            Depends: libgcc1 (>= 1:3.3.2-1) but 1:3.3.2-0pre5 is to be installed
            Depends: libstdc++5 (>= 1:3.3.2-1) but 1:3.3.2-0pre5 is to be installed
            Depends: libxml2 (>= 2.6.2) but 2.5.11-2 is to be installed
            Depends: zlib1g (>= 1:1.2.1) but 1:1.1.4-15 is to be installed
E: Broken packages
so, is synaptic not installable? using Xandros btw, with the following /etc/apt/sources.list:

Code: Select all

deb http://xnv2.xandros.com/2.0/pkg xandros2.0-xn main contrib non-free

deb ftp://ftp.de.debian.org/debian-non-US/ sarge/non-US main
deb ftp://ftp.de.debian.org/debian/ sarge main

#If you like to add some multimedia-stuff (mplayer):
#deb http://marillat.free.fr/ testing main

#for k3b:
deb http://www.planet-moll.de/debian/ sarge main

#BTW: Xandros alos have a "unsupported" repository - which seems to be a sarge snapshop for a hudge bunch of files:
deb http://xnv2.xandros.com/2.0/pkg unsupported2.0-xn main contrib non-free
also, the idea of pinning is new to me, but i now have a file at /etc/apt/preferences with this in it:

Code: Select all

Package: libatk1.0-0
Pin: version 1.4.1*
Pin-Priority: 1000

Package: *
Pin: release a=xandros2.0-xn
Pin-Priority: 777

Package: *
Pin: release a=testing
Pin-Priority: 650
the reason for this is to avoid overwriting xandros packages with non xandros packages, and also to ensure a specific version of atk which allegedly is the only version that synaptic will work with, although of course this is moot if i can't install synaptic.

what are your thoughts? don't go looking into it or anything, i need to google for myself to learn properly, but just wanted your thoughts, folks.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

It looks like Xandros must include base libraries that are newer than what are in the Debian apt repository and what Synaptic has been built against thus causing the dependency issues. One way you can probably get around it is to install Synaptic via the source rather than apt, but that pretty much defeats the purpose of apt and dpkg. Now, since you get this error while trying to install Synaptic I would assume that there are going to be other packages that will cause you problems. It might be wise to stick with Xandros repos that have packages compiled against the Xandros installed library versions. But this is all just speculation on my part... Might want to ask that question in the Xandros fourms.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum »

yes a lot of other things (like dillo etc) have the same or similar unresolvable dependencies. apparently xandros 2 is based on the sarge (testing) distro of debian, and 'real' debian is based on the woody or potato branches. allegedly a lot of packages will work but i'll just get used to xandros i think before i start fiddling.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Either that or switch to the Debian unstable repos which should have newer software. But I would still ask for suggestions on the Xandros forums.

Post Reply