Installing DebIan

Place to discuss Debian Linux and Debian based distributions
User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Installing DebIan

Post by Calum »

Anybody happen to know how to install debian in text only mode?
you know when you first boot the installation and you have to type in 'linux' or 'isaide' or whatever, well what do you type to get it to not install graphically?

my video card is oops and debian cannot display anything during install, when it tries to start the x server to give me a graphical install. unlike red hat 7 (which had the same problem) debian does not seem to know it is not displaying properly and so i am left with a blank screen and no way to tell it to install textually.

i read some of the text files that came with the system but couldn't find anything about a text only install. is it really necessary to have an X compatible video card (actually X runs fine in some other linuces) or is it possible to install textually, if so how please?

thanks in advance

Panos
user
user
Posts: 45
Joined: Mon Feb 03, 2003 12:54 pm
Location: Florence, Italy
Contact:

Post by Panos »

I also wrote that in the MES forums: At the boot prompt you could type the following at the boot prompt:

Code: Select all

boot: text
I don't know if that helps though, since I thought Debian does not have a graphical installer.

PS BTW, Void Main congratulations on a great job creating these forums. They're simply great! :wink:
Last edited by Panos on Mon Feb 03, 2003 1:13 pm, edited 1 time in total.

Panos
user
user
Posts: 45
Joined: Mon Feb 03, 2003 12:54 pm
Location: Florence, Italy
Contact:

Post by Panos »

Sorry for doubleposting what's already been posted at the MES forums. If it goes in framebuffer mode, type at the boot prompt:

Code: Select all

boot:nofb
That should do it.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Just curious, don't you have to put "linux" in front of those options? e.g. "boot: linux text", "boot: linux nofb"?

Panos
user
user
Posts: 45
Joined: Mon Feb 03, 2003 12:54 pm
Location: Florence, Italy
Contact:

Post by Panos »

I think it works both ways in recent distros. However, I'm not certain if that would work in distros other than RedHat. For example, neither "boot: text" or "boot: linux text" worked in Calum's case and admittedly the "Welcome" screen in Debian's installer does not include these options. That's really strange because Debian's installation worked fine for me. What's even more strange is that there wasn't any graphical installer. Just a good old text installation, like for example in RedHat 6.0 or SuSE 6.* (my first attempts at Linux :lol: ).

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

That's what I thought. The last time I installed debian there was no graphical (X based) installation. In fact I didn't remember there being one and still don't think there is one. Maybe he's really installing Xandros? :)

According to the Debian installation trouble-shooting section for buggy video cards you should turn off frame-buffer by doing the following:

Code: Select all

boot: video=vga16:off
(may have to preface that with "linux" as I mentioned earlier).

See:
Unsupported Video cards
Last edited by Void Main on Mon Feb 03, 2003 4:02 pm, edited 5 times in total.

Panos
user
user
Posts: 45
Joined: Mon Feb 03, 2003 12:54 pm
Location: Florence, Italy
Contact:

Post by Panos »

Hey, I haven't thought of that. Perhaps Calum is indeed trying to install Xandros :)

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I edited my last message with the instructions for turning off frame-buffer mode which may be his problem. See my last message.

Panos
user
user
Posts: 45
Joined: Mon Feb 03, 2003 12:54 pm
Location: Florence, Italy
Contact:

Post by Panos »

Yep, I bet that's it void main. God you're quick! :)

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum »

void main you god! thank you very much! i haven't tried it yet but if that indeed turns off the framebuffer then i will be very happy.

Also, as far as i can see the debian install screen doesn't let you put proper kernel options as far as i know, but is kind of a script that wants certain input words to decide how to proceed.

will try and will see.

X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

Post by X11 »

If lovin the lord is wrong then i dont wanna be right.
(lord == voidmain)

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

You better watch it X. I'll ban you for being a sick pup. :)

X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

Post by X11 »

I was quoteing an eddie murphy movie.
(Coming to America)

And if you ban me ill just move house and sign up with charter. :P

Anyway i just had this same problem and went to see if it got answered.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Did it fix the problem? I never did hear back..

X11
guru
guru
Posts: 676
Joined: Sun Jan 19, 2003 11:09 pm
Location: Australia
Contact:

Post by X11 »

Well it looks that way to me.

Post Reply