I'm still a n00b, help... my $HOME keeps getting unmounted a

Place to discuss Mandriva Linux
Post Reply
Lennon
n00b
n00b
Posts: 3
Joined: Sun Jul 27, 2003 4:48 pm

I'm still a n00b, help... my $HOME keeps getting unmounted a

Post by Lennon » Sun Jul 27, 2003 5:00 pm

Ok heres how it all started:

I was using gFTP and suddenly as I was uploading my left portion of the window showed "Permission denied" meaning i cant access my home/... directory.

So I went and startedn IceWM which didnt need the home dir, ran linuxconf, added a new user. (important I also changed some flags of the HOME partition so that User can mount it. Then I logged in as the new user. Then I changed to Super Mode, and I noticed that permissions for my Home dir were all disabled! So I fixed that and restarted the machine completely, to see if everything will work after restart. But then I got a message that it cant access Home cos theres no "Supermount" or "Superpoint" for it or that it was unmounted. So I again went to IceWM, added new user, went in as root and now i had to mount my HOME from DiskDrake (Partition util on mandrake).

Now how do I fix my HOME being actually MOUNTED AND ACCESSIBLE at boot by my default user?

I dont wanna mess any more on my own.

----

ituation update: Now I can log in as the other user normally, mount the HOME partition, and login as primary user, so its not a huge problem, but it would be dandy cool if someone told me how 2 fix it! cheers

I was sent here from microsuck, in hope of an answer, dont let me down guys...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sun Jul 27, 2003 8:42 pm

I don't know what to say about your GUI tools as I don't use them, but here's what the line in your /etc/fstab should look like for /home:

Code: Select all

/dev/hda2               /home                   ext3    defaults        1 1
Of course your device is probably something other than "/dev/hda2" so change accordingly. I'm also assuming that your /home partition is ext3. owner/group for /home should be "root" and the permissions should be 0755 (drwxr-xr-x). Normally a user's home directory will be owned by that user and permissions set so only that user and root can enter the directory, that is 0700 (drwx------).

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Tue Jul 29, 2003 1:58 am

if you are using mandrake, then your mounting is all stuffed anyway, do "supermount --help" to find out how to disable supermount (which is a useless program which mandrake enables by default). You should be able to do "supermount -disable" and it will print a new fstab for you to use instead of your current one. some of the lines in yr current fstab will be messed up atm but back it up anyway and use the new one instead.

Lennon
n00b
n00b
Posts: 3
Joined: Sun Jul 27, 2003 4:48 pm

Post by Lennon » Tue Jul 29, 2003 3:50 am

thanks, i'll try that now...

Lennon
n00b
n00b
Posts: 3
Joined: Sun Jul 27, 2003 4:48 pm

Post by Lennon » Tue Jul 29, 2003 4:02 am

Yup that worked !

Thank you good fellows, i am now happy... verry happy... indeed...mm.......

Post Reply