slackware on home network issues

Place to discuss Slackware
User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

slackware on home network issues

Post by Calum » Tue Oct 28, 2003 3:52 pm

hello.
i know nothing about networking.
i have a laptop with slack 9.0 on it. i want to connect to an existing network at home. the 2 existing computers run windows, and they (and i) plug into a d-link DI-624 wireless router.

i have an onboard network card on my compaq m300 laptop, it's this one i am attempting to use. if i ping myself it looks ok, if i ping 192.168.0.1 (the router), i get "sendto:Network is unreachable".

i ran ifconfig eth0 up and got NO output. nothing appears to have changed including my disconnectedness.

I also have a pcmcia network card which should also work. no /etc/eth* devices exist, i don't know if they should or not. i ran netconfig, it asked me a lot of questions which seemed irrelevant since this router uses DHCP, and created a new rc.* file, which i am not sure the use of because i don't know if it is called by any other script at any time.

I am totally up a gum tree. how can i begin to even consider this seemingly easy but actually infuriating problem? what am i even looking for? i feel perhaps this would be simpler with red hat but then is that true or am i simply missing some small step?

Thank you, thank you, thank you for any help at all which might be forthcoming.

Here are a few interesting things to consider:
here's my /etc/rc.d/rc.inet1 script:

Code: Select all

#! /bin/sh
# /etc/rc.d/rc.inet1
# This script starts up the base networking system.
#
# Version:
# @(#)/etc/rc.d/rc.inet1 8.1 Tue May 28 15:27:39 PDT 2002 (pjv)

# Edit these values to set up your first Ethernet card (eth0):
IPADDR="127.0.0.1"  # REPLACE with YOUR IP address!
NETMASK="255.255.255.0"	# REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth0 using DHCP:
USE_DHCP=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME="CCHOSTNUM-A"

# Edit these values to set up your second Ethernet card (eth1),
# if you have one.  Otherwise leave it configured to 127.0.0.1,
# or comment it out, and it will be ignored at boot.
IPADDR2="127.0.0.1"  # REPLACE with YOUR IP address!
NETMASK2="255.255.255.0" # REPLACE with YOUR netmask!
# Or, uncomment the following lines to set up eth1 using DHCP:
#USE_DHCP2=yes
# If your provider requires a DHCP hostname, uncomment and edit below:
#DHCP_HOSTNAME2="CCHOSTNUM-A"

# Edit the next line to point to your gateway:
GATEWAY="" # REPLACE with YOUR gateway!

# You shouldn't need to edit anything below here.

# Set up the loopback interface:
/sbin/ifconfig lo 127.0.0.1
/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo

# Set up the eth0 interface:
if [ "$USE_DHCP" = "yes" ]; then # use DHCP to set everything up:
  echo "Attempting to configure eth0 by contacting a DHCP server..."
  # Add the -h option to the DHCP hostname:
  if [ ! "$DHCP_HOSTNAME" = "" ]; then
    DHCP_HOSTNAME="-h $DHCP_HOSTNAME"
  fi
  /sbin/dhcpcd -t 10 ${DHCP_HOSTNAME} -d eth0
elif [ ! "$IPADDR" = "127.0.0.1" -a ! "$IPADDR" = "" ]; then # set up IP statically:
  # Determine broadcast and network addresses from the IP address and netmask:
  BROADCAST=`/bin/ipmask $NETMASK $IPADDR | cut -f 1 -d ' '`
  NETWORK=`/bin/ipmask $NETMASK $IPADDR | cut -f 2 -d ' '`
  # Set up the ethernet card:
  echo "Configuring eth0:"
  echo "ifconfig eth0 ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}"
  /sbin/ifconfig eth0 ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}
  # If that didn't succeed, give the system administrator some hints:
  if [ ! $? = 0 ]; then
    echo "Your eth0 card was not initialized properly.  Here are some reasons why this"
    echo "may have happened, and the solutions:"
    echo "1. Your kernel does not contain support for your card.  Including all the"
    echo "   network drivers in a Linux kernel can make it too large to even boot, and"
    echo "   sometimes including extra drivers can cause system hangs.  To support your"
    echo "   ethernet, either edit /etc/rc.d/rc.modules to load the support at boot time,"
    echo "   or compile and install a kernel that contains support."
    echo "2. You don't have an ethernet card, in which case you should run netconfig"
    echo "   and configure your machine for loopback. (Unless you don't mind seeing this"
    echo "   error...)"
  fi
fi # set up eth0

# Set up the eth1 interface:
if [ "$USE_DHCP2" = "yes" ]; then # use DHCP to set everything up:
  echo "Attempting to configure eth1 by contacting a DHCP server..."
  # Add the -h option to the DHCP hostname:
  if [ ! "$DHCP_HOSTNAME2" = "" ]; then
    DHCP_HOSTNAME2="-h $DHCP_HOSTNAME2"
  fi
  /sbin/dhcpcd -t 10 ${DHCP_HOSTNAME2} -d eth1
elif [ ! "$IPADDR2" = "127.0.0.1" -a ! "$IPADDR2" = "" ]; then # set up IP statically:
  # Determine broadcast and network addresses from the IP address and netmask:
  BROADCAST2=`/bin/ipmask $NETMASK2 $IPADDR2 | cut -f 1 -d ' '`
  NETWORK2=`/bin/ipmask $NETMASK2 $IPADDR2 | cut -f 2 -d ' '`
  # Set up the ethernet card:
  echo "Configuring eth1:"
  echo "ifconfig eth1 ${IPADDR2} broadcast ${BROADCAST2} netmask ${NETMASK2}"
  /sbin/ifconfig eth1 ${IPADDR2} broadcast ${BROADCAST2} netmask ${NETMASK2}
  # If that didn't succeed, give the system administrator some hints:
  if [ ! $? = 0 ]; then
    echo "Your eth1 card was not initialized properly.  Here are some reasons why this"
    echo "may have happened, and the solutions:"
    echo "1. Your kernel does not contain support for your card.  Including all the"
    echo "   network drivers in a Linux kernel can make it too large to even boot, and"
    echo "   sometimes including extra drivers can cause system hangs.  To support your"
    echo "   ethernet, either edit /etc/rc.d/rc.modules to load the support at boot time,"
    echo "   or compile and install a kernel that contains support."
    echo "2. You don't have an ethernet card, in which case you should fix"
    echo "   /etc/rc.d/rc.inet1 to stop trying to configure eth1. (Unless you don't mind"
    echo "   seeing this error...)"
  fi
fi # set up eth1

# Set up the gateway:
if [ ! "$GATEWAY" = "127.0.0.1" -a ! "$GATEWAY" = "" ]; then
  /sbin/route add default gw ${GATEWAY} metric 1
fi

# End of /etc/rc.d/rc.inet1
here's my /etc/rc.d/rc.M script (this one gets run when going to a multiuser runlevel):

Code: Select all

#!/bin/sh
#
# rc.M		This file is executed by init(8) when the system is being
#		initialized for one of the "multi user" run levels (i.e.
#		levels 1 through 6).  It usually does mounting of file
#		systems et al.
#
# Version:	@(#)/etc/rc.d/rc.M	2.23	Wed Feb 26 19:20:58 PST 2003
#
# Author:	Fred N. van Kempen, <waltje@uwalt.nl.mugnet.org>
#		Heavily modified by Patrick Volkerding <volkerdi@slackware.com>
#

# Tell the viewers what's going to happen.
echo "Going multiuser..."

# Screen blanks after 5 minutes idle time.
/bin/setterm -blank 5

# If there's no /etc/HOSTNAME, fall back on this default:
if [ ! -r /etc/HOSTNAME ]; then
  echo "darkstar.example.net" > /etc/HOSTNAME
fi

# Set the hostname.
/bin/hostname `cat /etc/HOSTNAME | cut -f1 -d .`

# Initialize PCMCIA devices:
#
# NOTE: This used to be started near the top of rc.S so that PCMCIA devices
# could be fsck'ed along with the other drives.  This had some unfortunate
# side effects, however, since root isn't yet read-write, and /var might not
# even be mounted the .pid files can't be correctly written in /var/run and
# the pcmcia system can't be correctly shut down.  If you want some PCMCIA
# partition to be mounted at boot (or when the card is inserted) then add
# the appropriate lines to /etc/pcmcia/scsi.opts.
#
if [ -x /etc/rc.d/rc.pcmcia ] ; then
  . /etc/rc.d/rc.pcmcia start
  # The cards might need a little extra time here to initialize.
  if [ -r /var/run/cardmgr.pid ]; then
    sleep 5
  fi
fi

# Initialize the networking hardware:
if [ -x /etc/rc.d/rc.inet1 ]; then
  . /etc/rc.d/rc.inet1
fi
# Initialize the hotplugging subsystem for PCI, Cardbus, and USB devices:
if [ -x /etc/rc.d/rc.hotplug -a -r /proc/modules ]; then
  # Don't run hotplug if 'nohotplug' was given at boot.
  if ! grep nohotplug /proc/cmdline 1> /dev/null 2> /dev/null ; then
    . /etc/rc.d/rc.hotplug start
  fi
fi
# Start networking daemons:
if [ -x /etc/rc.d/rc.inet2 ]; then
  . /etc/rc.d/rc.inet2
else
  # Start the system logger.  Normally this is started by
  # rc.inet2 because /usr might be mounted via NFS.
  if [ -x /etc/rc.d/rc.syslog ]; then
    . /etc/rc.d/rc.syslog start
  fi
fi

# Remove stale locks and junk files (must be done after mount -a!)
/bin/rm -f /var/lock/* /var/spool/uucp/LCK..* /tmp/.X*lock /tmp/core /core 1> /dev/null 2> /dev/null

# Remove stale hunt sockets so the game can start.
if [ -r /tmp/hunt -o -r /tmp/hunt.stats ]; then
  echo "Removing your stale hunt sockets from /tmp."
  /bin/rm -f /tmp/hunt*
fi

# Ensure basic filesystem permissions sanity.
chmod 755 / 2> /dev/null
chmod 1777 /tmp /var/tmp

# Update all the shared library links:
if [ -x /sbin/ldconfig ]; then
  echo "Updating shared library links:  /sbin/ldconfig"
  /sbin/ldconfig
fi

# Update the X font indexes:
if [ -x /usr/X11R6/bin/fc-cache ]; then
  echo "Updating X font indexes:  /usr/X11R6/bin/fc-cache"
  /usr/X11R6/bin/fc-cache
fi

# Start the print spooling system.  This will usually be LPD or CUPS.
#if [ -x /etc/rc.d/rc.cups ]; then
  # Start CUPS:
#  /etc/rc.d/rc.cups start
#elif [ -x /usr/sbin/lpd ]; then
  # Start LPD:
#  echo "Starting the line printer daemon:  /usr/sbin/lpd"
#  /usr/sbin/lpd
#fi

# Start netatalk. (a file/print server for Macs using Appletalk)
#if [ -x /etc/rc.d/rc.atalk ]; then
#  /etc/rc.d/rc.atalk
#fi

# Start smartd, which monitors the status of S.M.A.R.T. compatible
# hard drives and reports any problems.  Note some devices (which aren't
# smart, I guess ;) will hang if probed by smartd, so it's commented out
# by default.
#if [ -x /usr/sbin/smartd ]; then
#  /usr/sbin/smartd
#fi

# Monitor the UPS with genpowerd.
# To use this, uncomment it and edit in your serial device and UPS type.  For
# more information, see "man genpowerd" or the extensive documentation in the
# /usr/doc/genpower-1.0.1 directory.  You can see a list of supported UPS
# devices by running genpowerd from the command line.
# You'll also need to configure a similar block in /etc/rc.d/rc.6 if you want
# support for stopping the UPS's inverter after the machine halts.
#if [ -x /sbin/genpowerd ]; then
#  echo "Starting genpowerd daemon..."
#  /sbin/genpowerd /dev/ttyS4 tripp-nt
#fi

# Turn on process accounting.  To enable process accounting, make sure the
# option for BSD process accounting is enabled in your kernel, and then
# create the file /var/log/pacct (touch /var/log/pacct).  By default, process
# accounting is not enabled (since /var/log/pacct does not exist).  This is
# because the log file can get VERY large.
#if [ -x /sbin/accton -a -r /var/log/pacct ]; then
#  /sbin/accton /var/log/pacct
#  chmod 640 /var/log/pacct
#  echo "Process accounting turned on."
#fi

# Start crond (Dillon's crond):
# If you want cron to actually log activity to /var/log/cron, then change
# -l10 to -l8 to increase the logging level.
if [ -x /usr/sbin/crond ]; then
  /usr/sbin/crond -l10 >>/var/log/cron 2>&1
fi

# Start atd (manages jobs scheduled with 'at'):
if [ -x /usr/sbin/atd ]; then
  /usr/sbin/atd -b 15 -l 1
fi

# Slackware-Mini-Quota-HOWTO:
# To really activate quotas, you'll need to add 'usrquota' to the appropriate
# partitions as listed in /etc/fstab.  Here's an example:
# /dev/hda2   /home   ext2   defaults,usrquota    1   1
# You'll then need to setup initial quota files at the top of the partitions
# to support quota, like this:
# touch /home/quota.user /home/quota.group
# chmod 600 /home/quota.user /home/quota.group
# Then, reboot to activate the system.
# To edit user quotas, use 'edquota'.  See 'man edquota'.  Also, the
# official Quota Mini-HOWTO has lots of useful information.  That can be found
# here:  /usr/doc/Linux-mini-HOWTOs/Quota

# Check quotas and then turn quota system on:
#if fgrep quota /etc/fstab 1> /dev/null 2> /dev/null ; then
#  if [ -x /sbin/quotacheck ]; then
#    echo "Checking filesystem quotas:  /sbin/quotacheck -avugM"
#    /sbin/quotacheck -avugM
#  fi
#  if [ -x /sbin/quotaon ]; then
#    echo "Activating filesystem quotas:  /sbin/quotaon -avug"
#    /sbin/quotaon -avug
#  fi
#fi

# Start the sendmail daemon:
#if [ -x /etc/rc.d/rc.sendmail ]; then
#  . /etc/rc.d/rc.sendmail start
#fi

# Start the APM daemon if APM is enabled in the kernel:
if [ -x /usr/sbin/apmd ]; then
  if cat /proc/apm 1> /dev/null 2> /dev/null ; then
    echo "Starting APM daemon:  /usr/sbin/apmd"
    /usr/sbin/apmd
  fi
fi

# Start the ACPI (Advanced Configuration and Power Interface) daemon:
#if [ -x /etc/rc.d/rc.acpid ]; then
#  . /etc/rc.d/rc.acpid start
#fi

# Load a custom screen font if the user has an rc.font script.
if [ -x /etc/rc.d/rc.font ]; then
  . /etc/rc.d/rc.font
fi

# Load a custom keymap if the user has an rc.keymap script.
if [ -x /etc/rc.d/rc.keymap ]; then
  . /etc/rc.d/rc.keymap
fi

# Start Web server:
#if [ -x /etc/rc.d/rc.httpd ]; then
#  . /etc/rc.d/rc.httpd start
#fi

# Start Samba (a file/print server for Win95/NT machines).
# Samba can be started in /etc/inetd.conf instead.
#if [ -x /etc/rc.d/rc.samba ]; then
#  . /etc/rc.d/rc.samba start
#fi

# Start the GPM mouse server:
#if [ -x /etc/rc.d/rc.gpm ]; then
#  . /etc/rc.d/rc.gpm start
#fi

# If there are SystemV init scripts for this runlevel, run them.
if [ -x /etc/rc.d/rc.sysvinit ]; then
  . /etc/rc.d/rc.sysvinit
fi

# Start the local setup procedure.
if [ -x /etc/rc.d/rc.local ]; then
  . /etc/rc.d/rc.local
fi

# All done.
here's my /etc/rc.d/rc.netdevice file which is the one created by netconfig:

Code: Select all

# Load module for network device.
# This script is automatically generated during the installation.

/sbin/modprobe eepro100

i did run this script to see if it would make any odds. guess what, it didn't.

here's the output of dmesg. This was from after i had tried to get it going and then rebooted (in case some of the startup scripts needed running and i had missed them):

Code: Select all

Linux version 2.4.20 (root@midas) (gcc version 3.2.2) #2 Mon Mar 17 22:02:15 PST 2003
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000007ff0000 (usable)
 BIOS-e820: 0000000007ff0000 - 0000000007ff3800 (reserved)
 BIOS-e820: 0000000007ff3800 - 0000000008000000 (ACPI NVS)
user-defined physical RAM map:
 user: 0000000000000000 - 000000000009fc00 (usable)
 user: 000000000009fc00 - 00000000000a0000 (reserved)
 user: 00000000000f0000 - 0000000000100000 (reserved)
 user: 0000000000100000 - 0000000007ff0000 (usable)
127MB LOWMEM available.
On node 0 totalpages: 32752
zone(0): 4096 pages.
zone(1): 28656 pages.
zone(2): 0 pages.
Kernel command line: ro root=/dev/hda6 mem=131008K
Initializing CPU#0
Detected 597.792 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1192.75 BogoMIPS
Memory: 126520k/131008k available (1733k kernel code, 4100k reserved, 568k data, 112k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount-cache hash table entries: 2048 (order: 2, 16384 bytes)
Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU:     After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU:             Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xf0478, last bus=0
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Discovered primary peer bus 02 [IRQ]
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Diskquotas version dquot_6.4.0 initialized
Journalled Block Device driver loaded
pty: 512 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS02 at 0x03e8 (irq = 4) is a 16550A
PCI: Found IRQ 11 for device 00:09.1
PCI: Sharing IRQ 11 with 00:08.0
PCI: Sharing IRQ 11 with 00:09.0
Redundant entry in serial pci_table.  Please send the output of
lspci -vv, this message (11c1,0445,8086,2203)
and the manufacturer and name of serial board or modem board
to serial-pci-info@lists.sourceforge.net.
register_serial(): autoconfig failed
Real Time Clock Driver v1.10e
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x3820-0x3827, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x3828-0x382f, BIOS settings: hdc:DMA, hdd:pio
hda: IBM-DJSA-220, ATA DISK drive
hdc: Compaq DVD-ROM DRN-8080B, ATAPI CD/DVD-ROM drive
ide2: ports already in use, skipping probe
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
blk: queue c0388784, I/O limit 4095Mb (mask 0xffffffff)
hda: 23579136 sectors (12073 MB) w/1874KiB Cache, CHS=1559/240/63, UDMA(33)
hdc: ATAPI 24X DVD-ROM drive, 512kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
loop: loaded (max 8 devices)
ide-floppy driver 0.99.newide
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
   8regs     :   989.600 MB/sec
   32regs    :   593.600 MB/sec
   pIII_sse  :  1212.000 MB/sec
   pII_mmx   :  1341.600 MB/sec
   p5_mmx    :  1399.600 MB/sec
raid5: using function: pIII_sse (1212.000 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.5+(22/07/2002)
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
FAT: bogus logical sector size 0
UMSDOS: msdos_read_super failed, mount aborted.
FAT: bogus logical sector size 0
FAT: bogus logical sector size 0
reiserfs: checking transaction log (device 03:06) ...
Using r5 hash to sort names
ReiserFS version 3.6.25
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 112k freed
Adding Swap: 468680k swap-space (priority -1)
kjournald starting.  Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,8), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
reiserfs: checking transaction log (device 03:07) ...
Using r5 hash to sort names
reiserfs: using 3.5.x disk format
ReiserFS version 3.6.25
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb.c: registered new driver usb_mouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
USB Mass Storage support registered.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Linux Kernel Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Intel PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
PCI: Found IRQ 11 for device 00:04.0
PCI: Sharing IRQ 11 with 00:05.0
Yenta IRQ list 06b8, PCI irq11
Socket status: 30000010
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x100-0x107 0x378-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
eth0: autonegotiation failed; using 10mbs
eth0: MII selected
eth0: media 10BaseT, silicon revision 5
eth0: Xircom: port 0x300, irq 3, hwaddr 00:10:A4:08:97:87
ttyS03 at port 0x02e8 (irq = 3) is a 16550A
eth0: autonegotiation failed; using 10mbs
eth0: MII selected
eth0: media 10BaseT, silicon revision 5
eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others
PCI: Found IRQ 11 for device 00:09.0
PCI: Sharing IRQ 11 with 00:08.0
PCI: Sharing IRQ 11 with 00:09.1
eth1: OEM i82557/i82558 10/100 Ethernet, 00:D0:59:16:19:D9, IRQ 11.
  Board assembly 98003c-000, Physical connectors present: RJ45
  Primary interface chip i82555 PHY #1.
  General self-test: passed.
  Serial sub-system self-test: passed.
  Internal registers self-test: passed.
  ROM checksum self-test: passed (0xdbd8681d).
PCI: Found IRQ 11 for device 00:08.0
PCI: Sharing IRQ 11 with 00:09.0
PCI: Sharing IRQ 11 with 00:09.1
maestro: Configuring ESS Maestro 2E found at IO 0x3400 IRQ 11
maestro:  subvendor id: 0xb1120e11
maestro: not attempting power management.
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.15 time 15:38:03 Mar 11 2003
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:07.2
uhci.c: USB UHCI at I/O 0x3800, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: $Revision: 1.275 $ time 15:38:38 Mar 11 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
82596: IO address 0x0300 in use
dgrs: SW=$Id: dgrs.c,v 1.13 2000/06/06 04:07:00 rick Exp $ FW=Build 550 11/16/96 03:45:15
FW Version=$Version$
82596: IO address 0x0300 in use
dgrs: SW=$Id: dgrs.c,v 1.13 2000/06/06 04:07:00 rick Exp $ FW=Build 550 11/16/96 03:45:15
FW Version=$Version$
eth0: autonegotiation failed; using 10mbs
eth0: MII selected
eth0: media 10BaseT, silicon revision 5

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Oct 28, 2003 5:29 pm

The first thing I am confused about is you say you have a wireless router which I would assume means you will need a wireless card in your laptop (which may be the built in one you mention). If you have a wireless card in your laptop I am confused about using the eepro100 driver because that driver is for 100mbps Intel card (not wireless). And it seems to initially detect a Xircom and tries to set it to 10mbps (again, not a wireless speed). Really confused about your physical setup.

When you say "ping myself", what exactly do you mean? To me that means something like "ping localhost" or "ping 127.0.0.1", but it could mean that you tried to ping the IP address assigned to your ethernet inerface but from what I can see your ethernet interface does not actually appear to be up, and if it is you don't mention what address it has. That is normal to not get any output from an "ifconfig eth0 up" command, but you should be able to list how your ethernet interface is currently configured by typing "ifconfig eth0". It should display what IP address is assigned to it, the netmask, counters, physical address, etc, e.g:

Code: Select all

# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:D0:59:9D:0A:13
          inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3980 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4548 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1583967 (1.5 Mb)  TX bytes:453977 (443.3 Kb)
          Interrupt:11 Base address:0x6000
If you get no output from the above command or get nothing more than the "lo" interface from the "ifconfig" command by itself then you might as well stop right there and figure out why the interface is not up, let alone why it may not be configured properly. If it is not up you will need to determine if you have the correct driver loaded and the correct information in /etc/modules.conf.

Assuming the driver is supported and loaded properly my next question is does your wireless router act as a DHCP server? If one of your Windows boxes is NT or above an "ipconfig /all" and a "route print" command from a CMD prompt on one of the WIndows boxes would be very helpful (save me asking a lot of questions). It would also be helpful to see the output of a "netstat -rn" command on the Linux box, assuming your interface is actually up.

Now I haven't carefully traced through the script but if you want to set up the interface statically you want to change the "IPADDRESS" variable from 127.0.0.1 to something like 192.168.0.10 (address not conflicting with any of your other machines). This all really is a lot easier than it sounds once you do a little networking and learn a little about TCP/IP. I haven't used Slackware in over 10 years so if we get some of these questions answered I will have to trace through the scripts, unless another Slacky has your answer.

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Tue Oct 28, 2003 9:21 pm

Ive used slackware exclusively for quite some time. I must say that sounds about all correct. Except you say that your router is a DHCP server, if that is true then you can edit /etc/rc.d/rc.INET1 and there will be somewhere that says DHCP="no/yes" and you should have it say yes.

Ummm as void said there should be no output from ifconfig eth0 up.. so just run "ifconfig" and list what shows up.

There should be no /etc/eth* devices... .they should be /dev/eth0 (dev short for devices respectfully)

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Tue Oct 28, 2003 9:52 pm

erm.... if you have to load a modul it will probably be in /etc/rc.d/rc.modules at least it is in 9.1, i remember using /etc/modules.conf in older version though.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Wed Oct 29, 2003 5:47 am

Void Main wrote:The first thing I am confused about is you say you have a wireless router which I would assume means you will need a wireless card in your laptop (which may be the built in one you mention).
i'm a confusing kind of guy when i don't know what i'm talking about! okay, i'll try to clear up the effects of my vagueness now:
now the thing which is plugged into the wall is a zoom adsl modem, it's plugged in turn into the d-link wireless thing, model DI-624. This thing has two aerials and the windows xp laptop and windows 9x (or 2k?) desktop have both got d-link wireless cards, one's pcmcia and one i presume is pci. I haven't seen the desktop. Anyway, my laptop (which i am trying to connect) runs slack 9.0 and has only the inbuilt intel card and also a Xircom XEM56-100 pcmcia card (which i have in case i want to use a telephone modem, the inbuilt modem on the laptop is some win* rubbish). so to recapitulate, i have no wireless card on the slack machine. I have a UTP type cable connecting to the back of the d-link thing, into a socket marked 'local network 1'. My flatmates (who run the existing network) assure me this is correct for if i want to connect using a cable (which is what they were doing till a couple of weeks ago).
If you have a wireless card in your laptop I am confused about using the eepro100 driver because that driver is for 100mbps Intel card (not wireless). And it seems to initially detect a Xircom and tries to set it to 10mbps (again, not a wireless speed). Really confused about your physical setup.
well, hopefully i ironed it all out above, well spotted though since those are the two cards i do in fact have!
When you say "ping myself", what exactly do you mean? To me that means something like "ping localhost" or "ping 127.0.0.1", but it could mean that you tried to ping the IP address assigned to your ethernet inerface but from what I can see your ethernet interface does not actually appear to be up, and if it is you don't mention what address it has.
ok, yes i meant "ping 127.0.0.1", this shows no problems, and reports 0% packet loss. When i try to ping the d-link thing, though, i get the


...

you won't believe it. i just did that ping again, and it seems i can indeed ping the d-link thing. odd, i have not changed anything since last night, i simply switched off last night and now i am working...
well, good to see! still wish i could understand more about all this though.
That is normal to not get any output from an "ifconfig eth0 up" command, but you should be able to list how your ethernet interface is currently configured by typing "ifconfig eth0". It should display what IP address is assigned to it, the netmask, counters, physical address, etc, e.g:

Code: Select all

# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:D0:59:9D:0A:13
          inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3980 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4548 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1583967 (1.5 Mb)  TX bytes:453977 (443.3 Kb)
          Interrupt:11 Base address:0x6000
If you get no output from the above command or get nothing more than the "lo" interface from the "ifconfig" command by itself then you might as well stop right there and figure out why the interface is not up, let alone why it may not be configured properly. If it is not up you will need to determine if you have the correct driver loaded and the correct information in /etc/modules.conf.

Assuming the driver is supported and loaded properly my next question is does your wireless router act as a DHCP server? If one of your Windows boxes is NT or above an "ipconfig /all" and a "route print" command from a CMD prompt on one of the WIndows boxes would be very helpful (save me asking a lot of questions). It would also be helpful to see the output of a "netstat -rn" command on the Linux box, assuming your interface is actually up.

Now I haven't carefully traced through the script but if you want to set up the interface statically you want to change the "IPADDRESS" variable from 127.0.0.1 to something like 192.168.0.10 (address not conflicting with any of your other machines). This all really is a lot easier than it sounds once you do a little networking and learn a little about TCP/IP. I haven't used Slackware in over 10 years so if we get some of these questions answered I will have to trace through the scripts, unless another Slacky has your answer.
Wow! i say i want to learn and you have ALREADY answered my question! thanks again! :-D
Interestingly slack is only 10 years and a couple of months old, so i'd be interested in what it was like to use it over 10 years ago! (then it was apparently based on SLD which is older...)

anyway, thanks all, it now works, but i am sure i'll see you again with similar network issues sometime soon! i still have to set up the red hat 9.0 machine (which i will probably cowardly do with neat....
MoR:
There should be no /etc/eth* devices... .they should be /dev/eth0 (dev short for devices respectfully)
!!! how embarrasing. i did mean /dev/*
here's the current situation:

Code: Select all

calum@claudia:~$ ls /dev/eth*
/bin/ls: /dev/eth*: No such file or directory
calum@claudia:~$ /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:D0:59:16:19:D9
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2620 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1815 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1085773 (1.0 Mb)  TX bytes:232208 (226.7 Kb)
          Interrupt:11 Base address:0x3000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:504 (504.0 b)  TX bytes:504 (504.0 b)
calum@claudia:~$ cat /etc/rc.d/rc.modules | grep eep
#/sbin/modprobe eepro
#/sbin/modprobe eepro100
so no problems, but still no /dev/eth* devices, which as far as i can see have never been there! also, while the lines for this driver are indeed in the rc.modules script, they are commented out, perhaps they are compiled into the kernel by default? or they are successfully being called by the rc.netdevice script? i am not aware of what changes the netconfig program may have made in other scripts to ensure that rc.netdevice gets run at startup.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Oct 29, 2003 10:44 am

So to me it looks like you are up and networking ok now? As far as the "/dev/eth*" devices, I have no idea what they would be. I've never seen any device files with those names before.

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality » Wed Oct 29, 2003 10:49 am

yes..i now realize there is no /dev/eth*.
It does sound logical to have the net device interface be under dev though doesnt it?.. perhaps not, i dont know.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Wed Oct 29, 2003 4:25 pm

yes, i am up and networking however i have another question, not network related, system related, but related to the issue at hand too:

when i boot the system with the machine's network interface card plugged into the gateway (if that's what i call it) it all works fab, and i am connected to the internet from go.

if i boot the computer when it is not plugged in, and then decide to connect to the Internet, the best way it looks like is to su to root and then run the startup script /etc/rc.d/rc.inet1 (this script listed above) which gets it all going right enough.

my question is this: how can i allow a normal user to run a simple command (say called "internet" or similar) without having to su to root, which will connect to the internet using all the right settings etc. Also, i imagine that running inet1 is not the best way to get the connection up and i wonder what the best method is.

Any ideas?
again, thanks beforehand.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Oct 29, 2003 4:34 pm

You are bringing the interface up in acceptable ways. I'm guessing that in Slackware you will have to create a script that does a "sudo /etc/rc.inet1" and configure /etc/sudoers so that your users can execute it as if they were root without having to enter root's password. There very possibly could be a better way to do this in Slackware but again hopefully m0r will have your Slackware specific answer. In Red Hat (and others) you can just configure the interface with the "USERCTL=yes" option and then any user will be able to do an "ifup eth0" or "ifdown eth0" (or control the interfaces via the graphical network app).
Last edited by Void Main on Wed Oct 29, 2003 4:39 pm, edited 1 time in total.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Wed Oct 29, 2003 4:34 pm

The solution will involve hotplug but i hate hotplug, so i can't really help you :)

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Wed Oct 29, 2003 5:49 pm

Void Main wrote:You are bringing the interface up in acceptable ways. I'm guessing that in Slackware you will have to create a script that does a "sudo /etc/rc.inet1" and configure /etc/sudoers so that your users can execute it as if they were root without having to enter root's password. There very possibly could be a better way to do this in Slackware but again hopefully m0r will have your Slackware specific answer. In Red Hat (and others) you can just configure the interface with the "USERCTL=yes" option and then any user will be able to do an "ifup eth0" or "ifdown eth0" (or control the interfaces via the graphical network app).
it sounds as if 5 minutes of reading will be enough to let me set up this sudoers thing, so i'll try that first. no graphical network app exists for slack as far as i know (and i'm not too anxious to get one although i will probably pussy out and use one when i add the red hat machine) now, do you think i can just put USERCTL=yes into my inet1 script? i suppose there's only one way to find out...

oh yes, also, what's hotplug and why should i hate it? is it a similar reason for why i hate supermount? (eg: it always arses up and you'd be better off doing it the normal way anyway)

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Wed Oct 29, 2003 6:27 pm

Calum wrote:it sounds as if 5 minutes of reading will be enough to let me set up this sudoers thing, so i'll try that first. no graphical network app exists for slack as far as i know (and i'm not too anxious to get one although i will probably pussy out and use one when i add the red hat machine) now, do you think i can just put USERCTL=yes into my inet1 script? i suppose there's only one way to find out...
I don't use the graphical apps either although Red Hat has a very nice graphical network config utility. No, adding USERCTL=yes to your rc.inet1 script will not work, unless Slack uses the "usernetctl" command. The "usernetctl" command is called from ifup/ifdown in Red Hat and is what allows a normal user to manipulate the interfaces if the USERCTL=yes is in the interface's config file. Slack uses a different style of managing interfaces so I doubt that command is used.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Thu Oct 30, 2003 6:01 am

the gods are displeased today i think!

no ifup command seemingly. i found this document:
http://www.geocities.com/usmbish/hdi-sudo.html
which i thought looked well useful since the sudoers file tells me to see man sudo for details of how to edit it, and man sudo doesn't tell me how to do so, but actually i seem to have misunderstood.
here's my current /etc/sudoers file:

Code: Select all

# sudoers file.
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the sudoers man page for the details on how to write a sudoers file.
#

# Host alias specification

# User alias specification
User_Alias NETUSERS=username1,username2,username3 # names changed to protect the innocent
# Cmnd alias specification
Cmnd_Alias NETCMD=/etc/rc.d/rc.inet1
# Defaults specification
NETUSERS ALL=NOPASSWD:NETCMD
# User privilege specification
root	ALL=(ALL) ALL

# Uncomment to allow people in group wheel to run all commands
# %wheel	ALL=(ALL)	ALL

# Same thing without a password
# %wheel	ALL=(ALL)	NOPASSWD: ALL

# Samples
# %users  ALL=/sbin/mount /cdrom,/sbin/umount /cdrom
# %users  localhost=/sbin/shutdown -h now
now when i tried that, and ran /etc/rc.d/rc.inet1 as a normal user, i get:
SIOCSIFADDR: Permission denied
SIOCSIFFLAGS: Permission denied
SIOCADDRT: Operation not permitted
Attempting to configure eth0 by contacting a DHCP server...
**** /sbin/dhcpcd: not a superuser
so i tried replacing /etc/rc.d/rc.inet with /sbin/dhcpcd in the sudoers file, but got the same error messages. well, it's still baffling me but with a bit of reading i am sure all will become clear. it doesn't help that my networking knowledge is less than adequate i am sure.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Oct 30, 2003 9:21 am

You actually have to run the command through sudo, you want /etc/rc.d/rc.inet1 in your sudoers config file and then to execute it you would:

$ sudo /etc/rc.d/rc.inet1

Or to simplify that even further for your users you could create a script with an appropriate name ("ifup" or "startnet" maybe?) that has nothing more than the above command. I didn't look closely at your sudoers file but your first attempt was probably closer, just remember to use the real command as a parameter to the "sudo" command.

User avatar
Calum
guru
guru
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland
Contact:

Post by Calum » Thu Oct 30, 2003 2:05 pm

okay! cool, i changed it back to what i had it at to start with, took your advice and now it works fine. all i need now is a quick script in /usr/local/bin - i'm ammassing quite a few scripts there (for irritating programs that need funny stuff to run them, like opera which will seemingly only run if run from within its directory :roll: )

Post Reply