boot loader problem

Place to discuss Slackware
User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 3:29 pm

i understand your thinking but this is the same kernal that was successfully booting slack before i loaded fc1 to setup the dual boot

chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 3:31 pm

Was it set up to use an initrd? If so you need to use it for the SCSI modules. Try the Fedora kernel and see if it works. If it does then copy/paste your /etc/lilo.conf on here and let me take a look at it. In fact you can do that without booting into slack by accessing it at /mnt/slack/etc/lilo.conf. Also you might want to look at my previous message since I edited it.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Fri Jan 09, 2004 7:44 am

i tried setting it up as you suggested to use the fc1 kernal to boot slack and it started to boot slack but i get to the point of mounting the root filesystem in slack and it ends up with

kernel panic: no init found. try passing init= option to kernal .

i'm beginning to think the easier way to fix this might be to just wipe sytem start over clean and this time load slack with lilo loading in first partition not in MBR then load fc1 and let grub load in mbr. what do you think void?

Chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Jan 09, 2004 8:38 am

Yes, that is how I used to multi-boot. But we surely shouldn't have this much trouble. Also, you don't need to reinstall to do what you want, You can just run lilo against the good LILO config on your Slack partition but using the chroot lilo param (along with changing your lilo.conf to install on the partition boot record rather than the MBR). You should have access to your lilo.conf at /mnt/slack/etc/lilo.conf. I would still be interested in looking at it. I could maybe post the change that would be needed along with the lilo command line parameter you need to give to get lilo installed on your partition boot record rather than the master boot record. Then you should be able to chain load it as before. It also would do good to memorize that kernel is spelled with an "e". It might save a little time in the future.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Fri Jan 09, 2004 8:56 am

here is my lilo.conf ...why does it say read-only at bottom .. is that the problem why root can't mount? if so what is the correct entry?

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda1
label = Linux
read-only
# Linux bootable partition config ends

Chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Jan 09, 2004 9:07 am

Before I go any farther I want to mention that the kernel you are using with that lilo.conf is called "/boot/vmlinuz" (when booted in Fedora would show up as /mnt/slack/boot/vmlinuz). I thought you said it was using the *-ide-* named kernel? That's certainly not the same kernel because the sizes are different according to your directory listing. I would suggest first try using GRUB again but use the proper kernel.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Fri Jan 09, 2004 9:33 am

i modified lilo.conf to reference the fc1 kernel so that both grub.conf and lilo.conf reference the same kernel and slack still does not boot all the way it now appears to mount root filesystem but i get the follwing lines

pivotroot: pivot_root(/sysroot,/sysroot/iniitrd) failed: 2
umount /initrd/proc failed: 2
freeing unused kernel memory: 136k freed
kernel panic: no init found. try passing init= option to kernel

Chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Jan 09, 2004 9:42 am

No, I didn't want you to modify lilo.conf. I wanted you to use the "vmlinuz" kernel in the Fedora grub.conf for your Slack boot since it appears that the *proper* Slack kernel is "vmlinuz" just to see if that worked before setting up LILO to install on the partition boot record. Something like:

Code: Select all

default=0
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
# Fedora
title Fedora Core (2.4.22-1.2115.nptl)
     root (hd0,2)
     kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb
     initrd /initrd-2.4.22-1.2115.nptl.img
# Slackware
title Slackware 9.1
     root (hd0,0)
     kernel /boot/vmlinuz ro root=/dev/sda1

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Jan 09, 2004 9:53 am

Actually you may have to add "(hd0,0)" to your kernel line as well:

Code: Select all

default=0
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
# Fedora
title Fedora Core (2.4.22-1.2115.nptl)
     root (hd0,2)
     kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb
     initrd /initrd-2.4.22-1.2115.nptl.img
# Slackware
title Slackware 9.1
     root (hd0,0)
     kernel (hd0,0)/boot/vmlinuz ro root=/dev/sda1
according to this:
http://www.linuxquestions.org/questions/history/120773

Post Reply