boot loader problem

Place to discuss Slackware
User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 10:02 am

For one thing in the last line of your grub.conf "kernel" is spelled wrong, that certainly would cauase a failure. Also, I don't believe the chainloader line is necessary since it isn't needed on the Fedora line. Also, I believe it should be picking up your Slackware kernel from the Slackware partition since you are using (hd0,0) in the boot entry. I would first just try correcting the spelling and see if that works, then remove the chainloader statement.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Thu Jan 08, 2004 10:19 am

title Slackware 9.1
rootnoverify (hd0,0)
chainloader +1
kernal /boot/vmlinuz-ide-2.4.22 ro root=/dev/sda1
That's just plain wrong.
chainloader +1, is used for loading a partition that has a bootloader at the beginning of it.
If you told slackware to install LILO onto /dev/sda1 then this is correct, but in this case you would have to remove the following line beginning kernal.
Which, BTW, is spelt kernel.

If you didn't install LILO to /dev/sda1 then we need:

title Slackware 9.1
root (hd0,0)
kernel /boot/vmlinuz-ide-2.4.22 ro root=/dev/sda1

I hope that helps.
Last edited by Tux on Thu Jan 08, 2004 10:39 am, edited 1 time in total.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Thu Jan 08, 2004 10:20 am

Ah, you beat me too it. :p

EDIT: Or 'to' it even :)

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 10:32 am

Heh heh, you also misspelled "kernel" at the end of your example. :)

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux » Thu Jan 08, 2004 10:40 am

I blame copy n' paste! :)

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 10:41 am

i had told slack to install lilo in the mbr. i have removed the kernal line that was below chainloader and still getting the same error when trying to boot slack.

Error 13: invailid or unsupported executable format
Chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 10:47 am

But did you get rid of the chainloader statement? You are using GRUB and don't need LILO any more. GRUB will boot the kernel directly.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 11:07 am

i removed the chainloader and now instead of the error it goes right back to the grub menu

chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 11:18 am

That usually means it's not finding the kernel because it's either looking in the wrong place or the name doesn't match. Remember, you are telling it that the kernel resides in /boot on the first partition with the name you have in your grub.conf (not the one you copied to the Fedora partition). Make sure they match exactly, and it's case sensitive.

While booted into FC1, what is the output of this command:

Code: Select all

ls -l /mnt/slack/boot
Can you copy/paste the output?

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 1:43 pm

here is the output of the command

[root@localhost root]# ls -l /mnt/slack/boot
total 3236
-rw-r--r-- 1 root root 512 Jan 6 06:12 boot.0800
-rw-r--r-- 1 root root 179 Jan 6 06:12 boot_message.txt
lrwxrwxrwx 1 root root 17 Jan 6 05:15 config -> config-ide-2.4.22
-rw-r--r-- 1 root root 38645 Sep 2 23:54 config-ide-2.4.22
-rw------- 1 root root 28160 Jan 6 06:12 map
lrwxrwxrwx 1 root root 21 Jan 6 05:15 System.map -> System.map-ide-2.4.22
-rw-r--r-- 1 root root 609166 Sep 2 23:54 System.map-ide-2.4.22
-r-------- 1 root root 1380436 Jan 6 06:11 vmlinuz
-rw-r--r-- 1 root root 1226706 Sep 2 23:54 vmlinuz-ide-2.4.22
[root@localhost root]#

and here is copy of the current verison of grub.conf
default=0
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2115.nptl)
root (hd0,2)
kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb
initrd /initrd-2.4.22-1.2115.nptl.img
title Slackware 9.1
rootnoverify (hd0,0)
kernal /boot/vmlinuz-ide-2.4.22 ro root=/dev/sda1

thanks
chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 2:14 pm

kernel is still spelled wrong in the last line of your grub.conf. It should be spelled kernel not kernal. It has no chance of loading like it is.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 2:20 pm

i corrected that since i posted the message feel like idiot for missing it again.. anything else you see wrong ? thanks again for all the help

Chris

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 2:31 pm

Well, you could copy the kernel to your FC1 /boot partition and then remove the preceding "/boot" from the kernel line in the grub.conf and see if that works (you also will probably have to change the "rootnoverify (hd0,0)" to "root (hd0,2)" like your fedora line. If that doesn't work I would have to say there must be something drastically wrong with the kernel file although it should at least produce some sort of error message as to why it isn't loading it.

User avatar
cdhgold
administrator
administrator
Posts: 382
Joined: Tue Mar 18, 2003 6:11 pm
Location: Texas

Post by cdhgold » Thu Jan 08, 2004 2:38 pm

i now can boot into slackware but instead of coming all the way up to login prompt i get

VFS: CAnnot open root device "sda1" or 8:01
Please append a correct "root=" boot option
kernal panic: VFS: Unable to mount root fs on 8:01

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Jan 08, 2004 3:12 pm

If "ide" in the kernel name means what I think it means then I can surely understand your error. :) You should actually be able to use the Fedora kernel to boot your slackware installation (as a temporary way to get Slackware up if nothing else). Just copy the entire Fedora section down to make a 3rd entry (including the initrd line). Change the label (title) so as not to conflict with the Fedora one and pass it the root=/dev/sda1 parameter instead of root=LABEL=/. Sort of like:

Code: Select all

default=0
timeout=10
splashimage=(hd0,2)/grub/splash.xpm.gz
# Fedora
title Fedora Core (2.4.22-1.2115.nptl)
     root (hd0,2)
     kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb
     initrd /initrd-2.4.22-1.2115.nptl.img
# Slackware
title Slackware 9.1
     rootnoverify (hd0,0)
     kernel /boot/vmlinuz-ide-2.4.22 ro root=/dev/sda1
# Slackware with Fedora kernel
title Slack with FC1 kernel
     root (hd0,2)
     kernel /vmlinuz-2.4.22-1.2115.nptl ro root=/dev/sda1
     initrd /initrd-2.4.22-1.2115.nptl.img
Last edited by Void Main on Thu Jan 08, 2004 3:30 pm, edited 1 time in total.

Post Reply