:( I cant get my server working right

Place to discuss Slackware
Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

:( I cant get my server working right

Post by Doogee » Thu Feb 19, 2004 7:00 am

Hey i have a problem (as usual)

Im trying to set up a webserver on a seperate pc to my main one.

Ive got the server running and i can see pages just fine (including php) but when it comes to MySQL the thing just wont go.

When i try to install my forum software, i put in all my db details and that and click on "proceed" and it shows me a blank white page.


:cry: Does anyone have any ideas?


(Slack 9.1)

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Feb 19, 2004 11:31 am

Could you fill in some blanks, like what forum software you are trying to get running, whether you have PHP with MySQL support installed, whether you have looked through your web server error logs, whether you have turned on php debugging, whether MySQL is actually running, etc? To see if your PHP has MySQL support compiled in create a *.php file that has only this in it:

Code: Select all

<?
phpinfo();
?>
Put it somewhere under your server root and load it in your browser. It should tell you all of functionality that you have compiled in to PHP.

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Thu Feb 19, 2004 2:45 pm

how can i tell if mysql is running.


phpinfo says --with-mysql (or something like it)

Im trying to install invision power board.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Thu Feb 19, 2004 3:25 pm

Looks like MySQL support is compiled in to PHP. Can you connect to your MySQL server with the MySQL CLI ("mysql" is the client command).

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Thu Feb 19, 2004 11:10 pm

yes i can do that.

i think it may have something to do with the passwords because only one of the commands supplied worked.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Feb 20, 2004 12:00 am

What forum software?

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Fri Feb 20, 2004 1:13 am

I already said that

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Fri Feb 20, 2004 12:15 pm

So you did (even though you didn't answer the other questions about turning on debugging and checking your logs). Now, I see that it is commercial software. On top of that it looks nearly identical to phpBB which begs the question... why would you want to use it? Since it is commercial software they should provide support and I would suggest that you go through them to see what they can do to help you. I don't deal with commercial software here, sorry. And if it were phpBB there is a great support forum right at the phpBB web site (www.phpbb.com).

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Feb 23, 2004 1:28 am

Yeah but they offer a free version, and the fact of what i am installing shouldnt change your thoughts on whether you should help me get MySQL working (which is free software, not commercial, whatever)

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Feb 23, 2004 1:46 am

I am trying to install blog software called bMachine, I have this software working on another server (http://doogee.is.dreaming.org) which is a winblows server. I tried to install this software on my linux box but it didnt work, after you click ok to the configuration it dumps me to a white blank screen.

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Feb 23, 2004 2:37 am

Code: Select all

[notice] Apache/1.3.28 (Unix) configured -- resuming
normal operations
[Thu Feb 19 20:05:32 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Feb 19 22:16:54 2004] [notice] SIGHUP received.  Attempting to restart
[Thu Feb 19 22:16:54 2004] [warn] module mod_php4.c is already added, skipping
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php/extensions/mysql.so' - libmysqlclien$
[Thu Feb 19 22:16:55 2004] [notice] Apache/1.3.28 (Unix) PHP/4.3.3 configured -- resuming normal operations
[Thu Feb 19 22:16:55 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Feb 19 22:44:32 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:49:53 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:50:02 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:50:27 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:50:31 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:50:56 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 22:53:14 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 23:19:02 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 23:19:13 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 23:25:52 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/$
[Thu Feb 19 23:26:44 2004] [notice] SIGHUP received.  Attempting to restart
I hope that fills in another blank :)


I just had a look and it seems /usr/lib/php/extensions/mysql.so is present so i dont know whats going on

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Feb 23, 2004 12:19 pm

The log entries appear to be truncated. Can you post the full length of the lines?

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Mon Feb 23, 2004 2:47 pm

Code: Select all

daniel@dans-server:/var/log/apache$ more error_log
[Thu Feb 19 20:05:32 2004] [notice] Apache/1.3.28 (Unix) configured -- resuming normal operations
[Thu Feb 19 20:05:32 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Feb 19 22:16:54 2004] [notice] SIGHUP received.  Attempting to restart
[Thu Feb 19 22:16:54 2004] [warn] module mod_php4.c is already added, skipping
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php/extensions/mysql.so' - libmysqlclient.so.12: cannot open shared object f
ile: No such file or directory in Unknown on line 0
[Thu Feb 19 22:16:55 2004] [notice] Apache/1.3.28 (Unix) PHP/4.3.3 configured -- resuming normal operations
[Thu Feb 19 22:16:55 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Feb 19 22:44:32 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sources/Drivers/myS
QL.php on line 64
[Thu Feb 19 22:49:53 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 22:50:02 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 22:50:27 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 22:50:31 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sources/Drivers/myS
QL.php on line 64
[Thu Feb 19 22:50:56 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 22:53:14 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 23:19:02 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 23:19:13 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sources/Drivers/myS
QL.php on line 64
[Thu Feb 19 23:25:52 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 23:26:44 2004] [notice] SIGHUP received.  Attempting to restart
[Thu Feb 19 23:26:45 2004] [warn] module mod_php4.c is already added, skipping
PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/php/extensions/mysql.so' - libmysqlclient.so.12: cannot open shared object f
ile: No such file or directory in Unknown on line 0
[Thu Feb 19 23:26:46 2004] [notice] Apache/1.3.28 (Unix) PHP/4.3.3 configured -- resuming normal operations
[Thu Feb 19 23:26:46 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Thu Feb 19 23:33:42 2004] [error] [client 10.0.0.1] File does not exist: /var/www/htdocs/random.php
[Thu Feb 19 23:34:30 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 23:42:44 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sm_install.php on l
ine 342
[Thu Feb 19 23:42:53 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sources/Drivers/myS
QL.php on line 64
[Thu Feb 19 23:42:57 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_connect() in /var/www/htdocs/forum/sources/Drivers/myS
QL.php on line 64
[Thu Feb 19 23:48:41 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_get_client_info() in /var/www/htdocs/forum/phpMyAdmin-
2.5.5-pl1/libraries/defines.lib.php on line 47
[Thu Feb 19 23:49:18 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_get_client_info() in /var/www/htdocs/forum/phpMyAdmin-
2.5.5-pl1/libraries/defines.lib.php on line 47
[Thu Feb 19 23:49:48 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_get_client_info() in /var/www/htdocs/forum/phpMyAdmin-
2.5.5-pl1/libraries/defines.lib.php on line 47
[Thu Feb 19 23:50:09 2004] [error] PHP Fatal error:  Call to undefined function:  mysql_get_client_info() in /var/www/htdocs/forum/phpMyAdmin-
--More--(39%)
thats the most i can get

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Mon Feb 23, 2004 4:22 pm

Do you have a "libmysqlclient.so.12" file on your system? If not it would appear the version of PHP you have installed was compiled against a different version of MySQL than you have installed. I don't know the history of how you installed Apache/PHP/MySQL so it's hard to tell. I would assume that if you installed them all from slackware packages for your version of slackware then you shouldn't be having these problems. As it stands, it looks like a PHP rebuild. You might want to check over some LAMP sites on how to install Apache, PHP, MySQL from source, or wait for some help from some of our Slackware users for suggestions. Here is an example of a LAMP site with all sorts of PHP/MySQL goodies:

http://www.onlamp.com/

Or here is a nice turorial for installing the whole ball of wax from source (Apache, MySQL, PHP):

http://fedoranews.org/krishnan/tutorial ... ndex.shtml

Doogee
administrator
administrator
Posts: 261
Joined: Fri Jan 10, 2003 1:40 am

Post by Doogee » Tue Feb 24, 2004 1:06 am

I shall chedck out those links, thanks alot.

Post Reply