flash disc copy problem

Discuss Applications
Post Reply
caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

flash disc copy problem

Post by caveman » Fri Jul 02, 2004 8:54 pm

Hi.

Bit of a different problem this time round.

I have a system built with Suse 7.3 on a 256Mb SanDisk.
Everything works fine - except
I'm trying to make a copy of the disc so as to be able to just put
it into another system and boot it up - but no go!

I've dd if=/dev/hdb of=imagefile.raw and then
copy it back with dd id=imagefile of=/dev/hdb....
even tried cat /dev/hdb > imagefile2.raw and then copy it back.
I thought that dd will do a byte by byte image copy.

When booting from the new disc the system hangs when it gets to
"Partition Check: hdd:" and unless I start it with "linux pci=off"
nothing happens. (read somewhere that the kernel sometimes thinks
the CF is DMA capable when it aint)
But getting it to start this way - things like the network etc.. does not
start - gives an error that insmod fails as the sis990.o file cannot
be found - even though it is there.
It is as if the copy just did not work properly, but I can "chroot" to the
root of the new disc and the fdisk looks the same as the original.
I can even see all the needed files on the new disc.
(both flash discs are SanDisk 256MB - type SDCFB)

As I have to fool around with my development machine to get the flash
card loaded as an IDE device with some extra cables, I boot from
cdrom using Knoppix 3.4 to do the above.
The production machine is a single board job with only place for a
flash disc .

Any ideas anyone? anybody had a similiar problem like this?
Any extra info - I'll supply as soon as I'm back..

Tx in advance.

It is now nearly 5 in the morning where I am - this kept me up too long.
of to grab some sleep for a while.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Jul 03, 2004 7:12 am

What happens if you use fdisk to create the partition table on the new device (with exact same sizes as original device) and then just dd the file system (hdb1) rather than the whole disk?

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Sat Jul 03, 2004 6:53 pm

yep. I've allready tried that with the same result.

In the mean time I discovered that all the new and newer cards are DMA
enabled by default. That is the first problem.
This somehow leads to the second problem ie.
Somehow the IRQ or IO in the machine is now different with the new
card.
The log message actually fails on the "insmod" of the sis900.o driver
with an incorrect irq or I/O - even doing it manually.
Doesn't matter what and how I set the BIOS.....
have as yet not figured out the boot parameters to send the kernel
to over ride the defaults etc. and at least get the system up and
going. But I'll eventually get to that as well.

This now leaves me with 3 options
get a non-dma flash disc from the suppliers or
rebuild the system from scratch to be able to use these new cards
(seems to be the end-result in any case)
in the interim figure out and send some parameters at boot time.

Tx for the help thus far.

Post Reply