Keyboard flops after GTK packages installed

Discuss Applications
User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

It's actually:

# apt-get install MPlayer

Notice the upper case M and P. synaptic is in /usr/sbin and needs to be run as root. In Red Hat and fedora you can start it as a normal user and it will ask you for root's password. SUSE doesn't seem to have that option. You should be able to just open a shell and:

$ su -
# synaptic

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

he he...slap me now...

joey@linux:~> apt-get install mplayer*
error: cannot get exclusive lock on /var/lib/rpm/Packages
error: cannot open Packages index using db3 - Operation not permitted (1)
error: cannot open Packages database in /var/lib/rpm
E: could not open RPM database
joey@linux:~> su
Password:
linux:/home/Joey # apt-get install mplayer
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package mplayer
linux:/home/Joey # apt-get install MPlayer*
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
libogg libogg-devel libtheora
The following packages will be upgraded
libogg libogg-devel
The following NEW packages will be installed:
MPlayer libtheora
2 upgraded, 2 newly installed, 0 removed and 1883 not upgraded.
Need to get 8139kB of archives.
After unpacking 21.7MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.0-i386/packman libogg-devel 1.1-0.pm.0 [72.8kB]
Get:2 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.0-i386/packman libogg 1.1-0.pm.0 [23.9kB]
Get:3 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.0-i386/packman libtheora 0.9_1.0alpha3-0.pm.0 [133kB]
Get:4 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.0-i386/packman MPlayer 1.0pre5-pm.1 [7909kB]
Fetched 8139kB in 1m16s (106kB/s)
Committing changes...
Preparing... ########################################### [100%]
1:libogg-devel ########################################### [ 25%]
2:libogg ########################################### [ 50%]
3:libtheora ########################################### [ 75%]
4:MPlayer ########################################### [100%]
Done.
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.alljava...
Executing /sbin/conf.d/SuSEconfig.apache...
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft .......................
Creating fonts.{scale,dir} files ............
Executing /sbin/conf.d/SuSEconfig.gconf2...
Executing /sbin/conf.d/SuSEconfig.gdm2...
Executing /sbin/conf.d/SuSEconfig.gnome-filesystem...
Executing /sbin/conf.d/SuSEconfig.gnome-print...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.hostname...
Executing /sbin/conf.d/SuSEconfig.isdn...
Modify isdn.conf
provider provider0 done
provider provider1 done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdenetwork-lan...
Executing /sbin/conf.d/SuSEconfig.kdm3...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.mailman...
Executing /sbin/conf.d/SuSEconfig.named...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.OpenOffice.org...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.rplay...
Executing /sbin/conf.d/SuSEconfig.samba...
Executing /sbin/conf.d/SuSEconfig.scrollkeeper...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
Executing /sbin/conf.d/SuSEconfig.tetex...
Executing /sbin/conf.d/SuSEconfig.xdm...
Finished.
apt executing: /sbin/ldconfig
linux:/home/Joey #

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

linux:/home/Joey # synaptic
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(synaptic:13849): Gtk-WARNING **: cannot open display:
linux:/home/Joey # su
linux:/home/Joey # synaptic
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(synaptic:13858): Gtk-WARNING **: cannot open display:
linux:/home/Joey #

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Actually synaptic should be on your menu and it *will* ask you for root's password. Click the menu and it's under system->More Programs. The actual command line it would run is:

$ kdesu -u root /usr/sbin/synaptic

SUSE is a little different with X authorization than Red Hat. Now, when you install on the command line, don't use the asterisk (*) at the end. It should just be:

# apt-get install MPlayer

It looks like you got lucky and it installed MPlayer anyway. :) Just type "gmplayer" on the command line or start it from your menu. Hopefully this will get you on your way.

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

joey@linux:~> kdesu -u root/usr/sbin/synaptic
kdesu: ERROR: User root/usr/sbin/synaptic does not exist
joey@linux:~> su
Password:
linux:/home/Joey # kdesu -u root /usr/sbin/synaptic
bash: kdesu: command not found
linux:/home/Joey # -u root /usr/sbin/synaptic
bash: -u: command not found
linux:/home/Joey # $kdesu -u root
bash: -u: command not found
linux:/home/Joey # $ kdesu -u root usr/sbin/synaptic
bash: $: command not found
linux:/home/Joey # $ kdesu -u root /usr/sbin/synaptic
bash: $: command not found
linux:/home/Joey # /usr/sbin/synaptic
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(synaptic:13969): Gtk-WARNING **: cannot open display:
linux:/home/Joey #

gmplayer worked, I got it~

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

but what in the world does all of this mean?
joey@linux:~> gmplayer
MPlayer 1.0pre5-3.3.1 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon Thunderbird 1000 MHz (Family: 6, Stepping: 2)Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/MPlayer/mplayer.conf
Reading config file /home/Joey/.mplayer/config
[cfg] read config file: /home/Joey/.mplayer/gui.conf
Reading config file /home/Joey/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1280x1024 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/Joey/.mplayer/codecs.conf: Can't open '/home/Joey/.mplayer/codecs.conf': No such file or directory
Reading /etc/MPlayer/codecs.conf: 73 audio & 180 video codecs
font: can't open file: /home/Joey/.mplayer/font/font.desc
Font /usr/share/MPlayer/font/font.desc loaded successfully! (206 chars)
Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Using usleep() timing
Can't open input config file /home/Joey/.mplayer/input.conf: No such file or directory
Input config file /etc/MPlayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed to open LIRC support.
You will not be able to use your remote control.

Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path: "libpixmap.so",SKIN dir 1: '/home/Joey/.mplayer/Skin'
SKIN dir 2: '/usr/share/MPlayer/Skin'

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

The "kdusu" command has to have a space after "root":

Code: Select all

$ kdesu   -u    root    /usr/sbin/synaptic
gmplayer does usually spit a lot of information out at you if you run it from the comand line but you do seem to have some sort of missing gtk library. I don't get those GTK messages. You won't see any of those messages if you run it from the menu (or press "ALT+F2" and type in "gmplayer"). Does it work? Are you running KDE or GNOME? I'll do some searching to see if I can pin down that libpixmap.so message.

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

It's not appearing in my start menu. Alt = F2 works

I'm running GNOME

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Ah, that's why. SUSE is very KDE centric and they only included KDE menu items in the MPlayer package. It should show up on your KDE menu. You can always add a launcher for it in GNOME. You might not want to use kdesu though. It might still work, don't know if they would have a gnome version. In Red Hat they use something called "console helper" for this. I'm very green with SUSE (the new versions anyway).

EDIT: What do you get when you do this:

# apt-cache search libpixmap.so

I show it associated with gtk-engines and gtk2-engines. If you show the same thing you might install those packages:

# apt-get install gtk-engines gtk2-engines

Only install whatever the search finds.

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

I'm assuming it should be either in Multimedia>more programs or multimedia>video players...anyway, heres what happened...

Joey@linux:~> su
Password:
linux:/home/Joey # apt-cache search libpixmap.so
gtk-engines - Theme Engines for GTK+
gtk2-engines - Engines for GTK2 Themes
linux:/home/Joey # apt-get install gtk-engines gtk2-engines
Reading Package Lists... Done
Building Dependency Tree... Done
gtk2-engines is already the newest version.
The following NEW packages will be installed:
gtk-engines
0 upgraded, 1 newly installed, 0 removed and 1883 not upgraded.
Need to get 664kB of archives.
After unpacking 1080kB of additional disk space will be used.
Get:1 ftp://mirrors.mathematik.uni-bielefeld.de SuSE/9.0-i386/base gtk-engines 0.12-818 [664kB]
Fetched 664kB in 11s (55.7kB/s)
Committing changes...
Preparing... ########################################### [100%]
1:gtk-engines ########################################### [100%]
Done.
apt executing: /sbin/SuSEconfig
Starting SuSEconfig, the SuSE Configuration Tool...
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.alljava...
Executing /sbin/conf.d/SuSEconfig.apache...
Executing /sbin/conf.d/SuSEconfig.automake...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating cache files for Xft .......................
Creating fonts.{scale,dir} files ............
Executing /sbin/conf.d/SuSEconfig.gconf2...
Executing /sbin/conf.d/SuSEconfig.gdm2...
Executing /sbin/conf.d/SuSEconfig.gnome-filesystem...
Executing /sbin/conf.d/SuSEconfig.gnome-print...
Executing /sbin/conf.d/SuSEconfig.groff...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Executing /sbin/conf.d/SuSEconfig.guile...
Executing /sbin/conf.d/SuSEconfig.hostname...
Executing /sbin/conf.d/SuSEconfig.isdn...
Modify isdn.conf
provider provider0 done
provider provider1 done
Executing /sbin/conf.d/SuSEconfig.ispell...
Executing /sbin/conf.d/SuSEconfig.kde...
Executing /sbin/conf.d/SuSEconfig.kdenetwork-lan...
Executing /sbin/conf.d/SuSEconfig.kdm3...
Executing /sbin/conf.d/SuSEconfig.libxml2...
Executing /sbin/conf.d/SuSEconfig.mailman...
Executing /sbin/conf.d/SuSEconfig.named...
Executing /sbin/conf.d/SuSEconfig.news...
Executing /sbin/conf.d/SuSEconfig.OpenOffice.org...
Executing /sbin/conf.d/SuSEconfig.pango...
Executing /sbin/conf.d/SuSEconfig.perl...
Executing /sbin/conf.d/SuSEconfig.permissions...
Executing /sbin/conf.d/SuSEconfig.postfix...
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
Executing /sbin/conf.d/SuSEconfig.profiles...
Executing /sbin/conf.d/SuSEconfig.rplay...
Executing /sbin/conf.d/SuSEconfig.samba...
Executing /sbin/conf.d/SuSEconfig.scrollkeeper...
Executing /sbin/conf.d/SuSEconfig.sortpasswd...
Executing /sbin/conf.d/SuSEconfig.susehelp...
Executing /sbin/conf.d/SuSEconfig.tetex...
Executing /sbin/conf.d/SuSEconfig.xdm...
Finished.
apt executing: /sbin/ldconfig
linux:/home/Joey # apt-get install gtk2-engines
Reading Package Lists... Done
Building Dependency Tree... Done
gtk2-engines is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 1883 not upgraded.
linux:/home/Joey #



OOps, I did this in KDE...let me switc to GNOME and see if it's there too.

It's In There!!!

joey@linux:~> su
Password:
linux:/home/Joey # apt-cache search libpixmap.so
gtk-engines - Theme Engines for GTK+
gtk2-engines - Engines for GTK2 Themes
linux:/home/Joey # apt-get install gtk-engines gtk2-engines
Reading Package Lists... Done
Building Dependency Tree... Done
gtk-engines is already the newest version.
gtk2-engines is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 1883 not upgraded.
linux:/home/Joey #

ummm...I'm a friggin Newb, so the next dumb question I guess is...Now what?

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

Also, I found synaptic package manager in my system>configuration

Whenever I try to fire it up it says a child process failed gksu no such file or directory

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

After you installed the gtk-engines did you stll get that Gtk-WARNING message about the missing libpixmap.so file when you ran gmplayer from the command line?

Just so you know, the apt-get and synaptic commands are independent of KDE or GNOME. They are system tools used to manage the software installed on your system. However, to start a command as root in KDE SUSE includes the "kdesu" command. When you are in GNOME it appears that SUSE tries to run the "gksu" comamnd to start a program as root. You do not appear to have "gksu" installed. Since you now have apt installed you should be able to just install the gksu package by:

# apt-get install gksu

I assume this is actually a SUSE package so you could alternately install it with YaST. Of course all of this is speculation on my part as I do not currently have access to a SUSE machine to verify this. I will this evening.

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

YOU says no such file...

here's what apt says...

joey@linux:~> su
Password:
linux:/home/Joey # apt-get install gksu
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package gksu
linux:/home/Joey #


I'm starting to understand why I'm having so many problems...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I guess gksu isn't included with SUSE. I could probably build a SUSE RPM and start my own SUSE repository. You do have a couple of other options to start X apps as root from your normal account. At a command line you could:

$ sux -c /usr/sbin/synaptic

The above command will ask you for root's password and then start synaptic.

Another thing I would do if I were you is make it work more like Red Hat so when you "su" you can run X apps. I just did a little digging and figured out what has to be done to automatically add the appropriate Xauthority when you do an "su". Be careful not to make a mistake when you do this. Open two terminal windows. In one of them do this:

Code: Select all

$ su -
# cd /etc/pam.d
# cp su su.bak
# echo "session  optional pam_xauth.so" >> su
Without closing the first terminal window do this in the other one:

Code: Select all

$ su
If "su" still appears to work then you should now be able to do this:

Code: Select all

# /usr/sbin/synaptic
If everything works you are done. If you made a mistake and are not able to do an "su" successfully in the second window then go back to the first window and restore the backup pam file for the su configuration:

Code: Select all

# cp  su.bak  su
From now on you should be able to run X apps after running the "su" command. Note, if you do an "su -" you will not be able to run an X app unless you set your DISPLAY environment variable (this is also done automatically in Red Hat, I'll have to figure out how to make it work the same way in SUSE).

If you would like that "gksu" command I could get the source and create an RPM as I mentioned, but if you don't want it I'm not going to mess with it. I guess "kdsu" doesn't work in GNOME? I'm going to install GNOME now on my SUSE install and check for myself.

EDIT: I just installed GNOME via synaptic and logged in to it. I found Synaptic on my SUSE menu and clicked on it. It stared kdesu and asked for root's password which I entered. Up popped synaptic with no problems. I guess this doesn't work for you? If not I wonder if it's something with SUSE 9.0 vs 9.1?

JoeDude
administrator
administrator
Posts: 355
Joined: Sun Feb 08, 2004 1:41 pm
Location: Sutton Coldfield, UK
Contact:

Post by JoeDude »

joey@linux:~> $ sux -c /usr/sbin/synaptic
bash: $: command not found
joey@linux:~> sux -c /usr/sbin/synaptic
Password:

(synaptic:4080): Gtk-CRITICAL **: file gtkwidget.c: line 1827 (gtk_widget_hide): assertion `GTK_IS_WIDGET (widget)' failed
joey@linux:~>

haven't tried the second bit yet

Post Reply