Error in my local repository

Discuss Applications
Post Reply
User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Error in my local repository

Post by Basher52 »

I get weird error in my own repository that says that a directory dosen't exist and that is correct but it has added some dir name that is not in there.
Here's an example but it says this for all of them.

Code: Select all

Error Downloading Packages:
  xorg-x11-fonts-100dpi-7.2-6.fc9.noarch: failed to retrieve 10/i386/os/Packages/xorg-x11-fonts-100dpi-7.2-6.fc9.noarch.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/xorg-x11-fonts-100dpi-7.2-6.fc9.noarch.rpm
  1:xorg-x11-twm-1.0.3-3.fc10.i386: failed to retrieve 10/i386/os/Packages/xorg-x11-twm-1.0.3-3.fc10.i386.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/xorg-x11-twm-1.0.3-3.fc10.i386.rpm
  openslp-1.2.1-9.fc9.i386: failed to retrieve 10/i386/os/Packages/openslp-1.2.1-9.fc9.i386.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/openslp-1.2.1-9.fc9.i386.rpm
  xorg-x11-fonts-Type1-7.2-6.fc9.noarch: failed to retrieve 10/i386/os/Packages/xorg-x11-fonts-Type1-7.2-6.fc9.noarch.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/xorg-x11-fonts-Type1-7.2-6.fc9.noarch.rpm
  libmal-0.31-8.fc9.i386: failed to retrieve 10/i386/os/Packages/libmal-0.31-8.fc9.i386.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/libmal-0.31-8.fc9.i386.rpm
  xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch: failed to retrieve 10/i386/os/Packages/xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch.rpm from updates-local
error was [Errno 2] Local file does not exist: /data/www/yum.updates/10/i386/pdate/10/i386/os/Packages/xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch.rpm
The files is taken from the Everything dir from a server close to me and i placed under: /data/www/yum.updates/10/i386/

the yum.conf is changed into this:

Code: Select all

[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
metadata_expire=1800
installonly_limit=10

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

[base-local]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=file:///data/www/yum.updates/$releasever/$basearch
#baseurl=http://192.168.0.250/yum/base/$releasever/$basearch
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-
$releasever&arch=$basearch
enabled=1
gpgcheck=0

[updates-local]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=file:///data/www/yum.updates/$releasever/$basearch/
#baseurl=http://192.168.0.250/yum.updates/$releasever/$basearch/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-
released-f$releasever&arch=$basearch
enabled=1
gpgcheck=0
I just can't understand where the dir name: '/pdate' comes from.
It looks like a cut name from 'update' but I can no clue anymore

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

Can I assume that is not really your yum.conf and it's really a repository configuration file from your /etc/yum.repos.d directory? If it really is in your yum.conf it shouldn't be and the answer to your problem probably really resides in one of your repository configuration files in the /etc/yum.repos.d directory (in the "updates-local" section in one of those files).

User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 »

well, then I might have done something I shouldn't, cos this IS the yum.conf file. All the files in the yum.repos.d/ is for fedora except one and that's pidgin.repo

Can I just use the remarked line for the "original" values of this file? or have they changed?

these:
base:
#mirrorlist=http://mirrors.fedoraproject.org/mirror ... po=fedora-

and for update:
#mirrorlist=http://mirrors.fedoraproject.org/mirror ... o=updates-

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I shouldn't have said you "can't" put your repo definitions in the yum.conf but I just don't think it's the common/preferred place. Usually you'll have a separate file in /etc/yum.repos.d for each repo you have set up and if you are creating your own, just create a new file with your definitions in it in that directory. Is there another file in there that contains the "[updates-local]" file in that directory? Also, did you do a "yum clean all" to make sure it's not a mistake that it's pulling from cache?

User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 »

yum clean all, well here I just learned a new thing again :) thx

I'll try that and I'll put a separate file in the .d/ for my repos.
but... will they always be first in line before the original from fedora?

oh btw, can I remove the remarked lines to "restore" the yum.conf file?

UPDATE: yum clean all fixed it :)

now only to remove this from yum.conf...

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

You should not have two repos with the same name active at the same time. Just set "enabled=0" in the section to disable it. You don't have to uncomment the "baseurl" as the "mirrorlist" will cover it but there is no reason you can't uncomment it. The baseurl sites will likely be swamped though.

User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 »

It all seems to work now :) thx

but should I just disable the ones I have in the yum.conf file?
Shouldn't I remove those lines totally and move those lines into an own file under yum.repos.d/

I looked at a totally clean install of a F10 system that that yum.conf had only this in it:

Code: Select all

[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=9

#  This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
#  It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
So shouldn't this file look the same? Aren't these lines just left from a previous release.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I would.

User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 »

ahh, WHAT would you do?
Remove the lines so that yum.conf looks like the one on the fresh install or disable the two sections.

...and after either of these two, add a new file for my local repository?

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I would remove the repo junk from the yum.conf and if it doesn't already exist in /etc/yum.repos.d put them there so it's fairly close to default.

User avatar
Basher52
guru
guru
Posts: 928
Joined: Wed Oct 22, 2003 5:57 am
Location: .SE

Post by Basher52 »

k I'll try that
thx man, you just made my crappy XMas :)

Post Reply