Don't use xf86cfg, it's buggy

Discuss Applications
Post Reply
Refalm
user
user
Posts: 38
Joined: Tue Jan 21, 2003 12:40 pm
Location: Twente
Contact:

Don't use xf86cfg, it's buggy

Post by Refalm »

When I first installed Slackware 9.1, I noticed that my middle mouse button was working correctly, but my scrollwheen wasn't.

So I started up xf86cfg as su. I configured it from "Intellimouse" to "Auto scroll-mouse" and rebooted the computer.
When it was about to go to runlevel 4, the message popped up that X wasn't starting, because there was a fault in the configuration file.
xf86cfg started, and I configured it back to "Intellimouse", being a little bit suspicious that this could cause X not to boot.

After restarting X, it still wouldn't start! It just keep telling me that there was a fault. So this time I looked closely into the output, and noriced something like: "^AEndSection". You know what hepeneds if you type Ctrl+Shift+5 in Vim? You get a weird character like "^Y". I think that was what hapenned to the configuration file, it couldn't parse the last section.

So next time, I'll just use Vim to edit X's configuration files. But damn, it won't start X, and as a treat, it won't go back to runlevel 3, which sucks deeply. So my only option now is to re-install Slackware, just because xf86cfg has this stupid bug.

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

why wont it go back to 3?

Refalm
user
user
Posts: 38
Joined: Tue Jan 21, 2003 12:40 pm
Location: Twente
Contact:

Post by Refalm »

Tux wrote:why wont it go back to 3?
When X shuts down, there is no "root@localhost #"... the only option left is Ctrl+Alt+Delete :(

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

You should be able to start it in single user mode which should not start X by passing a parameter to the kernel at the LILO prompt. In Red Hat and other distros just add the word "single" to the boot command line. I think it's the same for Slack... e.g. "LILO: linux single".

You could also boot from alternate media (such as Knoppix), mount the root partition and edit your XF86Config to repair it.

Refalm
user
user
Posts: 38
Joined: Tue Jan 21, 2003 12:40 pm
Location: Twente
Contact:

Post by Refalm »

Why didn't I think of that :?

Thanks Void Main...

I noticed that KDE has the same stuff as xf86cfg in their configuration panel :) at least that didn't bugged like hell

Tux
guru
guru
Posts: 689
Joined: Wed Jan 08, 2003 10:40 am

Post by Tux »

This is the way my system behaves, what you have to do is use one of the other virtual teminals.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I know it's a little late now but I have learned *long* ago that once you have a working XF86Config, back it up into a safe place, especially right before making a change to it. It has been a long time since I have have a non-working XF86Config during the installation process. This is a good one to keep in a safe place. Then when you come behind with these other tools and screw it up (always happens) you can just copy the good one over the bad one.

Master of Reality
guru
guru
Posts: 562
Joined: Thu Jan 09, 2003 8:25 pm

Post by Master of Reality »

Void Main wrote:You should be able to start it in single user mode which should not start X by passing a parameter to the kernel at the LILO prompt. In Red Hat and other distros just add the word "single" to the boot command line. I think it's the same for Slack... e.g. "LILO: linux single".

You could also boot from alternate media (such as Knoppix), mount the root partition and edit your XF86Config to repair it.
in addition to this you should be able to switch to a different console (ctrl+alt+F6) and use that console.

Post Reply