gnome file associations

Discuss Applications
Post Reply
dishawjp
administrator
administrator
Posts: 334
Joined: Thu Jan 23, 2003 9:05 am
Location: Central NY
Contact:

gnome file associations

Post by dishawjp »

Hi All,

I know that this is a stupid question, but I'm stumped.

I recently converted my court from Windows to Linux (FC1),and my clerk is no computer whiz... and that's being kind. Most of our records were MSWord or MSExcel format and OpenOffice has done a great job importing and converting them. My problem is that anything more than clicking on an icon is a bit more than my clerk can comfortably handle. By default, Gnome wants to open .xls files with Gnumeric. Right clicking on the icon gives an "open with...." dialog box that gives OOCalc as an option. I would like to change the default file association to OOCalc rather than Gnumeric.

I played around with it last night for a bit, but couldn't find a way to create a permanent file association between .xls files and OOCalc.

Thanks in advance for any help. I always have been a bit GUI-impaired which was one of the things that made me want to switch to Linux in the first place.

Jim Dishaw

Maniaman
scripter
scripter
Posts: 94
Joined: Tue Mar 11, 2003 5:10 pm

Post by Maniaman »

I'm at school right now on their Windows machines (:()
But isn't there an option on the Open With window that lets you select the default application to open it with? I could have sworn there was.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

I'm not at home right now either and I don't use a graphical file manager so I never run into that problem. I can check it out when I get home, but this looks promising in a worst case situation:

http://lists.debian.org/debian-openoffi ... 00021.html

dishawjp
administrator
administrator
Posts: 334
Joined: Thu Jan 23, 2003 9:05 am
Location: Central NY
Contact:

Post by dishawjp »

Maniaman,

There is an "open with..." tab when you right click, and OOCalc does show up as an option, but I don't see a way to set it as a default. You have to understand that Tina is a wonderful person, but she didn't even have any idea of how to copy files from the Windows computer hard drive to floppies so that I could transfer them to the new Linux box. Honest! Asking her to select the application to open files with is playing with fire and these are important records. Oh, to answer the question... yes, she is cute.

Void Main,

I followed the link you posted and checked out the
/usr/share/mime-info/gnome.mime file, but it has been deprecated and is being replaced with /usr/share/mime-info/gnome-vfs.mime.

I checked that one out and found lines like this one:
# OpenOffice 6.x document types
application/vnd.sun.xml.calc
ext: sxc
application/vnd.sun.xml.calc.template
ext: stc
application/vnd.sun.xml.draw
ext: sxd
So it looks like I could just just replace the ext: sxc with ext: xls and all .xls files would open with OOCalc.

Do you see any harm in trying this? Unfortunately, this particular computer isn't a toy and I really can't afford to break it. Especially after the hard time the Office of Court Administration gave me about installing Linux on "their" computer.

Thanks again for all your help!

Jim Dishaw

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main »

It's even easier than that. Click on your Red Hat menu, then click Preferences, then click "File Types and Programs" (or run the "gnome-file-types-properties" program). Expand the "Documents" tree, expand the "Spreadsheet" tree, double click the "Microsoft Excel spreadsheet", then click the "Default Action" box where you should have "OpenOffice.org" as one of the apps. Select it. Well, I don't know if it's easier. :)

dishawjp
administrator
administrator
Posts: 334
Joined: Thu Jan 23, 2003 9:05 am
Location: Central NY
Contact:

Post by dishawjp »

Doh!! (as Homer Simpson; my hero, role model and look-alike would say)

How much easier could it be! I must be the most GUI-challenged computer user in the world! I must have poked around the GUI interfaces for 15 minutes last night trying to find a way to do it, but never even thought to go to the main menu. I kept playing around with Nautilus and with right clicking on the icon. Guess I couldn't use modern Windows versions even if I wanted to. Just not smart enough :D

Thanks again all for the help!

Jim Dishaw

Post Reply