Help: Wrt54g V1.0 bricked

Place to discuss anything, almost. No politics, religion, Microsoft, or anything else that I (the nazi censor) deem inappropriate.
Post Reply
Posts: 1
Joined: Mon Jun 04, 2007 12:40 pm

Help: Wrt54g V1.0 bricked

Post by san9jay »

I Have a wrt54G V1.0 that was bricked when doing a reset.

I successfully reflashed using the tutorial (method 2 Grounding pin 16) with the WRT54G_2.02.2_US_code.bin firmware using TFTP.

After that I upgraded to the latest linksys firmware 4.30.5 using the linksys upgrade utility.

All was well at this point. I powered off and restarted the router and it was working fine.

I should have left it alone BUT I thought I would try the DD-WRT V23 firmware and upgraded the firmware using the web interface. The flash seemed to go ok and I got a success message but after that the router would not work. On power on the power LED and DIAG led would stay on and there was no traffic on the LAN port.

I cursed myself and opened up the box again tried the pin 16 to ground mechanism again and reflashed the WRT54G_2.02.2_US_code.bin again using TFTP.

Again TFTP said it was ok and immediately after the flash the diag LED went off but no traffic on the LAN port. I powered off and on and again the diag LED stays on all the time with no traffic on the LAN port.

I have repeated the flashing procedure many times even using the Linksys firmware upgrade utility directly. The flash seems to go ok but the router on power reset hangs with the diag led on all the time.

Looks like I did not follow the instructions of the DD-WRT install.

Apparently I was supposed to first install the minimal version and then upgrade to the standard version of DD-WRT .

On another forum a users says that not doing this could have caused the NVRAM to get corrupted.

My question is now that it is corrupt how can I recover the device.

I have already tried
1) "Hard reset (holding reset button for 30 secs while plugging in the power). that does not help
2) Going back to an older version of the Linksys firmware (tried 1.02 and 2.02 and 4.30. The firmware installs successfully over TFTP but the router hangs with a permanently lit diag light and no traffic on the LAN ports.



User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA

Post by Void Main »

Hmmm, if this doesn't work, and this doesn't help, and this doesn't help (hmmm, I see a lot of familiar text, images and body parts in that last one) then you might be at the next stage of needing a jtag connector. I do remember having one I thought was completely bricked and I think I ended up letting it run for about 30 minutes even though I thought it wasn't doing anything and eventually it just started working. I have no idea what happened there. So far I haven't bricked one I couldn't recover from without a jtag. I've never actually used a jtag before but I've thought about making one just to play with.

User avatar
Posts: 1349
Joined: Fri Jan 10, 2003 11:32 am
Location: Bonny Scotland

Post by Calum »

body parts! :shock:

Post Reply