fedora 9 upgrade problem

Place to discuss anything, almost. No politics, religion, Microsoft, or anything else that I (the nazi censor) deem inappropriate.
Post Reply
caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

fedora 9 upgrade problem

Post by caveman » Tue Jun 17, 2008 2:49 pm

Hi

weird problem - on Sunday I downloaded and upgraded my system.
Using synaptic - when the upgrade was done, some 16 packages all
failed with MD5 errors AND when I quit synaptic, the system was
completely bust. Would not even reboot.

So I reinstalled a fresh copy, set what I needed and redid the upgrades,
this time from a different mirror.
Boom - same problem with the MD5 errors and again the system is bust.
Redid a fresh install on my dev box, downloaded and installed the upgrades
and ditto - exactly the same problem.
Cannot even logout properly, network is down etc.etc.

So I'll have to rebuild the systems again.
Anybody ever had something like this happen?

Oh - and the logs show nothing that I can see - on both boxes.

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Tue Jun 17, 2008 5:59 pm

Let me see if I have this straight. You upgraded your system to Fedora 9 from CD and everything was fine but then you used synaptic to update it later and this problem occurred. Is this correct? Are you only updating from the Fedora 9 repositories or are you using 3rd party repositories. I assume you have verified that you were using Fedora 9 and not older versions of the repositories. Have you tried to update with yum?

caveman
programmer
programmer
Posts: 130
Joined: Sun Feb 09, 2003 1:08 pm
Location: Midrand Gauteng, South Africa

Post by caveman » Sat Jun 21, 2008 7:29 am

hi

yep - in short that is what happened
only it was not an upgrade but a fresh install
AND the 2nd time the machine actually booted but the X-server
wont start - used alt-ctrl-F1 to get to a login screen
(this took about 5 minutes!)


rebuilt the machine again and then used yum to do
the updates (3rd time)
checked the updates I kept from the previous install
against the newly downloaded files and they were the same
AND again the X-server only seems bust
the machine boots and I can get to a login screen as above
but it hangs when trying to use "startx" without any error messages
or any indication of what is wrong
yum had similiar errors re. the MD5 on the same set of files
It seems it updated parts - then stopped the remainder of the updates due to the MD5 errors
Starnge (sic)

As soon as I get time I'll try to install again
then using synaptic - exclude the files with the MD5 errors
and see what happens - this might then by default not try and update
some other files due to dependencies

Shall keep you informed

User avatar
Void Main
Site Admin
Site Admin
Posts: 5716
Joined: Wed Jan 08, 2003 5:24 am
Location: Tuxville, USA
Contact:

Post by Void Main » Sat Jun 21, 2008 7:34 am

I didn't even know synaptic was included in Fedora 9. That is some odd behavior for sure. I have never done a fresh install of 9, only one upgrade so far and that went smoothly. Are you sure the disks are good? Did you do a verify on them? If you are getting checksum errors it sounds like there is a problem with the disk burn.

Copperhead
scripter
scripter
Posts: 83
Joined: Wed May 14, 2003 1:12 am
Location: Los Angeles, CA, USA

Post by Copperhead » Sat Jun 28, 2008 12:46 pm

<edit>
Last edited by Copperhead on Sat Jun 28, 2008 12:47 pm, edited 1 time in total.

Copperhead
scripter
scripter
Posts: 83
Joined: Wed May 14, 2003 1:12 am
Location: Los Angeles, CA, USA

Post by Copperhead » Sat Jun 28, 2008 12:47 pm

If you could, please post the output of:

Code: Select all

apt-cache policy package_that_is_giving_you_problems.rpm
That is always a good step to start with dissecting issues with apt.

Post Reply